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1 Software Introduction 

1.1 Overview 

Houseplan 1.0 is a powerful, easy-to-learn, lightweight and compatible software that can create stunning 3D models and 

renderings efficiently. It not only supports generating 3D architectural entities with one click, but also offers more advanced tools 

that help to customize and refine your designs, as well as produce high-quality images and animations without any hassle. In addition 

to being of great help to architectural planning projects, it can also be used in various other industries that require 3D modelling and 

rendering. Its powerful modelling methods and real-time rendering engine, as well as the large amount of 3D model and texture 

resources, allow you to obtain the best work experience and high-quality results with lowest budgets. 

1.2 System requirements 

1.2.1 Hardware requirements 

 Minimum Recommended 

CPU Intel I5-6 processor Intel I5-9 and above 

Monitors 1440 x 900 true color display 1920 x 1080 or higher configuration 

Video Card Nvidia GTX1050Ti Nvidia GTX1660Ti or higher 

RAM 16GB 16GB or higher 

Hard Drive 4G 8G 

Others 
Mouse, trackball or another pointing 

device 
Mouse, trackball or another pointing device 

1.2.2 Software Configuration 

OS Win 7 (64-bit) / Win10 (64-bit) / Win 11(64-bit) 

1.3 Houseplan 1.0 Interface Overview 

The user interface consists of a quick access toolbar, ribbon, property palette, status bar, file tab, command line and workspace. 
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Quick Access Toolbar: Allows quick access to frequently used tools such as New, Open, Save, Save As, Undo, Redo, Layer 

Control, Element on/off and Layers. 

 

Ribbon: Displays task-based tools relevant to the current workspace that consists of nine tabs. Each tab consists of a series of 

panels of related functions. 

 

Property Palette: Displays the properties of selected object and can be modified. 
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Status Bar: It is composed by cursor coordinate position, tools that affect the drawing environment (Orthogonal, Polar Axis, 

Snap, Follow, and Reference), The units used by the current drawing, slider to adjust camera speed, view mode buttons (Isometric, 

Perspective), and effect switch buttons (Shadow, Anti-Aliasing, Light Projection). 

 

 

File Tab: Located above the command line, displays one or more opened files. 

 

Command Line: Shows the command prompt during the execution of a tool or command. 

 

Workspace: Displays visible area of current opened file. 
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2 Home Menu 

This chapter introduces basic features of Houseplan 1.0, such as creating and saving projects, parameter settings, drawing 

lines, planes, and volumes, designing building models, deconstructing interior structure, etc., allowing users to quickly create new 

projects and improve design efficiency. 

2.1 File Panel 

2.1.1 New 

Select "Home Tab > File Panel >  New" to create a new blank drawing. 

2.1.2 Open 

Select "Home Tab > File Panel >  Open" to open a file in *.cpi format. 

Note: Multiple documents can be opened at the same time, and you can switch between documents by Ctrl+ Tab, and copy 

(Ctrl+ C) and paste (Ctrl+ V) data between documents. 

2.1.3 Save 

Select "Home Tab > File Panel >  Save" to save the current file. 

Note: 

① Saved file is in *.cpi format. When saving an existing file, the original file will be saved as *.cpi.bak. If the original 

file is needed, remove the .bak suffix. 

② The default auto save interval is 30 minutes. Set the save interval and location in "Home Tab > Manage Panel > 

Settings > Auto Save". 

2.1.4 Save As 

Select "Home Tab > File Panel >  Save As" to save the current file as *.cpi format only. 

2.1.5 Save Selected 

Select "Home Tab > File Panel >  Save Selected" to select and save existing objects or elements on workspace as *.cpi 
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format. 

2.2 Manage Panel 

2.2.1 Properties 

Select "Home Tab > Manage Panel >  Properties" to close/open the property palette. 

 

2.2.2 Settings 

Allows to manage Houseplan 1.0 parameters regarding to command shortcut customization, workspace background color, 

auto save function, switch themes, Units Setup and reset to default option. 

Select "Home Tab > Manage Panel >  Settings" to open the following dialog box. 
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2.2.2.1 Simplify Commands 

Sets a key shortcut to quick access a command similar as command alias. Select "Home Tab > Manage Panel >  

Settings > Simplify Commands" to open the following dialog box. 

 

1. Enter a custom shortcut command in the "Simplify Command" column, and enter it on the command line when it is used. 

2. Click on the  button to save the simplified command. 
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3. Click on the  button to open a list of defined "simplify command" for easy access and modification. 

4. Update the simplified command list by clicking on the  button to import the simplified command list configuration file.  

5. Click the  button to select a storage location to export the current list of simplified commands as a configuration file. 

2.2.2.2 Set Background 

Sets the background color of the workspace in axonometric mode. Select "Home Tab > Manage Panel >   Settings > 

Set Background". Select the color, and click "OK" to apply the settings. 

 

2.2.2.3 Auto Save 

Sets the interval and save path for backup files to be saved automatically. Select "Home Tab > Manage Panel >  Settings > 

Auto Save" to bring up the following dialog box.  
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Enter or select the interval time and click the  button to set the save path; click the "Confirm" button to apply the settings.  

Note: The backup file format is *.cpi. 

2.2.2.4 Switch Theme 

Toggles the available skin or themes provided by Houseplan 1.0. Select "Home Tab > Manage Panel >  Settings > 

Switch Theme " to switch the theme. 

 

 

2.2.2.5 Units Setup 

Sets the drawing units for the current drawing. The common units in metric system are millimeters, centimeters, meters, and 

the common units in imperial system are inches, feet. 

Select " Home Tab > Manage Panel >  Settings > Units Setup", the dialog box will pop up, select the required units in 

the list and click "Confirm" button to activate the settings. 
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Notes:  

① The unit of the drawing is determined by the most 

recent setting. 

② The status bar will synchronously display the 

currently set unit. 

③ If you switch to a different unit method, the 

dimensions will be automatically converted to the 

current unit value. However, this does not apply to merged files or imported data such as tilt data, point cloud data, 

or manual data. 

④ When copying a scene to another scene, the unit of the selected scene will match that of the target scene, and related 

values will be automatically adjusted. 

2.2.2.6 Reset 

Select "Home Tab > Manage Panel >  Settings > Reset", to restore all settings in the software to the state they were in 

when the software was installed. 

2.3 Draw Panel 

2.3.1 Line 

2.3.1.1 Polyline 

Creates a polyline. Select "Home Tab > Draw Panel >  Line >  Polyline", there are two ways to draw. 

1. Direct draw a polyline 

(1) Draw a straight-line segment: After specifying the starting point, specify the next point, or continue specifying more 

points until the target position, and press Enter. 

(2) To draw a circular line segment: Type or input “A” and press Enter, specify the next point, or continue specifying 

more points until the target position, and press Enter. 

Note: The arc is tangent to the previous segment of the polyline.  

During the process of drawing a single line segment, straight lines and arcs can be drawn at any time by switching 

between the “L” and “A” keys. To close, enter “C” and press enter; to abandon the previous operation, enter “U” and press 

enter. 
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2. Drawing 3D polylines 

Type or input “S” to enter and specify the next point, or you can continue specifying the second and third points until the 

target position and press Enter. To close, enter “C” and press Enter; to abort the previous operation, enter “U” and press enter. 

Note: When drawing a three-dimensional polyline, 

open the "polar axis", as shown in the figure, so 

that you can snap to the auxiliary lines when 

drawing. 

2.3.1.2 Line Segment 

Creates line segments. Select "Home Tab > Draw Panel >  Line >  Line Segment", specify the start and end 

points, and generate a line segment. 

2.3.1.3 Arc 

Creates an arc. Select "Home Tab > Draw Panel >  Line >  Arc" and there are two ways to draw. 

1. Draws an arc by directly specifying three points. 

2. Enter or type “C” and press enter, draw the arc by the specified circle center. Specify the circle center, start point and end 

point to generate. 

2.3.1.4 Spline 

Creates a spline. Select the item "Home Tab > Draw Panel >  Line >  Spline" to draw a spline at the specified 

point. 

1. Draw an unclosed spline: Specify the starting point and endpoint tangents separately to generate the splines.  

2. Draw a closed spline: Enter or type “C” and specify the tangent direction. To abort the previous operation, type “U” and 

press enter. 

2.3.1.5 Circle 

Creates a circle. Select "Home Tab > Draw Panel >  Line >  Circle" to create a circle with the specified center 

and radius. 

2.3.1.6 Ellipse 
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Creates an ellipse. Select "Home Tab > Draw Panel >  Line >  Ellipse" to create an ellipse with the specified 

center and axis length. 

2.3.1.7 Regular Polygon 

Creates a regular polygon. Select "Home Tab > Draw Panel >   Line >  Regular Polygon", enter a value to 

determine the number of sides, and then start drawing. There are three ways to generate. 

1. Draws a square polygon internal to a circle: Specifying the center point and 

entering the radius generates a square polygon with the following effect. 

 

2. Draw a regular polygon based on the specified side lengths: Input or Enter “E” 

and press Enter to specify two points as the lengths of the sides of the regular 

polygon. 

 

3. To draw a square polygon tangent to a circle: Input or Enter “C”, specify 

the center point, enter the radius, and generate a square polygon with the 

following effect. 

2.3.1.8 Vertical Line 

Creates vertical lines. Select "Home Tab > Draw Panel >  Line > 

 Vertical Line", specify the first point, and use the normal direction to the plane of the point as the direction of the vertical line,  

and specify the second point or enter a value to determine the length of the vertical line. 

Note: If the specified point does not snap to a plane, the generated plumb line is perpendicular to the XOY plane.  

2.3.1.9 Spiral Line 

Creates spiral object. Select "Home Tab > Draw Panel >  Line >  Spiral Line". First specify the center of the 

bottom circle, then directly specify or enter a value to determine the bottom radius and top radius, then enter a value to determine 

the number of turns and equal degrees, and then directly specify or enter a value to determine the height to draw the spiral. 

Note: You can modify alias, layer color, bottom radius, top radius, tilt angle, number of spiral turns, helix height, floor elevation 

and other parameters in property palette. 
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2.3.1.10 Cloud Line 

Creates a cloud line. Select "Home Tab > Draw Panel >  Line >  Cloud Line", specify the starting point, and 

move the cursor to draw. There are three ways to draw. 

1. Direct drawing forward cloud lines. 

2. Enter or input “F” and press Enter to draw reverse cloud line. 

3. Enter or input “A” and press Enter to set the arc length. 

Note: You can modify alias, layer color, whether it is closed, and the floor elevation in property palette. 

2.3.2 Rectangle 

2.3.2.1 Rectangle 

Creates a rectangular plane. Select "Home Tab > Draw Panel >  Rectangle >  Rectangle" and specify two corner 

points to draw a rectangle. 

Note: You can modify alias, layer color, length, width, number of building floors, floor elevation and other parameter information 

in property palette. 

2.3.2.2 Polygon 

Creates a polygonal plane. Select "Home Tab > Draw Panel >  Rectangle >  Polygon", specify the starting point, 

and draw the polygon directly; or enter “S” to draw the polygon in 3D space. To abort the previous operation, type “U” and press 

enter. 

2.3.2.3 Spline Plane 

Creates a spline plane. Select "Home Tab > Draw Panel >  Rectangle >  Spline Plane", enter the plane width, and 

draw at the specified point. 

2.3.3 Box 

2.3.3.1 Box 

Creates a box. Select "Home Tab > Draw Panel >  Box >  Box", specify two corner points, and then specify or 

enter a value to determine the height. 
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2.3.3.2 Cylinder 

Creates a cylinder. Select "Home Tab > Draw Panel >  Box >  Cylinder", specify the center of the circle first, then 

specify or enter values to determine the radius and height respectively.  

2.3.3.3 Cone 

Creates a cone. Select "Home Tab > Draw Panel >  Box >  Cone" to specify the center of the base, and then 

specify or enter values to determine the base radius, top radius and height. 

2.3.3.4 Donut 

Creates a ring volume. Select "Home Tab > Draw Panel >  Box >  Donut ", specify the center of the circle first, 

then specify the radius and circle radius directly or enter a value. 

2.3.3.5 Pyramid 

Creates a prismatic cone. Select "Home Tab > Draw Panel >  Box >  Pyramid", first specify the center point, then 

enter a value to determine the number of sides of the base polygon of the pyramid, then directly specify or enter a value to determine 

the radius of the base external circle, the radius of the top external circle and the height.  

2.3.3.6 Sphere 

Creates a sphere. Select "Home Tab > Draw Panel >  Box >  Sphere" and specify the center of the sphere first, 

then specify the radius directly or enter a value to determine the radius. 

2.4 Building Panel 

2.4.1 Building Extrusion 

Extrudes planes, 3d solids, or surfaces of buildings to achieve building definitions or modifications of their shape. Select 

"Home Tab > Building Panel >  Building Extrusion" to extrude the building in the following two ways. 

1. Building Extrusion: Move the cursor to a plane to highlight it, then press and hold the left button to extrude or enter a value 

to determine the extrude distance. 
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(1) Select a plane and extrude (Y) (all entities 

move) or [click the entities on selected plane 

(stay) / extrude without entities move (N) / enter 

distance value]: 

 

 

(2) Select a plane and extrude (N) (no entity move) 

or [click the entities on selected plane (move) 

/ extrude with all entities move (Y) / enter 

distance value]: 

 

 

2. Standard Floor Extrusion:  

When the building is extruded upwards, if there is a plane object or 3D solid or volume that is less than 2 meters away from 

the building around the top floor of the building, then it will be copied out each floor as the building floor is extruded.  



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 15 of 241 

 

Note: 

⑤ The building must have at least one floor to take effect. 

⑥ Only supports the above-ground floors of the building. 

Building Properties: 

(1) Building name: Allows input a 

building name. 

(2) Building height: Automatically 

calculates the building height 

and it cannot be modified. 

Building height = difference 

between interior and exterior 

height + (floor height * number 

of floors) + height of roof 

components. When there is 

more than one roofing component, the higher one is counted in the building height. 

(3) Floor Properties: To set the properties of the floor, double click on the property palette or click on  button to open 

the dialog box shown below.  
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① Define floor: Click  button and select a floor in the list to bind interior elements to selected floors 

(should use “Show Floor” tool to hide the selected floor roof). You can select many floors, modify interior 

elements of one floor and others will change too. 

Note: 

① Hold down SHIFT or CTRL to select multiple floors. 

② After binding, different colors represent different standard floors. 

  



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 17 of 241 

 

 

 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 18 of 241 

 

② Separate floor: Click  button and select one or more floors in the list. When same interior elements are 

bonded to other floors, this tool helps disconnect the selected floor to others, when you modify the 

separated floor, others will be not changed. 

 

Modify the interior elements like furniture or walls in the selected floor. 
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Double-click other bonded floors to see the interior elements in place (no changed). 

 

③ Delete bonded Floor: Click  button and select a defined floor in the list to delete the specified floor in 

multiple instanced standard floor. 
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④ Floor Height: Displays the height of each floor, can be changed manually. 

⑤ Area: Displays the geometric area of the current floor. 

⑥ Factor: Affects the calculation of the area, converted according to the height of the floor. 

⑦ Capacity Factor: Affects the capacity area, counted by the height of the floor. 
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(4) Number of floors: The number of floors 

above and below ground can be modified 

and the building dynamically changes 

accordingly. 

(5) Indoor and outdoor height difference: The 

difference between the indoor and the 

outdoor floor on the ground floor, which is 

to shown when there is no above-ground 

floor. 

(6) Above-ground height of basement: The 

height of the basement above the ground; 

this item is not displayed when there is no basement. 

(7) Base area: The software calculates the base area based on the building outline and cannot be modified. 

(8) Apron: Floor lines can be turned on and off. 

(9) Elevation: Reads the building's z coordinate in the scene; can be modified manually. 

Note: 

① Extruding planes and volumes automatically generates buildings with the corresponding number of floors according 

to the default floor height. 

② The data in the property palette updates in real time during extrusion.  

2.4.2 Cross-section Extrusion 

Extrudes a plane into a volume or 3D solid. Select "Home Tab > Building Panel >  Cross-section Extrusion", move the 

cursor to the plane, hold down the left button to extrude or enter a distance. There are two types of extrusion. 

1. Extruding directly with any plane edges as boundary. 

2. Type “S” and press Enter to extrude with the outermost edges of a plane as the boundary when lines or edges split the plane. 

Note: 

① When no boundary is specified, the edges of a plane or volume, or other lines on the plane, "splits" a plane into 

several areas, and the cursor will snap to one of the individual areas, extruding it into a volume; when the entity 

boundary is specified, the edges outside the selected entity will no longer "split" the entity interval. 
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② When cross-section extrusion is performed on a volume, the newly generated volume is integral to the original entity, 

which is a local extrusion and transformation of the original entity. Whereas lines or planes on the volume are used 

to divide a given plane into parts and act as auxiliary lines. 

 

③ As shown below, it is convenient to extrude section planes on a building.  
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2.4.3 Building Gallery 

Houseplan 1.0 provides a wide range of building base outlines and enables the organization of building assets by adding, 

deleting and modifying operations on the building gallery, providing easy access to design projects. 

Select "Home Tab > Building Panel >  Building Gallery" to open the following dialog box.  
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1. Applying the gallery: Drag the building outline directly into workspace. 

 

2. New: Right-click on a blank space in the gallery list to create a new gallery. 

3. Edit the gallery: Right-click on the gallery name to show the context menu, as shown above. 

(1) Delete: Removes the selected gallery title from the list. 

(2) Clear: Removes all building outlines in the selected gallery title. 

(3) Rename: Changes the name of the selected gallery title. 

(4) Import DWG: Building outlines can be imported into the gallery by selecting the "Import DWG" command, which 

brings up the dialog box shown below. 

① Enter directly or click on the  

button to select the folder where the 

drawings need to be imported. 

② Enter the balcony layer name at 

Specify Balcony Layer Name, and the 

entities for the other layers default to 

the building outline. 
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Note: 

① The imported drawing must be 

closed lines, and the layers need to 

be regularized. 

② The building outline imported by 

the user should be a dwg format file 

and the drawing units should be in 

meters. 

 

 

(5) Export Resource, Import Resource. 

① Exports the building outline drawings under this category, as well as the *.bmp and *.ini files generated from 

the *.dwg drawings of the building outline, as compressed files in *.zip format.  

② Imports the exported *.zip file into the gallery. 
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Note: When importing, the user will be prompted whether to import by appending, select "Yes" to keep the existing outline 

drawings under the category, and import all the drawings in *.zip into the gallery, and replace the files with the same 

name directly; select "No" to delete the existing outline drawings under the category, and import the building outline in 

*.zip.  

4. Delete: Right-click on the building outline to delete. 

5. Building planar attributes: Building outline dimensions and its single layer area, and household type, can facilitate statistical 

analysis. 

(1) Area: the area of the building base. 

(2) Outline: the length and width of the 

building outline. 

Note: 

① The area does not include the base 

area of the balcony. 

② After the building is extruded, the 

software automatically calculates the 

number of households that come with the building as well as the household type information.  
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2.4.4 Balcony 

Inserts preset or custom balconies on buildings. Select "Home Tab > Building Panel >  Balcony" to open the following 

dialog box. 

 

1. Types of balconies: Convex, concave and concave-convex. 

2. There are two ways to define a convex balcony: 

(1) Mode: Inserts balconies according to the 

parameters set. 

(2) Custom: Defines the balcony based on 

the outline of an existing plane. 

3. You can manually set width, deep, thickness and 

height of selected balcony type. 

4. Insertion method: 

(1) Single: Inserts one balcony at a time. 
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(2) Column: Generates a balcony on the selected floor, as well as on each floor above it. 

(3) Middle: Automatically snaps the middle point of a building plane edge. 
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5. Direct insertion: Select the balcony type, set the size, select your insertion method, then click "Insert" button. After selecting 

the above-ground floor of the building, specifying the edge and entering the distance, the balcony will be inserted 

successfully. 

6. Custom insertion: Select the convex balcony, switch to the "Custom" tab, set the size, select your insertion method, click 

"OK" button. After selecting a horizontal plane (planes that are not surfaces buildings) without holes, and selecting the 

above-ground floor of the building, the balcony will be inserted.  

Note: 

① When inserting a balcony, Houseplan 1.0 automatic generates water apron on first floor balconies. 

② Inserting preset balconies will automatically corner when they encounter building angles.  

③ When defining a convex balcony, if the original position insertion method is not checked, the edge closer to the point 

where the cursor is clicked on the plane that you selected will be highlighted in red, and this edge will be specified 

as the insertion edge. 

④ After inserting a balcony its properties can be modified in the property palette. 

⑤ Snapping building plane edge activates auxiliary lines when inserting balconies to facilitate precise insertion. 

2.4.5 Window 

Inserts preset or custom windows on buildings. Select "Home Tab > Building Panel >  Window" to open the dialog box 
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shown below. 

 

1. Types of window: Flat, bulge and bay window. 

2. There are two ways to define a flat window: 

(1) Mode: Inserts windows according 

to the parameters set. 

(2) Custom: Defines the window 

based on the outline of an existing 

plane. 
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3. You can manually set width, deep, thickness and height of selected window type.  

4. Insertion method: 

(1) Single: Inserts one window at a time. 
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(2) Column: Generates a window on the selected floor, as well as on each floor above it. 

(3) Middle: Automatically snaps the middle point of a building plane edge. 

 

5. Direct insertion: Select the window type, set the size, select your insertion method, then click "Insert" button. After selecting 

the above-ground floor of the building, specifying the edge and entering the distance, the window will be inserted 

successfully. 

6. Custom insertion: Select the flat window, switch to the "Custom" tab, set the size, select your insertion method, click "OK" 

button. After selecting a horizontal plane, planes that are not surfaces of buildings without holes, and selecting the above-

ground floor of the building, the window will be inserted.  

Note: 

① When customizing a flat or convex window, the window directly generates at the location of the plane if the plane is 

on a building wall. 

② Inserting preset windows will automatically corner when they encounter architectural angles. 

③ When defining a bay window, if the original position insertion method is not checked, the edge closer to the point 

where the cursor is clicked on the plane that you selected will be highlighted in red, and this edge will be specified 
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as the insertion edge. 

2.4.6 Door 

Inserts preset or custom doors on the building. Select "Home Tab > Building Panel >  Door" to open the dialog box 

shown below. 

 

1. There are two ways to define a door: 

(1) Mode: Inserts doors according to the parameters set. 

(2) Custom: Defines the door based on the outline of an existing plane. 

2. You can manually set width, deep, thickness and height of selected door type. 

3. Insertion method: 

(1) Single: Inserts one door at a time. 
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(2) Column: Generates a door on the selected floor, as well as on each floor above it. 

(3) Middle: Automatically snaps the middle point of a building plane edge. 

 

4. Direct insertion: Select the door type, set the size, select your insertion method, then click "Insert" button. After selecting 

the above-ground floor of the building, specifying the edge and entering the distance, the door will be inserted successfully. 

5. Custom insertion: Select the door, switch to the "Custom" tab, set the size, select your insertion method, click "OK" button. 

After selecting a horizontal plane (planes that are not surfaces buildings) without holes, and selecting the above-ground 

floor of the building, the door will be inserted.  

Note: 
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① Inserting or drawing preset doors will automatically corner when they encounter architectural angles.  

② When a building has a basement level, the insertion of doors is done separately above and below ground.  

③ When insert a door, the edge closer to the cursor click point, when the plane is selected are highlighted in red, and 

this edge is used as the insertion edge. 

2.4.7 Rooftop 

2.4.7.1 Crenelated Parapet Wall 

A crenelated parapet wall is a low wall around the roof of a building that serves as a protection.  Select "Home Tab > Building 

Panel >  Rooftop >  Crenelated Parapet Wall" and enter a value to determine the height of the crenelated parapet wall. 

 

Note: 

① Crenelated parapet wall is counted towards building height, building height = indoor and outdoor height difference 

+ (floor height * number of floors) + height of crenelated parapet walls. 

② When painting the material, the crenelated parapet wall and the main volume of the building are painted separately, 

and when painting the crenelated parapet wall, a single-sided painting method is available. 

2.4.7.2 Flat Rooftop 

A flat roof is a type of exterior roof form with a gentle roof that can be made into a terrace, roof garden, etc. 

This feature is used to add a flat roof to a building. Select "Home Tab > Building Panel >  Rooftop >  Flat Rooftop" 

and select the top plane of the building to create. 
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Note: 

① Flat roofs do not count towards building height.  

② The property palette allows you to modify the flood height, elevation angle, thickness, eave length and extension type. 

2.4.7.3 Sloped Rooftop 

The sloped roof is automatically generated based on the outline of the building roof and the parameters set.  Select "Home 

Tab > Building Panel >  Rooftop >  Sloped Rooftop" to open the dialog box. 

 

1. Full slope: Automatically generates a full slope roof based on the outline of the roof. After setting the slope and eaves, click 

on the "Confirm" button and select the top plane of the building to generate it. 
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2. Double slope: Generate a sloped roof with two slopes. After setting the slope and eaves, click on the "Confirm" button and 

there are two ways of generating them. 

(1) Generate gable: Select a single vertical plane of a building to generate a gable. 

(2) Generate multiple gables: Enter “D” and press enter, select a building vertical plane, and all vertical planes in the 

same direction as that plane will generate a gable. 

 

3. Four slope: Generate a four-slope roof. After setting the slope and eaves, click on the "Confirm" button. 
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4. Arc top: Creates a curved roof. After setting the slope and eaves, click on the "Confirm" button. 

 

5. Description of full sloped roof parameters: Once a sloped roof is selected, its properties can be viewed in the property 

palette as shown below. 
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(1) Hanging board height: Sets the height 

of the hanging board. 

(2) Extension panel type: Switch between 

flat wall and adjoining balcony. 

(3) Flat top height: Enter a value to make 

the roof flatten from the top. 

(4) Detailed parameter: To modify the 

slope and eaves of a sloped roof, 

double-click directly on the roof or 

click on the  button of detailed parameter to open the dialog box shown below. 

 

Click the "Slope" or "Eave" to change its value. Click "Confirm" button to regenerate the roof according to the new 

parameters. 

(5) Hanging board enclosure: Set whether the hanging board is closed or not. 

Note: 

① Created full-slope roofs cannot switch styles on property palette. 

② After changing the flat roof height, roof cannot be arched. 

③ Arch roof does not support closed hanging board. 
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④ When modifying the detailed parameters, a gable may be generated if the slope is changed to 90 degrees.  

⑤ Sloped roofs count towards building height. Building height = difference between interior and exterior heights + 

(floor height * number of floors) + half of the roof height of the sloped roof. 

6. Description of Arc roof parameters: Once an arc roof is selected, its properties can be viewed in the property palette as 

shown below. 

(1) Hanging board height: Set the height of 

the hanging board. 

(2) Style: Switch between double slope, four 

slope and arc top. 

(3) Slope gradient: Enter a value to make the 

arc of the roof increase or decrease its 

radius. 

(4) Eaves length: Enter a value to increase 

eaves length of arc roof. 

(5) Hanging board enclosure: Set whether the hanging board is closed or not. 

7. Description of Double slope roof parameters: Once a double slope roof is selected, its properties can be viewed in the 

property palette as shown below. 

(1) Hanging board height: Set the height of 

the hanging board. 

(2) Style: Switch between double slope, 

four slope and arc top. 

(3) Flat top height: Enter a value to make the 

roof flatten from the top. 

(4) Turn rooftop into arc: Click the  

button on the property palette to open 

the dialog box shown below, set the 

arcing parameters and then click the "Confirm" button to arc the roof. 
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(5) Detailed parameter: Modify the slope and eaves of a sloped roof. 

(6) Hanging board enclosure: Set whether the hanging board is closed or not. 

2.4.7.4 Dormer Window 

Inserts a dormer window on the sloped roof. Select "Home Tab > Building Panel > Rooftop >  Dormer Window" to 

open the dialog box shown below. Select the dormer window and specify the location on the sloped roof to insert it. 
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Note: 

① Curved roofs and sloped roofs that are arched do not support the insertion of dormer windows. 

② You can modify dormer window properties directly on the property palette. 

2.4.8 Awning 

Inserts an awning on the building according to the set parameters. Select "Home Tab > Building Panel >  Awning" to 

open the following dialog box. 

1. There are two ways to define an 

awning: 

(1) Mode: Inserts awnings 

according to the parameters 

set. 

(2) Custom: Defines the awning 

based on the outline of an 

existing plane. 

2. You can manually set width, deep, thickness and height of selected awning type.  

3. Insertion method: 

(1) Single: Inserts one awning at a time. 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 43 of 241 

 

(2) Column: Generates an awning on the selected floor, as well as on each floor above it. 

(3) Middle: Automatically snaps the middle point of a building plane edge. 
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4. Direct insertion: Select the awning type, set the size, select your insertion method, then click "Insert" button. After selecting 

the above-ground floor of the building, specifying the edge and entering the distance, the awning will be inserted 

successfully. 

5. Custom insertion: Select the awning, switch to the "Custom" tab, set the size, select your insertion method, click "OK" button. 

After selecting a horizontal plane (planes that are not surfaces buildings) without holes, and selecting the above-ground 

floor of the building, the awning will be inserted. 

Note: 

① Automatic cornering of inserted awnings when they encounter building angles. 

② You can modify an awning’s properties directly on the property palette. 

2.4.9 Outdoor Stairs 

Inserts outdoor stairs on the building according to the set parameters. Select "Home Tab > Building Panel >  Outdoor 

Stairs" to open the following dialog box. 

 

1. There are two ways to generate it: 

(1) Insert: Insert the stairs directly according to the set parameters. Click on the "Insert" button, select the upper floor of 

the building and insert it by specifying the location directly or by obtaining a positioning edge and entering the 

distance. 
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(2) Custom: Define the stairs based on existing planes. By clicking on the "Custom" button, two types of insertion are 

possible. 

① Insert with the wall: Select a rectangular plane, then select the upper floor of the building, and directly 

specify or obtain the positioning edge line and enter the distance to insert. 

② Insert in original position: Enter “Y” and press Enter, then select a rectangular plane, click a surface of the 

above-ground floor of the building, then you can insert the outdoor stairs by using the position of the 

rectangular plane as a reference. 

2. Parameter Note: 

(1) Direction: Setting the running direction of the stairs: clockwise and counterclockwise.  

(2) Top cover: Setting stairs with or without topping. 

(3) Top rooftop: Whether the stairs reach the roof. 

(4) Run to the accompanying wall: Whether the handrail on one side of the stairs is against the wall. 

(5) Middle: Automatically snaps the middle point of a building plane edge. 

(6) Railings: Sets the height of the railings. 

Note: 

① Automatic generation of aprons for outdoor stairs. 

② You can modify stair properties directly on the property palette. 

2.4.10 Glass Curtain Wall 

Defines or draw a glass curtain wall on a building wall. Select "Home Tab > Building Panel >  Glass Curtain Wall" to 

open the following dialog box.  
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After selecting a curtain wall type and set its parameters. There are four ways to generate a glass curtain wall. 

1. Define the glass curtain wall according to the wall or plane of the building. Click on the  button, the select a building 

wall to generate glass curtain wall. 
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2. Generate a glass curtain wall on all walls of the building. Generate by clicking on the  button and selecting the building 

with above-ground floors. 

 

3. Draw the glass curtain wall on the building wall according to the width. Click on the  button, place the cursor over a 

building wall and specify three points to finish the operation. To draw through other building walls, enter “C” and press 

ENTER. 

 

4. Draw polygonal glass curtain wall on the building wall. Click on the  button to draw the glass curtain wall as a polygon. 
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Note: The property palette can adjust the border width, border depth, unit width and unit height. 

2.4.11 Building Attachments 

Attachments are decorations that are placed outside of buildings walls. Select "Home Tab > Building Panel >  Draw 

Attachments" to open the dialog box shown below. 
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1. Insertion method: 

(1) Single: Drawing one attachment at a time. 

(2) Column: Generates one attachment for each floor in the selected floor and above. 

2. There are two ways to generate it. 

(1) Generate attachments based on existing cross-sections: 

① Click "Stratum" button, select the upper floor of the building, snap and get the positioning edge line, input 

distance and specify orientation to generate the attachment. 

 

② Click "Along edge" button, select the edge of the 

building or building wall, left-click to end the 

drawing and specify the orientation. 

③ Click the "Draw" button, select the edge of the 

building or building wall, left-click to end the 

drawing and specify the orientation. 

(2) Generate attachment according to custom cross-section: 

Take "stratum" as an example, click the "stratum" button, 

select a plane or line, select one side of the plane or line 

as baseline and specify insertion base point. You need to 

select the above-ground floors of the building to determine where to add the attachment, then select the red path or 

input distance to specify a path, and finally specify the orientation of the section to generate it. 
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3. Interrupt: Click "Interrupt" button and specify two points on the attachment to break. 

 

Note: 

① You can change attachment object on the properties palette.  

② Only the parameters of "W”, “H" can be modified in the cross-section style. 

③ When customizing the section, the attachment is drawn as solid if a plane is selected, or hollow if a closed line is 

selected. 

2.4.12 Move Components 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 51 of 241 

Changes the position of components like windows, doors, awnings and stairs on the building. Select "Home Tab > Building 

Panel >  Move Components", select the component and press Enter, then drag the mouse or enter the distance from the 

specified base point to move them. 

 

Note: 

① Moving elements supports the selection of balconies, windows, doors, awnings, outdoor stairs, steps along the line 

and area layering. 

② When specifying the base point, the component shall be specified on the building's vertical plane.  

③ When moving a component, the component moves along the side vertical plane of the building.  

2.4.13 Show Floors 

Hides or unhides a selected building floor. Select "Home Tab > Building Panel >  Show Floors" to select a floor, and 

the floors above that selected floor will be hidden, showing the interior structure and making it easy to see the building's interior 

layout. Click on the building again to restore the building to its original state. 
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2.4.14 Draw Wall 

Draws interior walls inside a building. Select "Home Tab > Building Panel >  Draw Wall" to open the following dialog 

box. 
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1. Draw Walls: After setting the parameters in the dialog box, select Straight Wall, Curved Wall or Rectangular Wall, and specify 

start and end points. You can switch the wall type in the command line prompt. You can draw continuously, enter “U” to go 

back to the previous step, and right-click to end the drawing. 

2. Parameter description: The wall has three directions: left, middle and right. Wall thickness, wall height and elevation can be 

set. 

Note: 

① Check the "Elevation" box to specified height as wall elevation, otherwise use the default height as the wall elevation. 

② You can modify wall properties on the property palette. 

③ Drawn walls have pinch points that can be dragged directly and merge intersection points.  

④ Command line allows drawing wall continuously, right-click to end to continue drawing, right-click again to end 

drawing, press Escape keyboard to exit drawing. 

⑤ Changing parameters while drawing can be continue the drawing with the new parameters. 

⑥ The next time you open the dialog box the last set wall direction and parameters are remembered.  

2.4.15 Floor Hole 

Draws hollow areas on selected building floor. Select "Home Tab > Building Panel >  Floor Hole" to open the following 

box. 
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1. Draw: After setting the parameters, click the "Draw" button, and draw directly at the specified point on the floor. You can 

draw continuously, enter U to go back to the previous step, and right-click to end drawing. 

2. Definition: Select objects such as planes, closed lines, and spline planes to generate. 

Note: 

① Holes are sub-entities of buildings and railings are sub-entities of holes; railings change as the shape of the hole 

changes. 

② The instances between each layer of railings are changed together: editing one floor changes all other floors; however, 

one floor can be deleted individually without affecting the other floors. 

2.4.16 Draw Railings 

Draws railings on specific entity. Select "Home Tab > Building Panel >  Draw Railings" to open the dialog box shown 

below. 
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1. Draw along edge: Specify start and end points on the edge of an existing floor hole or the edge of staircase. 

 

2. Free drawing: Specify any point inside the building to draw. Continuous drawing: enter U to go back to the previous step 
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and right click to end the drawing. 

 

3. Define rail: Select a line or plane and right click to convert the selected line entity or plane to a railing. 

 

Note: 

① Starting and ending floors are invalid for railings drawn on the exterior of a building.  

② The direction of the railing distance from the edge: can automatically determine the boundary of the staircase or hole 

to offset the railing inwards; cannot determine the boundary of the original position drawn without offsetting.  

③ You can modify railing properties on property palette. 

2.4.17 Stairs 

2.4.17.1 Stairs 
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Select "Home Tab > Building Panel >  Stairs >  Stairs " to open the dialog box shown below. 

 

1. Draw to match: Adapts the length and width of existing stair openings by drawing a rectangle. 
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2. Select to match: The length and width of the stairway opening can be adapted by selecting a rectangular plane. 

 

3. Insert staircase: Specifies an insertion point to insert the staircase into workspace. 

 

4. Rotate 90 degrees clockwise, 90 degrees counterclockwise, 180 degrees: Rotates the stairs on workspace and adapt the 

bounding box length and width. 

5. Flip left/right, flip front/back: Mirrors the stairs and adapts the bounding box length and width. 

6. Stair queues: Replicates the array of stairs, starting from the selected stair location level going upward. 
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7. Parameter Note: 

(1) Height: Automatically match the floor height when placed, or floor height can be entered manually. 

(2) Length: Specify two points as the total length of the stairs. 

(3) Width: Specify two points as the total width of the stairs. 

Note: 

① If stair is placed inside the building, the stair height automatically matches the floor height; if  it is placed outside the 

building, the height is the original dimension. 

② Double-click on the stair pattern or drag the stair into workspace to insert it. 

③ The leather band also attaches to walls (interior and exterior) when moving, copying and scaling stairs. 

④ You can modify stairs properties on the property palette. 

2.4.17.2 Draw Stairs 

Draws a single staircase. Select "Home Tab > Building Panel >  Stairs >  Draw Stairs" to open the dialog box. 
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1. Draw: Draws the stairs according to the set parameters. Click on the "Draw" button and there are two ways to generate it.  

 

(1) First specify the starting point to determine the location of the stair segment, followed by specifying length and 

direction of the stair. 

(2) Select the stair width line, enter “S” and press Enter, select the line or the edge of the plane, and specify length and 

direction of the stairs. 

2. Define: Selects two lines to define the stairs. Click the "Define" button and select one of the lines as start of the staircase, 

then select the other side line to create stairs. 
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3. Parameter Note: 

(1) Click on the word "Height of flight" in blue to specify two points as stair heights.  

(2) Click on "Starting height" in blue to designate a point as the floor elevation of the staircase. 

(3) Click on "Step width" in blue to specify two points as the width of the step. 

(4) Stair railings are generated in four ways: on both sides, on the left, on the right and none. 

(5) Trend: Stairs can be going either up or down. 

Note: 

① Check the checkbox before "Starting height" to use the entered or specified height as the floor elevation of the stair, 

otherwise use the captured height as the floor elevation of the section. 

② Step width and step height are preceded by radio boxes. If one is checked, the other parameter will be greyed out. 

③ You can modify stairs properties on property palette. 

2.4.18 Furniture Gallery 

Adds furniture entities such as sofas, beds, and tables into buildings. Select "Home Tab > Building Panel >  Furniture 

Gallery", and the following dialogue will pop up. 
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1. Apply: Double-click or directly drag the furniture preview in the gallery to place at specified position. 

 

Note: Previews that appear in grey in the gallery will automatically download if clicked. They can be placed on building 
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floors only after the download is complete. 

2. Edit the entity library list: right-click the furniture gallery list. 

(1) New: Creates a new furniture gallery. 

(2) Delete: Deletes the newly created furniture gallery. 

(3) Clear: Clears all newly added furniture entities in the selected gallery.  

(4) Edit: Renames the newly created furniture gallery. 

(5) Import: Selects a folder and import the model files within. 

3. Edit furniture gallery: 

(1) Add Object: Right-click on a blank space in the furniture gallery, click "Add Object", and select an entity in the scene 

to add. 

(2) Add File: Right-click on a blank space in the furniture gallery, click "Add File", and select any *.cpi, *.fbx, *.skp, 

*.osgb, *.osg, *.obj, *.rvt, *.3ds format file in the pop-up dialog box to add the model files. 

(3) Delete model: Right-click on a preview image, click "Delete" to delete the newly added model. 

2.5 3D Operations Panel 

2.5.1 Move 

Moves selected entity according to X, Y, Z axes. Select "Home Tab > 3D Operations Panel >  Move", select entities 

other than roads, right-click to end the selection. Place the cursor on the axis, select axial direction, axial plane or axis center, drag 

or enter a value to determine the displacement distance.  
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Note: 

① Roads cannot be displaced using spatial displacement, which is achieved by using the “M” move command. 

② Default to local axes, which can be switched to global axes by entering “S” and press Enter on the command line. 

③ When the axis is selected, the entity can be moved in any direction. 

④ The default axis is at the center of the selected entity, and the axis position can be reassigned.  

2.5.2 3D Rotate 

Rotates selected entity according to X, Y, Z axes. Select "Home Tab > 3D Operations Panel >  3D Rotate". 

Note: 
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① The default axes can be switched to 

global axes by entering “S” and 

press Enter on the command line. 

② 3D rotation supports the selection of 

entities other than single-sided 

planes, building components, and 

animation paths. 

③ Some entities support Z-axis rotation 

only, except for lines, planes and 

volumes. 

④ Can be rotated at any angle when cursor is placed on the inner circle of the axis; when placed on the outer circle of 

the axis, it is rotated according to the screen plane. 

⑤ The default axis is at the center of the selected entity, and the axis position can be reassigned.  

2.5.3 3D Scale 

Scales selected entity in space according to axes. Select "Home Tab > 3D Operations panel >  3D Scale". 

Note: 

① Default to local axes, which can be switched to global axes by entering S and press Enter on the command line. 

② 3D scaling supports the selection of 

planes, bodies, background entities, 

vegetation entities, skeletal 

animations and free-form modeled 

entities. 

③ If the cursor is placed at the center of 

the XYZ axis, all objects can be 

scaled as whole. 

④ The default axis is at the center of the 

selected entity, and the axis position 

can be reassigned.  
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3 Insert Menu 

This chapter introduces the import and management of project underlay and data, as well as the project publishing and 

exporting functions, which assist in creating a detailed and realistic rendering effect.  

3.1 Import Panel 

3.1.1 DWG Underlay 

Imports DWG or DXF files to be used as 

drawing underlay for project design. Select "Insert 

Tab > Import Panel >  DWG Underlay" to 

open its dialog box. 

1. Select: Click on the  button and 

select a DWG or DXF file to be imported. 

2. Result validity range: Automatically 

calculates and displays the size range of 

all objects in the inserted drawing as a 

whole image. 
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3. Units used on original drawing: Automatically 

identify the unit of the imported drawing, which 

cannot be directly modified. If you want to modify, 

you need to click the “Rescale” button to activate the 

unit drop-down list, and then you can adjust the unit. 

4. Content within view only: When checking this option, 

only the objects that are visible in the workspace 

when you save the DWG drawing will be imported, 

otherwise, every object in the drawing will be 

imported. 

5. Original height: Check this option to import 

according to the original height of objects drawn in 

the CAD drawing. 

6. Do not import blocks: Block entities in CAD drawings will not be imported. 

7. Do not import invisible entities: Entities that are frozen, closed, or on locked layers will not be imported. 

8. After setting the parameters, click the "Next" button and the following dialog box will pop up.  
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(1) Checkbox: You can check the drawing layers to be imported into workspace. Objects belonging to imported layers 

are visible and ready to be edited. If you uncheck drawing layers, objects are visible and dimmed in the workspace, 

those objects cannot be modified because they are locked. 

 

(2) Import type:  imports objects that belong to a layer as polylines,  imports objects as planes or 2D surfaces. 

Click the icon to switch between them, double click the icon to select all layers at once. Click the "Next" button to 

start importing. 

 

Note: DWG supports versions 2002-2021. 

3.1.2 DWG Layer Management 

Manages imported DWG/DXF drawing layers. You can set storage, snap and hidden states of drawing layers that are currently 
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turned off (not editable) and convert them into editable ones in workspace. 

Select "Insert Tab > Import Panel >  DWG Layer Management" 

 

1. Underlay layers: Displays the name, storage, snap and hidden status of imported DWG file. 

(1) Storage: Sets whether the underlay layers can be saved. 

(2) Snap: Sets whether the underlay layers can be snap. 

(3) Hide: Sets whether the underlay layers can be displayed. 

Note: Double click any checkbox to select the corresponding column at once. 

2. Underlay layer check box: Check a layer name to make it visible in workspace but not editable. 
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3. Convert to editable layer: Check a layer name in the list to later convert into not editable. 

4. Click  button to start layer conversion. Check the layer name whether is located (Underlay layer or Convert to 

editable layer list), in the conversion process, click the button again to abort. 

 

5. Click  button to move objects belonging to a selected layer to specific position in workspace. 

6. Click  button to delete all DWG layers keeping the editable layers visible in workspace. 

7. Click  button (it is recommended to uncheck all underlay layers to see the selection effect), select any object in 

the workspace, the corresponding layer will be located and selected in the dialog box.  

3.1.3 Merge Projects 

Merges other *.cpi files into current project. Select the "Insert Tab > Import Panel >  Merge Projects" to open the 

following dialog box. 

 

Click the  button and select the CPI file to be merged. 

Original coordinate: Inserts the file according to original coordinates stored. 

Specify coordinate: Inserts the file according to the specified coordinates. 
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3.1.4 Other Formats 

Inserts files in different formats into Houseplan 1.0 to be used as design references. 

Select "Insert Tab > Import Panel >  Other Formats" to open the dialog box shown below. 

 

1. Select *.jpg, *.bmp, *.png type files, and specify the insertion location. 

2. Select *.fbx file, there are two ways to insert them; Insert at specified position or Type Y to insert by original coordinates. 

3. Select *.osgb, *.osg, *.obj, *.3ds type files, , click the "Open" button to open the dialog box shown below. 

 

(1) Scene Units: Display the current drawing units. 

(2) File Units: Set the units of the drawing to be imported. 

4. Select *.skp file, click the "Open" button to open the dialog box shown below. 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 72 of 241 

(1) Import hidden objects: The option is 

checked by default, hidden components will 

be created and imported; if unchecked, 

hidden components will not be imported. 

(2) Import the two-sided model: If checked, the 

front and back sides of the skp model will be 

created and imported; if unchecked, only one 

side of the skp model will be analyzed, 

created and imported. 

(3) Import Edges/Profiles: If checked, the edges and profiles of the skp model will be created and imported; if unchecked, 

the edges and profiles will not be imported. 

5. Select *.rvt file, and click "Open" button to import it. 

 

6. Select *.tif file, click "Open" button, and follow the command line prompts to enter a value to determine the rendering level 

to complete the TIF import. 
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7. Select *.dem file and click "Open" button to import it. 

Note: 

① The imported osgb data is model data. To import oblique photography data, please use the "Oblique Photography" 

function. 

② Import version description: SketchUp supports up to version 2022; fbx format supports up to version 2020. 

③ For the first import of the rvt format model, you need to be in a networked state and apply for permission from the 

server. 

④ The tif file is imported with the mapping render level, the smaller the value, the clearer the mapping; the larger the 

value, the blurrier the mapping. 

⑤ DEM is digital elevation model, which enable the digital simulation of ground terrain from limited terrain elevation 

data. 

3.2 Imagery Panel 

3.2.1 Oblique Photograph 

Imports oblique photography data or merge it into the current project. Select "Insert Tab > Imagery Panel >  Oblique 

Photograph" to open the dialog box shown below. 

1. Import: Right-click on the blank space to 

open the context menu, click "Import" to 

open the dialog box shown below. Click 

the  button to select the oblique 

photography file, click the "Original 

coordinate" button to import the scene 

according to the in-situ coordinates; click 

the "Specify Coordinate" button to import 

the scene according to the specified 

coordinates. 

2. Right-click on the layer node name to open the context menu, as shown above. 

(1) Rename: Change the name of the project. 
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Note: Naming rules: after 

importing, all data are added 

the "skew data" prefix, 

followed by sorting numbers, 

from 1, 2, ... The name in 

brackets reads the name of 

the oblique photography 

folder, and the name cannot 

be changed. 

(2) Delete: Delete the imported 

oblique data and retain the source files. 

(3) Positioning: Click "Positioning" to locate this oblique data in the scene. 

Note: 

① Only oblique photography project data of osgb files with the same name as the sub files under the path is 

supported (eg:Tile_1 /Tile_1.osgb). 

② After importing a project, you need to specify a new path when the path is invalid. When it is invalid, the path 

location is displayed in blue. 

3.2.2 Point Cloud Data 

This function imports point cloud data (collection of vectors in a 3D coordinate system) into Houseplan 1.0. 

Select "Insert Tab > Imagery Panel >  Point Cloud Data" to open the following dialog box. 

 

1. Point cloud data: Click on the  button to select a file in *.las format. 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 75 of 241 

2. Dilute ratio: The ratio of the number of data points to be reduced during the point cloud data processing. The larger the 

value, the greater the number of data points and the slower the transformation process; the smaller the value, the smaller 

the number of data points and the faster the transformation process. 

3. Original coordinate: Click on the "Original coordinate" button to import the scene according to the original coordinates. 

4. Specify coordinate: Click the "Specify Coordinate" button to import the scene according to the specified coordinates. 

Note: 

① After inserting the point cloud data, when using this function again, if the dilution value is the same as the last value, 

it can be directly inserted into the scene in in-situ coordinates or the specified coordinates; if the dilution value is 

changed, the data needs to be converted again. 

② Dilution ratio range:1-100. 

3.2.3 Data Classification 

A large amount of model data is automatically classified, and the number of data files after classification is significantly reduced 

and more organized. This function can solve the problems of low loading efficiency and high consumption of scene rendering when 

users process large batches of data. 

Select "Insert Tab > Imagery Panel >  Data Classification" to open the dialog box shown below. 

 

Right-click in the margin to open the right-click menu, as shown below. 
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1. New Project: Click on "Create new projects" and the following dialog box will pop up. 

 

Enter the project name, select the save path, click the "Confirm" button, and five layers will be automatically created, 

as shown in the figure. 
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The checkbox controls the display and hiding of that layer. 

2. To open the compiled data, select "Import Project", which brings up the following dialog box.  

 

After selecting the compiled project.zml file, click the "Original Coordinate" button to insert the scene according to 

its original coordinates; click the "Specify Coordinate" button to insert the scene according to the specified coordinates. 

3. Right-click on the layer node name to open the context menu, as shown in the following image. 
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(1) Rename: Changes the name of 

the project. 

(2) Delete: Deletes layers, retain 

local source files and data can 

be restored after deletion. 

(3) Positioning: Locates the item 

location in the scene. 

4. Compilation process. 

(1) Right-click on a new project in a blank space in the compiled data area. 

(2) Import the data source, click on the  button and select the source data to be compiled. 

(3) Select the compiled data layer and then check the corresponding data source in the table on the right to map the 

layer to the data source. 

(4) Click “Compile” button to compile the current layer data. 

Note: The data source needs to save as osgb files for buildings, plants, rivers, roads, terrain, and vignettes in a scene separately.  

3.2.4 Orthoimagery 

Resamples the distorted drawings to a new correct orthoimage. The original remote sensing image with distortions is 

resampled in grayscale according to the correct geometric relationship. Select "Insert Tab > Imagery Panel >  Orthoimagery 

" to open the dialog box shown below. 
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1. New: Right-click on the blank space to open 

the context menu, click "New", and the 

following dialog box appear. After entering the 

image data name, click the "Confirm" button to 

create new image data; click the "Cancel" 

button to cancel the operation and close the 

dialog box. 

2. Right-click on the data list to open the context menu, as shown. 

(1) Compile: Click on "Compile" and the 

following dialog box will pop up. 

① Path: the path of the generated 

project. 

② Data source: the original data path. 

Click the  button, select the result 

path and data source, click the "Compiling" 

button to start the compilation; click the "Terminated" button to terminate the compilation.  

(2) Import: Click on "Import" to open the dialog box shown below. 

 

Click the  button to select the generated result, click the "Original coordinate" button to insert the scene 

according to the original coordinates; click the "Specify coordinate" button to insert the scene according to the specified 

coordinates. 

(3) Rename: Changes the name of the image data. 

(4) Positioning: Locates this image data in the scene. 
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(5) Delete: Deletes the current image data. 

Note: 

① When selecting the already generated results for import by clicking on the  button, they can only be 

imported in the in-situ coordinates. 

② Check Show to show the data in the scene; uncheck Show to hide the data in the scene.  

③ The source data for the orthogonal projection are in tif, jpg format (with coordinates). 

3.2.5 Flatten Oblique Image 

Flattens selected area of an oblique photography. Select the "Insert Tab > Imagery Panel >  Flatten Oblique Image" item, 

and there are three types of flattening. 

1. Define the flattened area by drawing polylines.  

2. Define the flattened area by typing “S” and press Enter to draw 3D polylines. 

3. Define the flattened area by typing “D” and press “S” to select closed line or plane. 

Note: 

① When drawing a horizontal area, the horizontal plane is formed at the height of the first point at the time of drawing 

and is flattened according to the drawn outline. 

② When drawing a three-dimensional area, a plane is defined by the first three points and flattened according to the 

drawn outline. 

③ When defining the flattening area, flatten the image by the outline and height of the selected object. 

④ Define the flattened area to be less than or equal to the flattened image area, less than the image base outline, and 

the bottom of the image must not be overhanging. 

After flattening, select the oblique photography model in the scene and click on the  button after the "Flattened Area" field 

in the properties bar to open the dialog box shown. The dialog box shows the names of all the flattened areas. Select the name and 

the corresponding flattened area in the scene is highlighted; double-click the name to quickly locate the selected area. Right-click 

on the name to open the context menu: 
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1. Delete: The selected flattened area is deleted and the oblique 

photography data for that area is restored to its pre-flattened state. 

2. Delete all: All flattened areas are deleted and the oblique photography 

data in the scene is restored to its original state. 

3. Rename: Modifies the name of the flattened area. 

3.2.6 Oblique Data Filter 

Deletes or saves oblique photography area according to different cutting 

methods. Select "Insert Tab > Imagery Panel>  Oblique Data Filter" to open the following dialog box. 

 

1. There are four ways to draw the edit range: 

(1) Rectangle: Click  button to draw a rectangular editing area. 

(2) Polygons: Click  button to draw a polygon editing area. 

(3) Circles: Click  button to draw a circular editing area. 

(4) Select: Click  button to select a graphic as the edit area; the selected drawing can only be a line or volume. 

Note: 

① The editing area can be adjusted in extent by dragging and dropping the clip point and its position can be 

moved. 

② When a custom editing area is selected, the volume of the original reference is removed and a new editing area 

is created, and the new editing area is also dragged with clip points.  

③ Only one editing area can exist in the scene, and when a new editing area is drawn, the last one is automatically 

deleted. 

2. Permeate: Draw a planar edit area that includes all data on the plane and in the infinite mapping range above and below the 
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plane. 

3. Automatically pick: Draw an edit area and picks the highest point in the range as the model height to generate a 3D edit 

area. 

4. Height: When drawing an edit area, if a height value is manually inputted, the 3D edit area is generated with the given value.  

5. Delete Selected: The original data within the edit area is deleted and the scene is loaded with the remaining data. 

6. Delete Unselected: The original data outside the edit area range is deleted and the scene is loaded with the remaining data. 

7. Save As Selected: The data within the edit area is saved separately, and the original data is retained. 

3.3 Output Panel 

3.3.1 Publish 

Creates an .exe file that can be executed independently, and can realize video roaming , environment changing, and properties  

display. Select "Insert Tab > Output Panel >  Publish" to enter the Publish Preview screen. 

 

1. Menu: hover the cursor at the bottom to show the menu; move cursor away to hide the menu, as shown above.  

(1) Gallery: Click the "Gallery" button to turn on/off the left side gallery. When the gallery is on, hover the cursor on the 

left side of the screen to show the gallery; move the cursor away to hide it. Click on any video within the gallery to 

roam or position to the appropriate viewpoint. 
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(2) Video Roam: Click the "Video Roam" button to open the dialog box shown below. 

 

① Click on the  button to set the path roaming parameters. 

② Click on  button to preview the view of the path. 

③ Click on  button to draw grounded paths in the publish scenario.  

④ Click on  button to stop preview the view of the path. 

⑤ Click on  button to pause the previewing and click again to continue the previewing. 

⑥ Click  button to clear the drawn grounded path or the path being used in the gallery. 
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(3) Effect Environment: Manage the environment effects in the publishing scene. For more details, see the "Scene Tab > 

Environment Panel > Environment" function. 

 

① Weather: Double-click on a weather image to apply the corresponding weather effects. 

② Lighting: Set the shadow effect in the scene and adjust the azimuth and altitude angle parameters of the sun. 

When shadows are on, adjusting the azimuth and altitude will affect the effect of the shadows. 

③ Effect Parameters: Click on the "Effect Parameters", you can modify the parameters of Solar, ambient, fog 

effect, volumetric light and HDR to enhance the ambient effect. 

④ Night vision settings: The lighting category, lighting rate and brightness can be modified separately to adjust 

the lighting effect in night mode. 

(4) Properties: Click the "Properties" button to turn on/off the properties column on the right side of the screen. Click one 

element of the building and the properties column will display related information. 
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(5) Data Management: Specify 

the path to correctly load 

the oblique photography 

data in the scene. 

(6) Publish: Click the "Publish" 

button to package the file and save as .exe (executable application). 
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2. Context menu: Right-click in the scene to open the context menu. 

 

(1) Orbit: Dynamically moves the observer around the model while maintaining the same focus point. Pressing “Ctrl + 

middle mouse wheel” enables orbit view as well. If you have an entity selected and then use this function, the view 

is rotated with that entity as the center point. 

(2) Eye view: Turns on human eye view perspective. Press and drag the left button in the scene to view around by human 

perspective. 

(3) Full view: Displays all entities in the workspace to the maximum extent possible. 

(4) Pan: Moves the position of the view without changing the position or scale of the objects in the drawing. Press and 

hold the middle mouse wheel enables Pan operation as well. 

(5) View control: Switches current workspace 3D perspective view from different 

directions. Click on the corresponding blue arrow to set the view direction, 

and click on the "Plane" button in any view, the view will turn to the plane 

state.  

(6) Previous view: Returns to previous view performed. 

(7) Front face: Selects the plane on the volume to display its front view. 

(8) Window view: Maximizes the display of selected area, and enables full display and return to the previous view.  

3. Title: Double click on the title in the top left corner of the scene to open the dialog box shown below. 
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(1) Text: Set the title name. 

(2) Font: Sets the font of the title. 

(3) Text height: Sets the size of the font. 

(4) Color: Set the color of the font. 

4. Full-screen: Click the  button in the upper right corner to enter full screen, and press Esc to exit. Double-click the left 

mouse button to enter or exit full screen; in full screen, hover the cursor at the top to show the title bar; title bar will be 

hidden after the cursor moves out of it. 

5. Minimize: Click on the  button in the upper right corner to minimize the software to the taskbar. 

6. Close: Click the  button in the upper right corner to exit the publishing scene and return to the software scene.  

Note: 

① A gallery is a collection of highlights and video paths saved in a scene. 

② The gallery does not show highlights saved under the axonometric view. The highlights and roam paths are saved 

with the associated environment scene. 

③ It's necessary to resave the gallery after modifying the scene to update the preview image. 

④ Labels for particle entities in published scenarios and in published .exe files will be automatically hidden. 

⑤ Page Up/Page Down allows you to switch the gallery. 
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3.3.2 Export 

Exports the follow file formats; *.dwg, *.bmp, *. jpg, *.png, *.osgb, *.fbx, *.skp, *.3ds, *.obj. Select "Insert Tab > Output 

Panel >  Export" to open the following dialog box. 

 

1. Select the *.dwg format, click "Save" button and select the CAD version to export.  

2. Select the *.3ds, *.fbx, *.obj, *.osgb formats, click "Save" button, and the following dialog box will pop up. 

(1) Scene Units: Display the current drawing units. 

(2) File Units: Set the units of the drawing to be exported. 
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(3) When Model Centered is checked: The model coordinates 

will be centered. That is, the coordinates of the center 

point at the bottom of the model bounding box are set to 

(0,0,0) for exporting. 

(4) When Change Origin is checked: The model origin is 

changed, and the specified point is set as the origin of 

the model. 

(5) When both Model Centered and Change origin are 

unchecked: The origin and model position will not be 

changed, and the model will be exported according to the actual position in the current drawing.  

Note: Model Centered and Change origin options are mutually exclusive, only one can be checked, or both are unchecked.  

3. Select *.bmp, *.jpg, *.png format, click "Save" button, and the following dialog box will pop up.  

(1) Output size: Sets the width and height of the exported 

image in pixel. 

(2) Maximum size: The system will display the maximum 

pixels of the exported image supported by the system. 

(3) Watermark pattern: 

① Watermark: If checked, exported image will have 

watermark. 

② Tile, spacing: Select "Tile" to display the watermark 

pattern according to the default spacing; select 

"Spacing" to display the watermark pattern 

according to the specified spacing. 

③ Watermark image: Click on the  button to select an image in *.bmp or *.jpg format as the watermark image.  

④ Transparency: Drag the slider to set the transparency of the watermark image, 1 is opaque, 100 is fully 

transparent. 

(4) Click the "Confirm" button to export the image in the appropriate format. 

4. Select *.skp format, click "Save" button, and the following dialog box will pop up. 
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(1) Export Version: Select the exported .skp file version's standards. 

(2) Unit Conversion: Convert units when exporting to keep the same 

units as in SketchUp. 

(3) Model Centered: When checked, the exported objects will be 

automatically centered to the origin coordinates. 

(4) Export Line: Exporting lines, spline.  

(5) Ignore Material: Exported models without materials. 

(6) Change Origin: When checked, the model origin is changed, and the 

specified point is set as the origin of the model. 

Note: 

① If a file in *.dwg, *.osgb, *.3ds, *.obj, *.skp or *.fbx format is selected for exporting, the entities in the background 

layer of the current drawing are not exported. 

② When exporting renderings, it is recommended to turn on "Anti-aliasing, Shadow, Light Projection". 

3.4 VR Panel 

3.4.1 VR 

With Houseplan 1.0 and VR devices, users can immerse themselves in the 3D scene they have created, realizing a real-time 

virtual scene browsing experience that allows them to observe in detail from different perspectives. 

Before using the VR tool, please make sure that the SteamVR application has been installed correctly on your computer, and 

that the SteamVR program and the VR device are turned on and connected to the same network, and then select "Insert Tab > VR 

Panel >  VR" to open the following dialog box: 

 

Click the "OK" button to enter the VR scene. And click the "VR" function again to end the VR browsing. 
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Controller operation: 

1. Teleport: Press and hold the trigger located in front of the controller. Once the green light illuminates, direct the light towards 

the desired target point, then release the trigger to initiate teleportation 

2. Recenter: Press the controller side button to return to the initial position; 

3. Directional control: 

1) Move forward/backward: Hold the controller horizontally and push the controller's joystick forward/backward; 

2) Pan left/right: Hold the controller horizontally and push the controller's joystick left/right accordingly; 

3) Move up/down: Hold the controller vertically and push the controller's joystick forward/backward to achieve the 

desired movement; 

The aforementioned operations are demonstrated using the controller of the Quest 3 headset as an example. Operations for 

other headset are similar to those of the Quest headsets 

Note: 

Houseplan 1.0 currently supports VR devices such as Quest and HTC. For detailed information on how to use the device and 

its controller, please visit the official website of the respective VR device.  

  



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 92 of 241 

4 Edit Menu 

This chapter introduces the basic features of modifying the amount, size, shape, and position of model outlines. Using these 

features can help the user easily improve the effects of the project. 

4.1 Modify Panel 

4.1.1 Copy 

Copies an object to specified distance and direction. Select "Edit Tab > Modify Panel >  Copy", select the object, specify 

the base point and target point, and copy continuously.  

4.1.2 Cut 

Copies an object to clipboard and cut. Select "Edit Tab > Modify Panel >  Cut" and select the object to cut. 

4.1.3 Paste 

Inserts an object from clipboard into workspace. Select "Edit Tab > Modify Panel >  Paste" and there are two ways to 

paste. You can insert the object directly at the designated position or Enter “Y” and press Enter to insert at the original coordinates. 

4.1.4 Erase 

Deletes a selected object. Select "Edit Tab > Modify Panel >  Erase". 

4.1.5 Move 

Moves an object to the specified distance and direction. Select "Edit Tab > Modify Panel >  Move" to select the 

object. There are two ways to move it. 

1. Move directly by the global coordinate system: selecting the object and specifying the base and target points to move. 

2. Enter “M” and press enter, select the reference plane, select the entity to be moved, and specify the base and target points 

to move along the reference plane. 

4.1.6 Rotate 
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Rotates an object around at specified base point. Select "Edit Tab > Modify Panel >  Rotate", select the object, specify 

the base point. There are two types of rotation. 

1. Rotation is accomplished by directly specifying or entering a value to determine the angle of rotation. 

2. To rotate the entity at a reference angle, enter “R” and press enter. 

(1) After directly entering a value to determine the reference angle, specify or enter a value to determine the new angle. 

Note: The angle at which the final entity is rotated = new angle - reference angle. 

(2) Specify the angle to determine the reference angle, such as: specify the base point c, specify the reference angle 

after the first point a, specify the second point b, specify the new angle with reference to a point d on the edge, and 

rotate the edge ab to be parallel to the edge cd. The effect is shown in the following figure.  

 

4.1.7 Scale 

Scales selected object, keeping the proportion of the object unchanged after scaling. Select "Edit Tab > Modify Panel >  

Scale", select the object, specify the base point. There are two ways to zoom in. 

1. Scale by directly specifying or entering a value to determine the scaling ratio. 

2. Scales the entity by the reference length. Enter R and press enter. 

(1) After entering a value directly to determine the reference length, specify or enter a value directly to determine the new 

length. 

(2) Specify the length to determine the reference length, such as: specify the base point c, specify the reference length 

after the first point a, specify the second point b, specify a point d on the reference edge to determine the new length, 

and scale the ab edge to a length equal to the cd edge. The effect is shown in the following figure.  
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Note: Scale factor = new length / reference length, example; enter 0.5 to reduce to 0.5 times the original length. 

4.1.8 Mirror 

Creates a mirror copy of selected object. Select "Edit Tab > Modify Panel >  Mirror", select the object. If you enter “N”, 

after mirroring, the source object is not deleted; if you enter “Y”, after mirroring, the source object is deleted. There are two types of 

mirroring. 

1. Mirroring by direct reference to the line joining the two specified points.  

2. Type “Z” and press Enter to use the Z axis as reference. 

The effect is shown in the following figure. 

 

4.1.9 Offset 

Creates concentric circles, parallel lines and isometric curves of selected object. Select "Edit Tab > Modify Panel >  
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Offset" and there are two types of offsets. 

1. Specify directly or enter a value to determine the offset distance: Select the object to be offset and specify the point to 

determine the side on which the offset is to be made. 

2. Make the newly generated line entity pass through the specified point: Enter “T” and press enter, select the object to be 

offset, and then specify the pass-through point. 

4.1.10 Trim 

Trims intersected 2D objects. Select "Edit Tab > Modify Panel >  Trim", first select the boundary line, then select the 

object to be trimmed. The effect is shown in the following figure.  

 

You can also select multiple line entities with intersection points at the same time, and then select the object to be trimmed. 

The effect is shown in the following figure. 

 

 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 96 of 241 

Note: 

① Trimming objects can be line segments, polylines, arcs, clouds and splines.  

② Trimming can only be successful when the selected line intersects with the boundary line.  

4.1.11 Extend 

Extends the selected boundaries or edges. The objects are extended so that the edges of other objects can be converged. 

Select "Edit Tab > Modify Panel >  Extend" item, select the boundary line, and then select the object to be extended. The 

effect is shown in the figure below. 

 

You can also select multiple line entities with intersection points at the same time, execute the Extend command and select 

the object to be extended. The effect is shown in the following figure.  

 

Note: 

① Extension objects can be line segments, polylines or arcs. 
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② The extension can only be successful when the extension of the selected line has an intersection with the boundary 

line. 

4.1.12 Break  

Breaks the selected object between two points. You can create a gap between two specified points on an object, breaking it 

into two objects. Select "Edit Tab > Modify Panel >  Break", select the object, use the clicked position as the first break 

point, and then specify the second break point; to re-designate the first break point, enter “F” to specify the first and second break 

points to break. 

Note: The supported line entities are line segments, polylines, arcs, clouds, splines, and ellipses.  

4.1.13 Stretch 

Stretches objects crossed by a selection window or polygon. Objects that are partially enclosed by a crossing window are 

stretched. Select "Edit Tab > Modify Panel >  Stretch", select the 2D object to be moved or stretched, specify the base point 

first, and then the second point. The effect is as shown below. 

 

Note: 

① Box select one or more points of a line entity to locally stretched. 

② Point or box select the entire line entity to move it as a whole. 

4.1.14 Fillet 

Adds rounded corners to intersected 2D objects or volume. Select "Edit Tab > Modify Panel >  Fillet". 
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1. Rounding of line entities: Selecting two non-parallel lines, set radius of the rounded corners.  

2. Rounding the corners of the 3D 

volume is generated by selecting 

the edges of the 3D volume; The 

effect is shown in the following 

figure. 

3. Type “R” and press Enter to set the 

radius of the rounded corner. 

4.1.15 Chamfer 

Adds chamfers to intersected 2D objects or volume. Select "Edit Tab > Modify Panel >  Chamfer" item. 

1. Chamfering intersected 2D 

objects, selecting two non-

parallel lines, generated at the set 

chamfer distance. 

2. Chamfering of 3D volume is 

generated by selecting the 

chamfered main plane and 

chamfered edges. 

3. Enter “D” and press Enter to set the chamfer distance. 

4.1.16 Smooth  

Converts a polyline into a spline. Select "Edit Tab > Modify Panel >  Smooth" and select a polyline. 

4.1.17 Explode 

Decomposes selected objects. Select "Edit Tab > Modify Panel >  Explode" and select objects to explode. 

Note: 

① Break into planes when the selected object is a volume. 

② Break into lines when the selected object is a plane. 
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③ Break into line segments when the selected object is a polyline. 

④ Selecting a spline converts it to a polyline. 

⑤ Select grouped entities to Ungroup. 

4.1.18 Array 

4.1.18.1 Array Copy 

Quickly generates multiple copies of objects or other components by a set distance or number. Select "Edit Tab > Modify 

Panel >  Array >  Array Copy" to open the following dialog box. 

 

1. By Floor: Generate copies by building floor or opening. 

(1) Reference. 

① Check "Reference" to use the selected building's vertical plane as a reference plane. 

② If "Reference" is unchecked, the building's vertical plane within 2 meters is used as the reference plane. 

(2) Entire column. 

① Check "Entire column" to generate a copy of the column with the selected entity in-situ. 

② Uncheck "Entire column" to generate a column or layer of copies starting from the entity's location and following 

the cursor position. 

 

For example, check "Reference" and uncheck "Entire column". Click the "By Layer" button, first select the vertical plane 

of the building as a reference, and then select the entities to be arrayed, so that the cursor moves up and down (by layer) and 

specifies the end point to generate multiple copies of the entities between the two points. The effect is shown in the following 

figure. 
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2. Pick Point: Generates multiple copies starting with the selected entity.  

(1) Reference. 

① Check "Reference" to generate a copy in the direction of the selected reference line. 

② With "Reference" unchecked, specify two points to determine a line and generate a copy along that line.  

(2) Amount. 

① Amount: generate copies of the amount entered in the text box (including the original entity).  

② Distance: Click "Amount" in blue font and switch to "Distance". Set the distance between two adjacent copies, 

and generate copies at this spacing. 

(3) Base point. 

① Check "Base point" to specify the position relative to the original entity, using that point as the star ting point for 

the reference. 

② The entity center point is used as the base point without checking the "Base Point" box.  

For example, check "Reference", "Number", and "Base". Click the "Home" button, select the edges of the building, entities, 

etc., then select the entities to be arrayed, specify the base point, move the cursor, and specify the end point to generate 

multiple copies of the entities between the two points. The effect is shown in the following figure.  
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3. Select Line: Generates a copy along the selected path. 

(1) Follow. 

① Check "Follow" and the resulting copy is rotated to match the path orientation. 

② If "Follow" is unchecked, the copy is generated at the original angle. 

(2) Amount. 

① Amount: generate copies in the amount entered in the text box. 

② Distance: Click "Quantity" in blue font and switch to "Distance". Set the distance between two adjacent copies, 

and generate copies at this spacing. 

(3) Base point. 

① Check "Base point" to specify the position relative to the original entity, i.e. the position of the final copy relative 

to the path. 

② If "Base point" is unchecked, the entity center point is the base point, i.e. the center points of the copies are all 

on the path line. 

For example, check "Follow", "Number", and "Base point". Click the "Select Line" button, first select the path line, then 

select the entity to be arrayed, according to the relative position of the base point and the original entity, along the path line to 

generate a copy. The effect is shown in the following figure. 
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Note: If the specified base point is offset by a distance from the original entity, the final generated copy is also offset by 

a corresponding distance from the path. 

4. Draw Line: Generates a copy along the 2D or 3D line. 

(1) Follow. 

①  Check "Follow" and the resulting copy is rotated to match the path orientation. 

②  If "Follow" is unchecked, the copy is generated at the original angle. 

(2) Amount. 

①  Amount: the default quantity. Generate copies of the amount entered in the text box. 

②  Distance: Click "Amount" in blue font and switch to "Distance". Set the distance between two adjacent copies, 

and generate copies at this spacing. 

(3) Base point. 

①  Check "Base point" to specify the position relative to the original entity, i.e. the position of the final copy relative 

to the path. 

②  If "Base point" is unchecked, the entity's center point is used as the base point, i.e. the center points of the 

copies are all on the path line. 

(4) Two dimensional. 

①  Two-dimensional: by default, path lines are drawn in the same way as two-dimensional polylines. 

②  3D: Click on the blue font "2D" and switch to "3D". Draws the path line in the same way as a three-dimensional 

polyline. 

For example, check "Follow", "Number", and "Base point" to draw in 2D by default. Click the "Draw Line" but ton, select 
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the entity to be arrayed, specify the base point first, then specify the location of the first copy to be generated, and use it as 

the starting point to create the entity. Then draw the path in the same way as drawing a polyline, and right -click to end the 

generation. The effect is shown in the following figure.  

 

4.1.18.2 Planar Array 

Generates multiple copies of selected object. Select "Edit Tab > Modify Panel >  Array >  Planar Array" to open 

the dialog box shown below. 

   

1. Parameter settings. 

(1) Setting the number and spacing of copies. 

(2) Set the angle of the array, either manually or by clicking on the blue font "Angle" and specifying two points for drawing 

the line, using the angle between the line and the positive direction of the X-axis as the angle of the line. 

2. Click on "Select" in blue and select the objects (entities other than roads and terrain). 

3. Click the "Apply" button to complete the array and generate multiple copies. 
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4.1.19 Group 

4.1.19.1 Entity Group 

Groups multiple objects into a whole to facilitate operations such as moving, rotating, copying or deleting them. Select "Edit 

Tab > Modify Panel >  Group >  Entity Group", and select multiple objects for grouping. 

Note: 

① Groups do not support buildings and components. 

② Press ctrl + shift to select a single entity within the group. 

③ Can group entities already in a group. 

④ Select an entity while pressing down “ctrl + Alt” key to separate it from the group.  

4.1.19.2 Entity Ungroup 

Removes the grouping relationship. Select " Edit Tab > Modify Panel >  Group >  Entity Ungroup", and select 

grouped objects to ungroup. You can also use "explode" function to ungroup entities. When ungrouping entities in multi-layered 

groups, each single action only ungroups the outermost group.  

4.1.20 Text 

Inserts text into workspace. Select "Edit Tab > Modify 

Panel >  Text" item to open the following dialog box.  

Note: 

① When the cursor is on an arc, the text is adjusted to 

the angle of the tangent plane. 

② In the properties palette, the position, angle, screen-

facing properties and spacing of the text can be 

modified. 

③ You can double-click the text, or click the "Content" 

item in the property palette, and select  button to modify the text content. 

4.2 Measurement Panel 
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4.2.1 Distance 

Measures the distance between two points. Select "Edit Tab > Measurement Panel >  Distance ", specify two points, 

and display the distance value on the command line. When measuring, the distance is displayed in real time in the program. 

4.2.2 Line Angle 

Measures the angle between two lines in the same plane. Select "Edit Tab > Measurement Panel >  Line Angle", select 

two lines, and display the angle value on the command line. 

Note: 

① When an arc is selected, the angle of the tangent line is measured.  

② The line angle is displayed in real time in the program during the measurement.  

4.2.3 Plane Angle 

Measures the angle between any two plane entities. Select "Edit Tab > Measurement Panel >  Plane Angle", select two 

planes, and display the angle value on the command line. 

Note: 

① Does not support measuring curved planes.  

② When measuring, the plane angle is displayed in real time in the program.  

4.3 Positioning Panel 

4.3.1 Normal Move 

Moves a selected object along the normal direction of the selected plane or edge. Select "Edit Tab > Positioning Panel > 

 Normal Move", follow the command line prompt, place the cursor on the plane or edge of the selected object, highlight it and 

drag horizontally or vertically. 
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Note: 

① The cursor can snap to the planes or edges of entities. For example, the sides and top/bottom of a building can be 

snapped, as well as the edges of entities such as balconies, planes, etc.  

② When a plane is snapped, the whole plane is highlighted and the red cross cursor is displayed. At this point, drag 

along the plane in the vertical direction in a forward or reverse direction as indicated by the arrow to achieve 

continuous operation. 

③ When snapping to the edge or plane of a curved shape, move along the perpendicular direction of its tangent line. 

④ During dragging, move the cursor to other planes to align entities. Generally, select a plane in the same direction as 

a reference. For example, when selecting the top plane of a building to move, holding the left button down moves 

the cursor to the top plane of another building or other entity to make the tops of both at the same height. 

⑤ Line entities are not supported. 

4.3.2 Bottom Leveling 

Adjusts the floor elevation of selected object from its base point. Select "Edit Tab > Positioning Panel >  Bottom 

Leveling", according to the command line prompt, select the reference plane first, and enter the height relative to the reference plane, 

then select the object. You can adjust the elevation of the entity according to the reference plane and the relative height.  
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When selecting entities, enter “W”. You can box select multiple entities and adjust the height uniformly. 

Note: 

① When a reference plane is selected, the plane is displayed in red when it is clicked on the plane of a volume. When 

there is no plane at the clicked location, a horizontal plane is automatically created in red, centered on the clicked 

point, to indicate the reference plane. 

② If the relative height is set, the leveled elevation = the height of the reference plane + the relative height. For example, 

if the reference plane is specified at a height of 10 m and the relative height is set at 2 m, a building is selected 

whose lowest point elevation is 12 m. 

③ Roads are not supported. Roads can be modified via the property palette for starting and end height or elevation. 

4.3.3 Axis Rotation 

Rotates a selected object by the specified axis and angle. Select "Edit Tab > Positioning Panel >  Axis Rotation", 

according to command line prompt, put the cursor on the edge of the entity itself and click or enter the angle to rotate around this 

edge as the axis. You can click continuously to rotate. 
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Enter “S” to rotate object by using the edge lines of other entities as axes. For example, after entering “S”, first select entity A 

as the rotation object, right-click to end the selection, at which point the cursor is placed on the edge line of entity B and clicked, 

i.e., the edge line of B is used as the axis to rotate, to rotate A. 

Note: 

① Rotated objects support lines, planes (except grid planes), editable polygons and text.  

② Text cannot be rotated on its own axis. Text can be rotated by selecting another object as the axis of rotation. 

③ The rotation axis supports the selection of most entities, except for special entities such as background scenes and 

text. 

4.3.4 Rotate to Horizontal 

Take the center point of a line or plane and rotate it so that it is parallel to the XOY plane. Select "Edit Tab > Positioning Panel > 

 Rotate to Horizontal" and select the object to rotate it horizontally. 
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Note: 

① If the point is on a line, rotate the clicked line segment to horizontal by its midpoint; if the point is on the plane of a 

plane or volume, rotate the clicked plane to horizontal by its center. 

② Grid planes are not supported. 

4.3.5 Rotate Vertical 

Take the center point of a line or plane and rotate it so that it is perpendicular to the XOY plane. Select "Edit Tab > Positioning 

Plane >  Rotate to Vertical" and select the object to rotate horizontally. 

 

4.3.6 Adjacent Entities 

Fits the selected plane or line to the specified position. Select "Edit Tab > Positioning Panel >  Adjacent Entities", first 

select the plane or edge of object 1 as reference, then select the plane or edge of object 2 to fit together with object 1. 
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Note: 

① When the plane of a volume is selected, it is aligned with the center of the plane. 

② When the edges of the entity are selected, they are aligned at the midpoint of the edges.  

③ Reference entities and parallel entities can be any one of: buildings and components, line and other entities. 

4.3.7 Align Entities 

Aligns the selected plane or line to the specified position. Select "Edit Tab > Positioning Panel >  Align Entities" item, 

first select the plane or edge of object 1 as reference, then select a plane or edge of object 2, and align with object 1. 

 

Note: Reference and parallel objects can be any one of: buildings and components, lines and other objects. 

4.3.8 Arrange 

4.3.8.1 Arrange Along Line 

Arranges entities in order along a path. Select "Edit Tab > Positioning Panel >  Arrange Along Line" and follow the 

command line prompts as follows. 
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1. Enter a value to determine the normal net distance. For example; the distance between the object and the reference line 

when it is finally lined up.  

2. Select the edge lines of the objects as reference lines. Next, enter values to determine the distance between aligned entities 

and select the entities to be aligned. 

3. Finally, select the reference entity, and the other entities are arranged equidistantly with the reference entity as the base. 

4.3.8.2 Directional Copy 

Copies a selected object in parallel or perpendicular direction to the reference line. Select "Edit Tab > Positioning Panel > 

 Directional Copy", and follow the command line instructions as follows. 
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1. Select lines or solid edges as reference lines. 

2. Select the entity to be copied, and at this point move the cursor to the parallel, perpendicular, or Z-axis direction of the 

reference line, using the center of the entity as the base point to specify where the copy is to be generated. Enter S to 

reassign the base point for copying.  
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5 Modeling Menu 

This chapter introduces various traditional and advanced modeling features that allow users to create, modify and refine 

the buildings and entities in the scheme according to the rendered effect. 

5.1 Advanced Modeling Panel 

Advanced Modeling has powerful modeling capabilities, providing flexible and versatile point, line, plane-related operations 

to deal with all kinds of complex modeling process easily and efficiently. 

5.1.1 Advanced Modeling 

Select "Modeling Tab > Advanced Modeling Panel >  Advanced Modeling" to open the dialog box shown below. 

  

Note: In the vertex, edge, polygon, element and object tabs of advanced modeling, the Copy, Delete, Move, Rotate, Scale and 

Delete functions or tools under "Edit" tab are not available. 
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5.1.2 Display Mode 

Click  button in the upper right corner of the panel to expand the drop-down list, as shown below. 

1. Edged Faces: Editable polygons are displayed as "model + wireframe" by default. 

2. Wireframe: Displays in wireframe form. 

3. Facets: Displays in model mode. 

Note: You can use the shortcut key F9 to cycle through the three display modes.  

5.1.3 Vertex, Edge, Polygon 

Dynamically displays the total number of vertices, 

lines, and planes of editable polygons. 

Note: Contains both selected and unselected, 

hidden ones are not counted. 

5.1.4 Transform 

5.1.4.1 Select 

Select is a status command that defaults to the selected state. Normally, objects can be added to the selection set by "selecting 

them one by one" or "window selecting" for subsequent operations. As shown below: 

 

1. To add objects to the selection set, you need to hold down the "Ctrl" key and select the object to be added. 

2. To remove individual objects from the selection set, you need to hold down the "Alt" key and select the object to be removed.  

3. To invert the current selection of objects, you need to hold down the "Shift" key and select the object to invert the selection. 

Note: The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can be activated at 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 115 of 241 

any time. 

5.1.4.2 Move 

Selects and moves the object. When  in the selected state, the object is moved in the following ways. 

1. Move directly, click on an object and drag the mouse directly to move the object.  

 

2. Select and move. Add the object to be moved to the selection set first, and move it by specifying the reference point in the 

selection set as the base point. 

 

3. Right-click the Move button and set the move distance of the selected object in the pop-up window. 
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The direction of movement is determined by the mouse and the current reference coordinate system. To restrict the object's 

movement relative to the plane defined by the X, Y or Z axes or any two of them, click the corresponding button on the Constraints 

toolbar or click directly on the axis to temporarily lock the corresponding axis.  

Note: 

① You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and click the "OK" 

button to batch copy objects along the direction with equal intervals. 

② The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can be activated 

at any time. 

③ This command corresponds to the move command in the UV Editor. 

5.1.4.3 Rotate 

Selects and rotates the object. When  is selected, the object is rotated in the following ways.  

1. Direct rotation, click on an object and drag the mouse directly to rotate the object. 
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2. Select and rotate, the object to be rotated is first added to the selection set and rotated by specifying the reference point in 

the selection set as the base point. 

 

3. Right-click the Rotate button and set the rotation angle of the selected object in the pop-up window. 
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The direction of rotation is determined by the mouse and the current reference coordinate system. To restrict the rotation of the 

object to the plane defined by the X, Y or Z axis or any two of them, click the corresponding button on the Constraints toolbar or 

click the axis directly on the axis to temporarily lock the corresponding axis. If the XY, YZ or XZ axes are locked at the same time, the 

model will remain unchanged. 

Note: 

① You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and click the "OK" 

button to batch rotate objects with equal angle. 

② The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can be activated 

at any time. 

③ This command corresponds to the rotation command in the UV Editor. 

5.1.4.4 Scale 

Selects and scales the object. When  in the selected state, the object is scaled in the following ways. 

1. Direct scaling, click on an object and drag the mouse directly to scale the object. 
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2. Select and scale, the object to be scaled is first added to the selection set and scaled by specifying the reference point in 

the selection set as the base point. 

 

3. Right-click the “Scale” button and set the zoom scale of the selected object in the pop-up window. 
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The direction of scaling is determined by the mouse and the current reference coordinate system. To restrict object scaling to 

the plane defined by the X, Y or Z axis or any two of them, click the corresponding button on the Constraints toolbar, or click directly 

on the axis to temporarily lock the corresponding axis.  

Note: 

① You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and click the "OK" 

button to batch copy objects with equal proportion. 

② The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can be activated 

at any time. 

③ This command corresponds to the scale command in the UV Editor. 

5.1.4.5 Lock 

Enables or disables selection locking, which prevents accidental selection of other entities in complex scenes.  

By default, this button is unchecked. By checking the lock button and enabling this feature, you can click or drag the cursor 

anywhere in the viewport without losing that current selection set or adding unwanted new objects to the current selection se t. To 

cancel or change the selection, uncheck the lock item. 

On the toolbar, check the lock button and activate one of the move, rotate, or scale buttons. Drag anywhere in the viewport to 

move, rotate, or scale the objects in the selection set. 

5.1.5 State 
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5.1.5.1 Snap 

When creating and editing editable polygons in the Advanced 

Modeling panel, you can enable the snap function to assist in the 

operation for precise positioning. Click the checkbox  at the 

bottom of the panel to turn the snap function on or off. Right click on 

the checkbox  to open the dialog box shown below.  

You can set snapping options, where "plane" refers to the 

surface of a plane or entity. Click the "Select All" button to check all 

the boxes; click the "Confirm" button to apply the settings. 

Note: When snapping to the circle center of an arc, you need 

to hover the cursor over the edge line to display the center of 

the circle. 

5.1.5.2 Orthogonal 

Restricts the operation to horizontal or vertical orientation. Click the checkbox 

 at the bottom of the panel to turn the orthogonal function on or off. Right-click 

the checkbox  to open the following menu.  

1. Select "World": Operation is performed in the world coordinates direction (i.e., the 

axes in the lower left corner of the software). 

2. Select "User": Operation is performed in the self-defined axis direction. 

You can follow the command line prompts and enter the angle with the X direction of the world coordinate system as the 

X-axis direction in the user coordinate system; or select the edge or line as the orthogonal direction; you can also draw the 

line to obtain it. Enter “D” and press ENTER, specify two points, and draw the orthogonal direction. If you need to clear the  

defined orthogonal direction, enter “C” and press ENTER. 

Note: 

① When orthogonal is turned on, operations such as drawing can only be performed in the X, Y or Z axis directions.  

② When both snapping and orthogonal are enabled, snapping takes precedence.  

③ When drawing a line to obtain it, the two points are drawn with different directions and different angles. 

5.1.5.3 Ignore BackFacing 
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When this option is enabled, only points, lines, and planes visible in the workspace can be selected. With this option disabled, 

all points, lines, and planes in the viewport can be selected. Click the checkbox  at the bottom of the panel to 

turn this feature on or off. 

5.1.5.4 Local 

The native position, i.e., the object's own coordinates. Click the checkbox  at the bottom of the panel to turn this function 

on or off. 

Note: 

① When its own coordinates are checked, the axial direction of the operation is affected; when its own coordinates are 

unchecked, it is the axial direction in world coordinates.  

② The operations affected are move, rotate, scale, mirror, array, align, transform, etc. 

③ You can view the direction of the entity's own coordinates by using the "Axis Transformation" function.  

5.1.6 Constraint 

Constraints, i.e., axial constraints. Click the button at the bottom of the panel to turn on or off the constraint funct ion for the 

corresponding axis, as the following figure shows. 

 

Note: 

① Axis constraints affect the axes of move and zoom functions. For example, if you constrain the x-axis, you can only 

move in the x-axis direction when you perform a move. Similarly, if the xy-axis is constrained, the movement can 

only be made in the XOY plane. 

② When "Snap" is checked, movement is in the direction of the constraint, although it is possible to move by snap point.  

③ You can also achieve the constraint effect by dragging the cursor in an axial direction without checking the "Constraint" 

box. 

5.2 Create Tab 

Converts objects such as planes and volumes into editable polygonal entities.  

5.2.1 Polygon Tools 
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5.2.1.1 Rectangle 

Creates a rectangular plane. Select "Create Tab > Polygon > Rectangle", specify the first corner point, drag it to the target  

location as another corner point.  

Note: After activating the drawn rectangular plane, its alias, accompanying layer color, smoothing, length, width and other 

parameters can be modified on the property palette. 

5.2.1.2 NGon 

Creates a regular polygonal plane. Select "Create Tab > Polygon > NGon", enter a value to determine the number of sides, 

and then start drawing. There are three ways to generate. 

1. Draws a square polygon internal to a circle: Specifying the center point and entering the radius generates a square polygon. 

2. Draw a regular polygon based on the specified side lengths:  Input or Enter “E” and press Enter to specify two points as the 

lengths of the sides of the regular polygon. 

3. To draw a square polygon tangent to a circle: Input or Enter “C”, specify the center point, enter the radius, and generate a 

square polygon. 

Note: 

① The generated result is an editable plane. 

② You can modify polygonal plane properties on properties palette. 

③ If the drawn polygon plane has been edited, the number of sides and the internal tangent radius parameters in the 

property palette cannot be modified. 

5.2.1.3 Polygon 

Creates polygonal planes. The generated result is an editable plane. Select "Create Tab > Polygon > Polygon", specify the 

starting point, and draw the polygon directly; or enter “S” to draw the polygon in 3D space. To abort the previous operation, type 

“U” and press enter. 

5.2.1.4 Circle 

Creates a circular plane. Select "Create Tab > Polygon > Circle" to create a circle with the specified center and radius. 

5.2.1.5 Ellipse 

Creates an elliptical plane. Select "Create Tab > Polygon > Circle" to create an ellipse with the specified center and axis 

length. 
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5.2.1.6 Donut 

Creates a ring with a circular cross section. Select "Create Tab > Polygon > Donut", specify the center of the circle, and 

then set the inner and outer radii respectively. 

Note: 

① To set the radius, specify the location with the mouse or enter the value at command line. 

② The property palette allows you to modify parameters such as alias, accompanying layer color, smoothing, outer 

circle radius, inner circle radius, center point, etc. 

5.2.1.7 Star 

Creates a star-shaped closed plane. Select "Create Tab > Polygon > Star", specify the center point, enter a value to 

determine the number of star angles, and then set the outer and inner radii.  

Note: 

① To set the radius, specify the position with the mouse or enter the value at command line. 

② The property palette allows you to modify information about parameters such as alias, accompanying layer color, 

smoothing, corner points, outer radius, inner radius, center point, etc.  

5.2.2 Object Tools 

5.2.2.1 Box 

Creates a box. Select "Create Tab > Object > Box", draw the bottom side of the box, enter the height. 

Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth, 

length section, width section, height section, length, width, height, center, elevation, etc.  

5.2.2.2 Sphere 

Creates a sphere. Select "Create Tab > Object > Sphere", specify the center of the sphere, enter the radius.  

Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth, 

number of sides, radius, center, elevation, etc.  

5.2.2.3 Cylinder 

Creates a cylinder. Select "Create Tab > Object > Cylinder", draw the base of the cylinder, enter the height.  

Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth, 

number of sides, height section, face section, radius, height, center, elevation, etc.  
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5.2.2.4 Torus 

Creates a ring volume. Select "Create Tab > Object > Torus ", specify the center of the circle, enter the circle radius and the 

radius of the torus. 

Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth, 

number of sides, section, rotate angle, inner circle radius, out circle radius, center, elevation, etc.  

5.2.2.5 Cone 

Creates a cone. Select "Create Tab > Object > Cone", specify the center of the circle, enter the radius of the top and bottom 

planes, enter the height. 

Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth, 

number of sides, height section, face section, bottom radius, top radius, height, center, elevation, etc.  

5.2.2.6 Pyramid 

Creates a pyramid. Select "Create Tab > Object > Pyramid", specify the center point, enter the number of sides, enter the 

radii of the top and bottom external circles, and enter the height. 

Note: The property palette allows you to modify information about parameters such as al ias, color attached to layers, smooth, 

number of sides, bottom radius, top radius, height, center, elevation, etc. 

5.2.3 Convert Tools 

5.2.3.1 Convert 

Converts objects such as volumes, planes and buildings into editable polygons. Select "Create Tab> Convert > Convert" 

and select the entity to convert it to an editable polygon. 

Note: All entities except oblique photography, point cloud, and imagery data, can be converted to editable polygons and their 

points, lines, and planes edited. 

5.3 Vertex Tab 

5.3.1 Delete 

Erases the selected point. Select "Vertex Tab > Delete" and select the vertex to delete. The planes formed with this point will 

be deleted together after deletion. 
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5.3.2 Copy 

Copies the selected point. Select "Vertex Tab > Copy", select the point, specify the base point, and then specify the target 

point to create a copy. 

5.3.3 Select Invert 

Selects all points in the current workspace other than the selected points. Select the "Vertex Tab > Select Invert" item to 

select the object, all points other than the object are selected. 

5.3.4 FFD 

Adds control vertices to the selected point, making it more evenly to adjust the shape of an object. Select “Vertex Tab > 

FFD” to open the dialog box shown.  

1. Control Points: When using FFD under this submode, the 

lattice frame will be shown in yellow and the control points 

on it can be selected and manipulated to change the shape 

of the object. A single or multiple control points can be 

adjusted at the same time. 

2. Lattice: When using FFD under this submode, the lattice 

frame will be shown in orange. The frame can be moved, 

rotated, or scaled. By default, if the frame is moved or 

scaled, only vertices within the volume of the object can be 

used for transformation. 

3. Set Volume: Mainly used to set the initial state of lattice 

frame. Under this mode, when using FFD the frame will be shown in green. The control points can be adjusted without 

affecting the shape of the object. This provides better control when transforming irregular objects.  



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 127 of 241 

4. FFD style: The default setting is rectangular mode, with three 

different FFD styles: "FFD 2× 2× 2", "FFD 3× 3× 3" and "FFD 

4× 4× 4". You can also customize the style by clicking the 

"Customize" button to bring up the dialog box shown below.  

(1) Cuboid mode: Creates rectangular shape lattice free-

form transformations, where the number of edit points 

in the XYZ axis can be set separately in the rectangular 

parameters. 

(2) Cylinder mode: Creates cylindrical shape lattice free 

form. Radial, lateral and height edit points can be set 

separately. 

5. Set the parameters, select the editable polygon, and the FFD 

edit box will appear on the selected volume to enter the 

transformation edit mode. 

Note: 

① During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will 

end. 

② During operations, the three submodes can be switched to one another. 

③ The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher 

the number of segments, the higher the precision. 

④ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points, 

the smaller the range controlled by a single point.  

⑤ Ignoring back side is valid for FFD edit points. 

⑥ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time; 

if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as 

one volume and then use FFD transformation. 

⑦ When FFD editing, move, rotate, and scale under "Edit" tab are not available. 

5.3.5 Slice 

Specifies a slicing line to generate a slicing plane. New vertices and lines will be generated where the   model and the plane 
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intersect. Select "Vertex Tab > Slice", and select two points. 

5.3.6 Cut 

Cuts planes to create new vertices and lines. Select "Vertex Tab > Cut", then click on an entity to continuously specify positions 

to cut the plane of the entity. 

5.3.7 Tessellate 

Tessellates models by choosing to split the selected planes with edge 

midpoint connections or with vertex connections. 

After selecting a vertex, select "Vertex Tab > Tessellate", to open the 

following dialogue. 

Choose to tessellate either edge or face, set tension, and click Confirm 

to apply. 

5.3.8 Drag 

Drag select, with which vertices will be automatically selected when 

the cursor hovers over them. Select "Vertex Tab > Drag", hold down left mouse button, and hover over vertices to select them.  

5.3.9 Target Weld 

Drag the selected point to the target point to be merged (as close as possible) to automatically perform the merge. Select 

"Vertex Tab > Target Weld" and select the starting point and target point to merge. 

Note: 

① The starting point and the target point must be on the same line. 

② When the planes on which the points are located are not closed, points which do not lie on the same line may be 

welded. 

③ When points on different entities need to be merged, multiple entities should be "Attach" before merging. 

5.3.10 Break 

Breaks a shared vertex into multiple independent vertices for separate editing. Select "Vertex Tab > Break" and select the vertex 

to break. 
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5.3.11 Weld  

Welds multiple vertices of an editable polygon together into a single vertex. Select "Vertex Tab > Weld", select the vertex and 

enter the weld distance, and the vertices within the range are welded as one. 

Note: 

① A successful weld is achieved when the distance entered is greater than or equal to the distance between any vertices 

to the average position of the combined vertices. 

② The vertices selected must be vertices in the same plane on the entity. 

③ When vertices on different entities are to be welded, multiple entities must be "Attach" before welding. 

5.3.12 Exit  

All points will exit the editing state. Select "Vertex Tab> Exit" to exit the editing state. 

5.3.13 Remove 

Removes a selected point. Unlike Erase, removing vertices does not destroy the integrity of the plane.  Select "Vertex Tab > 

Remove" item to remove the selected point. 

5.3.14 Connect  

Connects points on editable polygons with lines. Select "Vertex Tab > Connect", and draw lines by clicking on vertices. 

Note: while connecting vertices, the connecting line cannot intersect with other lines. 

5.3.15 To Edge 

By selecting a point, the line associated with that point is selected and switched to line mode.  

Select "Vertex Tab > To Edge" item and select the line to select the line that connects this point. 

5.3.16 Shrink 

Shrink vertex selection towards the inner circumference direction from the currently selected point. 

Select the "Vertex Tab> Shrink" item, select the vertex, and then shrink the selection one turn inward along the selected range.  

Note: 

① Automatically selects the vertices on the lines that shares sides with this point.  

② The Ignore Backfacing option has no influence on this command. 
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5.3.17 Grow 

Extends vertex selection of the currently selected vertices in the peripheral direction.  

Select the "Vertex Tab > Grow" item, select the vertex, and then expand the selection one turn outward along the selected 

range. 

Note: 

① Automatically selects the vertices on the lines that shares sides with this point.  

② The Ignore Backfacing option has no influence on this command. 

5.3.18 Chamfer 

Fillets selected points. Slice the selected edge to create a new 

plane. Select the "Vertex Tab > Chamfer ", select the vertex to be 

sliced fillet. Set the slicing amount and segment parameters in the 

dialog box, and click Confirm. 

Parameter Description: 

1. Slicing amount: Specifies the size of the chamfered plane. 

2. Segment: Input value between 1 and 10. 

3. Open sliced corners: Decides whether the cut corners are closed. 

 

5.4 Edge Tab 

5.4.1 Delete 
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Erases the line on the selected editable polygon. Select "Edge Tab > Delete" and select the line to delete. The planes formed 

with this line will be deleted together after deletion. 

5.4.2 Copy 

Copies lines on editable polygons into separate 3D polylines. Select "Edge Tab > Copy", select the line, specify the base 

point, and then specify the target point to create a copy. 

5.4.3 Select Invert 

Selects all lines in current workspace other than the selected lines. Select the "Edge Tab > Select Invert" item to select the 

object, all lines other than the object are selected. 

5.4.4 FFD 

Adds control vertices to the selected edge to evenly adjust the shape of the object. Select “Edge Tab > FFD” to open the 

dialog box shown.  

1. Control Points: When using FFD under this submode, the 

lattice frame will be shown in yellow and the control points 

on it can be selected and manipulated to change the shape 

of the object. A single or multiple control points can be 

adjusted at the same time. 

2. Lattice: When using FFD under this submode, the lattice 

frame will be shown in orange. The frame can be moved, 

rotated, or scaled. By default, if the frame is moved or 

scaled, only vertices within the volume of the object can be 

used for transformation. 

3. Set Volume: Mainly used to set the initial state of lattice 

frame. Under this mode, when using FFD the frame will be shown in green. The control points can be adjusted without 

affecting the shape of the object. This provides better control when transforming irregular objects.  
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4. FFD style: The default setting is rectangular mode, with three 

different FFD styles: "FFD 2× 2× 2", "FFD 3× 3× 3" and "FFD 

4× 4× 4". You can also customize the style by clicking the 

"Customize" button to bring up the dialog box shown below.  

(1) Cuboid mode: Creates rectangular shape lattice free-

form transformations, where the number of edit points 

in the XYZ axis can be set separately in the rectangular 

parameters. 

(2) Cylinder mode: Creates cylindrical shape lattice free 

form. Radial, lateral and height edit points can be set 

separately. 

5. Set the parameters, select the editable polygon, and the FFD 

edit box will appear on the selected volume to enter the 

transformation edit mode. 

Note: 

① During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will 

end. 

② During operations, the three submodes can be switched to one another. 

③ The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher 

the number of segments, the higher the precision. 

④ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points, 

the smaller the range controlled by a single point.  

⑤ Ignoring back side is valid for FFD edit points. 

⑥ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time; 

if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as 

one volume and then use FFD transformation. 

⑦ When FFD editing, move, rotate, and scale under "Edit" tab are not available. 

5.4.5 Slice 

Specifies a slicing line to generate a slicing plane. New vertices and lines will be generated where the model and the plane 
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intersect. Select "Edge Tab > Slice", and select two points. 

5.4.6 Cut 

Cuts planes to create new vertices and lines. Select "Edge > Cut", then click on an entity to continuously specify positions 

to cut the plane of the entity. 

5.4.7 Tessellate 

Tessellates models by choosing to split the selected planes with edge 

midpoint connections or with vertex connections. After selecting a vertex, select 

"Edge Tab > Tessellate", and the following dialogue appears. Choose to tessellate 

either edge or face, set tension, and click Confirm to apply. 

5.4.8 Drag 

Drag select, with which lines will be automatically selected when the cursor 

hovers over them. Select "Edge Tab > Drag", hold down left mouse button, and hover over lines to select them. 

5.4.9 Fence  

Fence select. Select all lines that intersect the line you draw. Select "Edge Tab > Fence", draw a polyline, and all intersecting 

lines will be selected. 

5.4.10 Create Shape 

Extracts the contour lines. Select the "Edge Tab > Create Shape " item and select the line to generate a 3D polyline. 

Note: The 3D polyline generated can only be edited if you exit advanced modeling mode. 

5.4.11 Measure 

Select a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines evenly to divide  

the line or plane. Select the item "Edge Tab > Measure" and the dialog box pops up: 
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1. Object: You can choose lines, planes, and solids. 

(1) Line: "One line", an equal division of the selected line.  

(2) Plane:  

① One line, one plane: An equal division of the selected plane according to the vertical direction of the selected 

line. 

② Multi-line: Equally divide the associated planes based on the selected polyline. 

(3) Solid: 

① One line: The volume is divided equally according to the vertical direction of the selected line.  

② Two lines: The volume is divided equally according to the two lines chosen.  

2. Equipartition parameter: You can enter the value directly, or click the  button to adjust how many segments you want to 

add, or you can drag the slider to adjust it. 

(1) Segment: The default value is 2, means an equal division into 2 parts. 

(2) Shrink: Moves all newly generated segment lines or points, either towards the center or towards the ends.  

(3) Slider: Offsets all newly generated segment lines or points as a whole on the plane. 

Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes, both lines must 

belong to the same entity and must be coplanar. 

5.4.12 Exit  
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All lines will exit the editing state. Select "Edge Tab> Exit" to exit the editing state. 

5.4.13 Remove 

Removes a line from an editable polygon. Select "Edge Tab> Remove" item to remove the selected line. 

Note: After selecting the object: 

① Right-click or press space: Removes the line and its endpoints, and the two planes that have a common side with 

the line are combined into one plane. 

② Press Enter: Removes the line and keeps the endpoints. 

5.4.14 To Vertex 

In line mode, select the point on the selected line and switch to point mode. Select "Edge Tab > To Vertex " and after selecting 

the line, the point on the line is selected. 

5.4.15 To Polygon 

In line mode, select the plane associated with the selected line and switch to plane mode. Select "Edge Tab > To Polygon " 

and after selecting the line, the associated plane is selected.  

5.4.16 Shrink 

Shrink the selection of lines in the inward direction of the currently selected line. Select "Edge Tab > Shrink" item, select the 

line, and then shrink the selection one turn inward along the selected range. 

5.4.17 Grow 

Extends the selection of lines in the outward direction of the currently selected line. Select "Edge Tab > Grow" item, select the 

line, and then expand the selection by one circle along the selected range. 

5.4.18 Chamfer 

Slices the selected edge to create a new plane. Select the "Edge Tab> Chamfer", select the line to be sliced, and the following 

dialog box appears. 
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Set the slicing amount and segment parameters in the dialog 

box, and click Confirm. 

Parameter Description: 

1. Slicing amount: Specifies the size of the chamfered plane. 

2. Segment: Integer between 1 and 10. 

3. Open slice corners: Decides whether the cut corners are 

closed. 

5.4.19 Bridge  

Within the same model, the Bridge command can create a plane between edges, and the new bridging plane will be a part of 

the original mesh. Select " Edge Tab > Bridge", and the following dialogue will pop up: 

 

Set number of segments, type, taper, offset, twist 1 and twist 2 parameters, click "Confirm" to apply. 

Parameter Description: 

1. Segments: Sets the number of equal segments for the plane generated by the bridge. 

2. Type: Sets the type of plane generated by the bridge, the Liner and Curve are available. 

3. Taper: Sets the extent to which the bridge width becomes smaller or larger toward its center. Negative value tapers it smaller; 

positive value tapers it larger. 

4. Offset: Determines the position of the maximum taper. Ranges from -99 to 99, with default 0.0, the amount of taper is 

greatest at the center of the bridge. 

5. Twist1、Twist2: Rotates the order of connection between the edges of the two selections. The two controls let you set a 

different twist amount for each end of the bridge. 
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5.4.20 Ring 

Creates one edge ring based on the current sub-object selection and selects the results. Select "Edge Tab > Ring " to select 

a line of a quadrilateral and press enter, then the opposite line is selected. For example, if the you select the line “i”, t he line “i+2” 

will be RING selected. 

 

Note: The command is only available to the quadrilateral plane.  

5.4.21 Loop 

Creates one edge loop based on the current sub-object selection and selects the results. Select the "Edge Tab > Loop", and 

after selecting the line and pressing enter, connecting lines are selected. 
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Note: The command is only available to the quadrilateral plane. 

5.4.22 Border  

Quickly select border lines. Select "Edge Tab > Border", after selecting lines and press enter，all lines on the edge will be 

selected. 

5.4.23 Cap 

In line mode, select the boundary line that needs to be sealed to generate a new plane. Select the "Edge Tab > Cap" and 

select the closed line on the editable polygon to seal. 

Note: Window select the editable polygon, and the system automatically searches for the closed lines on the current polygon, 

and automatically excludes those that already have planes. 

5.4.24 Insert Vertex 

Manually add points to the edge for subdivision. Select "Edge Tab > Insert Vertex " and specify the insertion point on the line. 

5.5 Polygon Tab 

5.5.1 Delete 

Erases the selected plane. Select "Polygon Tab > Delete" and select the plane to delete. 
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5.5.2 Copy  

Copies the selected plane. Select "Polygon Tab > Copy", select the plane, specify the base point, and then specify the target 

point to create a copy. 

5.5.3 Select Invert 

Selects all planes in the current scene other than the selected plane. Select the "Polygon Tab > Select Invert" item to select 

the object, all planes other than the object are selected. 

5.5.4 FFD 

Adds control vertices to the selected plane to evenly adjust the shape of the object.  Select “Polygon Tab > FFD” to open the 

dialog box shown.  

1. Control Points: When using FFD under this submode, the 

lattice frame will be shown in yellow and the control points 

on it can be selected and manipulated to change the shape 

of the object. A single or multiple control points can be 

adjusted at the same time. 

2. Lattice: When using FFD under this submode, the lattice 

frame will be shown in orange. The frame can be moved, 

rotated, or scaled. By default, if the frame is moved or 

scaled, only vertices within the volume of the object can be 

used for transformation. 

3. Set Volume: Mainly used to set the initial state of lattice 

frame. Under this mode, when using FFD the frame will be shown in green. The control points can be adjusted without 

affecting the shape of the object. This provides better control when transforming irregular objects.  
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4. FFD style: The default setting is rectangular mode, with three 

different FFD styles: "FFD 2× 2× 2", "FFD 3× 3× 3" and "FFD 

4× 4× 4". You can also customize the style by clicking the 

"Customize" button to bring up the dialog box shown below.  

(1) Cuboid mode: Creates rectangular shape lattice free-

form transformations, where the number of edit points 

in the XYZ axis can be set separately in the rectangular 

parameters. 

(2) Cylinder mode: Creates cylindrical shape lattice free 

form. Radial, lateral and height edit points can be set 

separately. 

5. Set the parameters, select the editable polygon, and the FFD 

edit box will appear on the selected volume to enter the 

transformation edit mode. 

Note: 

① During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will 

end. 

② During operations, the three submodes can be switched to one another. 

③ The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher 

the number of segments, the higher the precision. 

④ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points, 

the smaller the range controlled by a single point.  

⑤ Ignoring back side is valid for FFD edit points. 

⑥ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time; 

if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as 

one volume and then use FFD transformation. 

⑦ When FFD editing, move, rotate, and scale under "Edit" tab are not available. 

5.5.5 Slice 

Specifies a slicing line to generate a slicing plane. New planes will be generated where the model and the plane intersect. 
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Select "Polygon > Slice", and select two points. 

5.5.6 Cut 

Cuts planes to create new vertices and lines. Select "Polygon Tab> Cut", then click on an entity to continuously specify 

positions to cut the plane of the entity. 

5.5.7 Tessellate 

Tessellates models by choosing to split the selected planes with edge 

midpoint connections or with vertex connections. After selecting a vertex, select 

"Polygon Tab > Tessellate", and the following dialogue appears. Choose to 

tessellate either edge or face, set tension, and click Confirm to apply. 

5.5.8 Drag 

Drag select, with which planes will be automatically selected when the cursor 

hovers over them. Select "Polygon Tab > Drag", hold down left mouse button, and hover over lines to select them. 

5.5.9 Fence  

Fence selected. Select all lines that intersect the line you draw. Select "Polygon Tab > Fence", draw a polyline, and all 

intersecting lines will be selected. 

5.5.10 Smooth 

Smooths the selected entity. Select "Polygon Tab > Smooth", after select editable polygons, and the following dialog box 

appears. 

Sets number of iterations whether to display smooth effect, click "Confirm" to apply. 
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Parameter Description: 

Iterations: Controls number of vertices that are 

added to the polygon to smooth the mesh. 

Show: The smooth effect will be displayed. 

Hide: The smooth effect will not be displayed. 

Note: When the number of iterations is 0, only 

display smoothness is active. 

5.5.11 Measure 

Select a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines evenly to divide 

the line or plane. Select the item "Polygon Tab > Measure" and the dialog box pops up:  

  

1. Object: You can choose lines, planes, and solids.  

(1) Line: "One line", an equal division of the selected line. 

(2) Plane:  

① One line, one plane: An equal division of the selected plane according to the vertical direction of the selected 

line. 

② Multi-line: Equally divide the associated planes based on the selected polyline.  

(3) Solid: 
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① One line: The volume is divided equally according to the vertical direction of the selected line.  

② Two lines: The volume is divided equally according to the two lines chosen.  

2. Equipartition parameter: You can enter the value directly, or click the  button to adjust how many segments you want to 

add, or you can drag the slider to adjust it. 

(1) Segment: The default value is 2, means an equal division into 2 parts. 

(2) Shrink: Moves all newly generated segment lines or points, either towards the center or towards the ends.  

(3) Slider: Offsets all newly generated segment lines or points as a whole on the plane. 

Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes, both lines must 

belong to the same entity and must be coplanar. 

5.5.12 Exit  

All planes will exit the editing state. Select "Polygon Tab> Exit" to exit the editing state. 

5.5.13 Detach 

Breaks the selected plane into a new volume. Select "Polygon Tab > Detach " to select a plane for breaking, which is shown 

in gray by default. 

5.5.14 To Edge 

While under the Polygon mode, select the lines on the selected plane and jump to the Edge mode. Select "Polygon Tab > To 

Edge" and after selecting the plane, the lines on the plane are selected and switched to the Edge Tab. 

5.5.15 To Element 

In polygon mode, select the elements related to the selected polygon and switch to element mode.  

After selecting a polygon, select "Polygon Tab > To Element", and the related elements will be selected and switched to the 

Element Tab. 

5.5.16 Shrink 

Shrinks the selection of planes in the inward direction of the currently selected plane. Select "Polygon Tab > Shrink" item, 

select the plane, and then shrink the selection one turn inward along the selected range. 
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5.5.17 Grow 

Adds planes on the outward direction of the currently selected plane into selection. Select "Polygon Tab > Grow" item, select 

the plane, and then expand the selection by one circle along the selected range. 

5.5.18 Flip Normal 

Flips the planes with reverse direction of normal in the selection set so that the UV material can be displayed properly. Select 

"Polygon Tab > Flip Normal " item and select the plane. 

Note: The selected plane is flipped 180° along the center of its own, the results of modifications by other commands to the 

editable polygon like Weld and Break, will not be changed. 

5.5.19 Bridge 

Within the same model, the Bridge command creates a connecting plane between edges, and the bridging plane will be part 

of the original mesh. Select "Polygon Tab > Bridge", and the following dialogue will pop up: 

 

Set number of segments, bridge type, taper, offset, twist 1 and twist 2 parameters, click Confirm to apply.  

Parameter Description: 

1. Segments: Sets the number of equal segments for the plane generated by the bridge. 

2. Type: Sets the type of plane generated by the bridge, the Liner and Curve are available. 

3. Taper: Sets the extent to which the bridge width becomes smaller or larger toward its center. Negative value tapers it smaller; 

positive value tapers it larger. 

4. Offset: Determines the position of the maximum taper. Ranges from -99 to 99, with default 0.0, the amount of taper is 

greatest at the center of the bridge. 
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5. Twist1、Twist2: Rotates the order of connection between the edges of the two selections. The two controls let you set a 

different twist amount for each end of the bridge. 

 

5.5.20 Outline 

Offsets the selected plane within the selection by the same proportion. Select "Polygon Tab > Outline" item, select the polygon 

plane, and drag the cursor or enter a value to determine the offset distance. 

5.5.21 Extrude Polygon 

Performs vertical or horizontal extrusion of multiple planes of editable polygons within a selection set according to polygons, 

groups, or local normal. Select "Polygon Tab > Extrude Polygon" and select the plane. Set the parameters in the dialog box and 

click the "Confirm" button to squeeze the selected plane. 

1. Polygons: Vertical or lateral extrusion in 

the normal direction of the selected plane 

itself. 

2. Group: Vertical or lateral extrusion in the 

average normal direction of the selected 

planes. 

3. Local normal: Selected planes adjacent to 

each other are merged in the direction of 

their combined normal for vertical or lateral extrusion. 

5.5.22 Extrude 
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Extrudes the selected plane. Select "Polygon Tab > Extrude" item, the selected object will be highlighted, drag the mouse or 

enter the exact value to extrude. Entering “Y” on the command line will retain the selected plane; entering “N” will not retain the 

selected plane; before pressing Enter to finish the command, you can select any additional planes to continue extruding.  

Note: Align the cursor to other entities when extruding, then the selected extrusion plane can be extruded to the same height 

as the selected entity. 

5.6 Element Tab 

5.6.1 Delete 

Erases the selected element. Select "Element Tab > Delete" and select the element to delete. Erases a single instance element 

and also deletes other instance entities of the same source. 

5.6.2 Copy 

Copies the selected element. Select "Element Tab > Copy", select the element, specify the base point, and then specify the 

target point to create a copy. 

5.6.3 Select Invert 

Selects all elements in the current scene other than the selected element. Select the "Element Tab > Select Invert" item to 

select the object, all elements other than the object are selected. 

5.6.4 FFD 

Adds control vertices to the selected elements to evenly adjust the object shape. Select “Element Tab > FFD” to open the 

dialog box shown.  
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1. Control Points: When using FFD under this submode, the 

lattice frame will be shown in yellow and the control points 

on it can be selected and manipulated to change the shape 

of the object. A single or multiple control points can be 

adjusted at the same time. 

2. Lattice: When using FFD under this submode, the lattice 

frame will be shown in orange. The frame can be moved, 

rotated, or scaled. By default, if the frame is moved or 

scaled, only vertices within the volume of the object can be 

used for transformation. 

3. Set Volume: Mainly used to set the initial state of lattice 

frame. Under this mode, when using FFD the frame will be shown in green. The control points can be adjusted without 

affecting the shape of the object. This provides better control 

when transforming irregular objects. 

4. FFD style: The default setting is rectangular mode, with three 

different FFD styles: "FFD 2× 2× 2", "FFD 3× 3× 3" and "FFD 

4× 4× 4". You can also customize the style by clicking the 

"Customize" button to bring up the dialog box shown below.  

(1) Cuboid mode: Creates rectangular shape lattice free-

form transformations, where the number of edit points 

in the XYZ axis can be set separately in the rectangular 

parameters. 

(2) Cylinder mode: Creates cylindrical shape lattice free 

form. Radial, lateral and height edit points can be set 

separately. 

5. Set the parameters, select the editable polygon, and the FFD 

edit box will appear on the selected volume to enter the 

transformation edit mode. 

Note: 

① During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will 
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end. 

② During operations, the three submodes can be switched to one another. 

③ The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher 

the number of segments, the higher the precision. 

④ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points, 

the smaller the range controlled by a single point.  

⑤ Ignoring back side is valid for FFD edit points. 

⑥ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time; 

if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as 

one volume and then use FFD transformation. 

⑦ When FFD editing, move, rotate, and scale under "Edit" tab are not available. 

5.6.5 Slice 

Specifies a slicing line to generate a slicing plane. New planes will be generated where the model and the plane intersect. 

Select "Element Tab > Slice", and select two points. 

5.6.6 Cut 

Cuts elements to create new vertices and lines. Select "Element Tab > Cut", then click on an entity to continuously specify 

positions to cut the plane of the entity. 

5.6.7 Tessellate 

Tessellates models by choosing to split the selected planes with edge 

midpoint connections or with vertex connections. 

After selecting a vertex, select "Element Tab > Tessellate", and the following 

dialogue will pop up: 

Choose to tessellate either edge or face, set tension, and click Confirm to 

apply. 

5.6.8 Drag 

Drag select, with which objects will be automatically selected when the cursor hovers over them. Select "Element Tab > Drag", 
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hold down left mouse button, and hover over objects to select them. 

5.6.9 Fence  

Fence selected. Select all elements that intersect the line you draw. Select "Element Tab > Fence", draw a polyline, and all 

intersecting elements will be selected. 

5.6.10 Smooth 

Smooths the selected entity. Select "Element Tab > Smooth", and the following dialogue will pop up: 

Sets number of iterations and whether to display smooth effect, click Confirm to apply. 

Parameter Description: 

Iterations: Controls number of vertices that are 

added to the element to smooth the mesh. 

Show: The smooth effect will be displayed. 

Hide: The smooth effect will not be displayed. 

Note: When the number of iterations is 0, only 

display smoothness is active. 

5.6.11 Measure 

Selects a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines evenly to divide 

the line or plane. Select the item "Element Tab > Measure" and the dialog box pops up:  
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1. Object: You can choose lines, planes, and solids.  

(1) Line: "One line", an equal division of the selected line.  

(2) Plane:  

① One line, one plane: An equal division of the selected plane according to the vertical direction of the selected 

line. 

② Multi-line: Equally divide the associated planes based on the selected polyline.  

(3) Solid: 

① One line: The volume is divided equally according to the vertical direction of the selected line. 

② Two lines: The volume is divided equally according to the two lines chosen.  

2. Equipartition parameter: You can enter the value directly, or click the  button to adjust how many segments you want to 

add, or you can drag the slider to adjust it. 

(1) Segment: The default value is 2, means an equal division into 2 parts. 

(2) Shrink: Moves all newly generated segment lines or points, either towards the center or towards the ends. 

(3) Slider: Offsets all newly generated segment lines or points as a whole on the plane. 

Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes, both lines must 

belong to the same entity and must be coplanar. 
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5.6.12 Exit  

All elements will exit the editing state. Select "Element Tab> Exit" to exit the editing state. 

5.6.13 Detach 

Breaks the selected element into a new, independent object. Select "Element Tab > Detach" and select the polygon to be 

broken, which is grayed out by default. 

Note: 

① The entity to which the relationship is attached is separable. 

② If the volume is divided into separate parts by operations such as removing points and lines, one of the parts 

(elements) can be separated. 

5.6.14 To Polygon 

Selects polygons related to an element and switch to the Polygon mode.  

After selecting an element, select "Element Tab > To Polygon", and the related polygons will be selected, while jumping to 

the Polygon Tab. 

5.7 Object Tab 

5.7.1 Delete 

Erases editable polygons or other entities. Select "Object Tab > Delete" and select the object to delete. 

5.7.2 Copy 

Creates copies of editable polygons. Select "Object Tab > Copy", select the object, specify the base point, and then specify 

the target point to create a copy. The default is no instance copy. Enter “Y” and press Enter, and the entity generated by the copy 

has an instance relationship with the original entity. You can copy on indefinitely before entering and exiting this command.  

5.7.3 Select Invert 

Selects all editable polygons in the current scene other than the selected volume. Select the "Object Tab > Select Invert" 

item to select the object, the editable polygons other than the object are selected. Hidden editable polygons cannot be reverse 

selected. 
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5.7.4 FFD 

FFD is a special lattice transformation editing tool. A lattice frame will be visible after selecting a model (a lattice frame is a 

frame that envelops the object), and the shape of the object can be adjusted using the control points on the frame to produce a 

smooth transformation and avoid tearing. FFD can be used directly as an editing tool or as an implied space shifting tool. Select 

"Object Tab > FFD" to open the dialog box shown.  

1. Control Points: When using FFD under this submode, the 

lattice frame will be shown in yellow and the control points 

on it can be selected and manipulated to change the shape 

of the object. A single or multiple control points can be 

adjusted at the same time. 

2. Lattice: When using FFD under this submode, the lattice 

frame will be shown in orange. The frame can be moved, 

rotated, or scaled. By default, if the frame is moved or 

scaled, only vertices within the volume of the object can be 

used for transformation. 

3. Set Volume: Mainly used to set the initial state of lattice 

frame. Under this mode, when using FFD the frame will be shown in green. The control points can be adjusted without 

affecting the shape of the object. This provides better control when transforming irregular objects.  
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4. FFD style: The default setting is rectangular mode, with three 

different FFD styles: "FFD 2× 2× 2", "FFD 3× 3× 3" and "FFD 

4× 4× 4". You can also customize the style by clicking the 

"Customize" button to bring up the dialog box shown below.  

(1) Cuboid mode: Creates rectangular shape lattice free-

form transformations, where the number of edit points 

in the XYZ axis can be set separately in the rectangular 

parameters. 

(2) Cylinder mode: Creates cylindrical shape lattice free 

form. Radial, lateral and height edit points can be set 

separately. 

5. Set the parameters, select the editable polygon, and the FFD 

edit box will appear on the selected volume to enter the 

transformation edit mode. 

Note: 

① During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will 

end. 

② During operations, the three submodes can be switched to one another. 

③ The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher 

the number of segments, the higher the precision. 

④ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points, 

the smaller the range controlled by a single point.  

⑤ Ignoring back side is valid for FFD edit points. 

⑥ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time; 

if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as 

one volume and then use FFD transformation. 

⑦ When FFD editing, move, rotate, and scale under "Edit" tab are not available. 

5.7.5 Slice 

Specifies a slicing line to generate a slicing plane. New planes will be generated where the model and the plane intersect. 
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Select "Object Tab > Slice", and select two points. 

5.7.6 Cut 

Cuts an editable 3D solid into multiple entities. Select "Object Tab > Cut", select the entity to be cut, specify the starting point, 

and draw a polyline as the cutting line; or enter S and press Enter, and select a line as the cutting line to cut the 3D entity.  

Note: 

① Two points specified Cutting line is not available to cut 3D objects in the 3D View (available when in the Front, back, 

top, bottom, left or right View). 

② Selected cutting lines are available to cut 3D objects when in the Front, back, top, bottom, left or right View.  

③ The selected cutting line must go through the model. 

5.7.7 Tessellate 

Tessellates models by choosing to split the selected planes with edge 

midpoint connections or with vertex connections. 

After selecting a vertex, select "Object Tab > Tessellate", and the following 

dialogue appears. Choose to tessellate either edge or face, set tension, and click 

Confirm to apply. 

5.7.8 Drag 

Drag select, with which 3D objects will be automatically selected when the cursor hovers over them. Select "Object Tab > 

Drag", hold down left mouse button, and hover over objects to select them. 

5.7.9 Fence  

Fence selected. Select all 3D objects that intersect the line you draw. Select "Object Tab > Fence", draw a polyline, and right-

click, all intersecting 3D objects will be selected.  
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5.7.10 Smooth 

Smooths the selected entity. Select "Object Tab > 

Smooth", and the following dialogue will pop up: 

Set number of iterations and whether to display 

smooth effect, click Confirm to apply. 

Parameter Description: 

Iterations: Controls number of vertices that are added 

to the element to smooth the mesh. 

Show: The smooth effect will be displayed. 

Hide: The smooth effect will not be displayed. 

Note: When the number of iterations is 0, only display smoothness is active. 

5.7.11 Measure 

Selects a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines evenly to divide 

the line or plane. Select the item "Element Tab > Measure" and the dialog box pops up:  

  

1. Object: You can choose lines, planes, and solids. 

(1) Line: "One line", an equal division of the selected line.  
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(2) Plane:  

① One line, one plane: An equal division of the selected plane according to the vertical direction of the selected 

line. 

② Multi-line: Equally divide the associated planes based on the selected polyline. 

(3) Solid: 

① One line: The volume is divided equally according to the vertical direction of the selected line.  

② Two lines: The volume is divided equally according to the two lines chosen.  

2. Equipartition parameter: You can enter the value directly, or click the  button to adjust how many segments you want to 

add, or you can drag the slider to adjust it. 

(1) Segment: The default value is 2, means an equal division into 2 parts. 

(2) Shrink: Moves all newly generated segment lines or points, either towards the center or towards the ends. 

(3) Slider: Offsets all newly generated segment lines or points as a whole on the plane. 

Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes, both lines must 

belong to the same entity and must be coplanar. 

5.7.12 Select by Name 

Selects the object by name. 

Select the "Object Tab > Select by Name" item and the following dialog box will appear. 
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1. Screening: 

(1) Search box: Search for entity names, with support for fuzzy searches, where the names of models that match the 

criteria are selected in the list. 

(2) List of names: The names of entities under the list can be selected singly or multi-selected (by pressing ctrl or shift). 

(3) Sort: Search results can be sorted alphabetically, by RGB value of the color or by size. 

2. All: select all entities in the list. 

3. Click the Confirm button to select the entities filtered in the list in the scene.  

Note:  

① Double-click on the entity name to position it in the middle of the view and maximize its display. 

② You can select all models with the same initials by entering the first letter of the model name in the list in the search 

field. 

③ The name selection is only valid for entities with free-form properties. 

5.7.13 Attach 

Attaches multiple editable polygons into one volume for easy editing and mapping operations. Select the "Object Tab > Attach" 

item, and select the volume and attached objects. 

Note: 
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① Additional entities cannot select instance entities that are homologous to the subject.  

② The editable polygon subsets when appended are all elements. 

③ To detach, you can use the detach function under element. 

5.7.14 Extrude Line 

Extrudes a selected line into a plane. Select "Object Tab > Extrude Line" and select the line to open the dialog box shown 

below. 

1. Parameter settings. 

(1) Squeeze direction. 

① Select "Horizontal squeeze" to 

squeeze the line horizontally into a 

plane. 

② Select "Vertical squeeze" to squeeze 

lines in the vertical direction to form a 

plane. 

(2) Squeeze parameters. 

① Squeeze value: Used to set the 

squeeze value. 

② Segment: Used to set the number of 

segments in the squeeze direction. 

(3) Sealing parameter: When selecting a closed 

line for squeezing, the sealing parameter 

can be set to control whether the beginning and end are closed. 

2. Click "Confirm" button to generate editable polygons according to the set parameters. 

Note: 

① The "squeeze" command may be executed on only one line at a time. 

② Only "Vertical Squeeze" can be selected for 3D lines, and there is no squeeze effect for lines drawn in the Z-axis 

direction. 
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5.7.15 Lattice 

Converts a line segment or edge of a drawing into a cylindrical structure with optional polyhedrons on the vertices, mostly 

used to produce frame of buildings. Select "Object Tab > Lattice" and 

select Editable Polygons to open the following dialog box. 

1. Parameter settings. 

(1) Parameter: 

① Show points only: Only points of editable 

polygons will be shown. 

② Show lines only: Only the lines of editable 

polygons will be shown. 

③ Both: Displays both points and lines of editable 

polygons. 

(2) Line. 

① Radius: Sets the size of the radius of the volume 

generated by the crystal lattice. 

② Number of sides: Sets the number of edges of the 

cross-section, the larger its value the more 

rounded it is. 

③ Angle: Set the angle of lattice lines. 

④ Ignore hidden edges: Check this checkbox to 

lattice only the visible edges; uncheck it to lattice all edges.  

⑤ End sealing: Check this checkbox to cap the volume generated by the latticed lines to make a closed shape. 

(3) Point. 

① Tetrahedron, octahedron, icosahedron: For setting the basic shape of the node. 

② Radius: Used to set the radius of the node, i.e. the size of the node. 

2. Click the "Confirm" button to generate it. 

Note: Editable polygons cannot be latticed twice, and latticed lines cannot be angularly rotated. 

 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 160 of 241 

5.7.16 Boolean 

Two intersecting bodies can be intersected, subtracted or combined to produce a new object. Select "Object Tab > Boolean", 

select the subtracted object, and then select the reference object, you can directly do subtract operations; enter “I”, selec t two 

objects for intersection operations; enter “U”, select two objects for merging operations.  

Note: 

① The two objects on which the Boolean operation is performed must be closed models.  

② The order in which the two objects are selected during the subtraction operation affects the result of the operation. 

5.7.17 Mirror 

Generates a mirror copy of the selected volume. Select "Object > Mirror", select the object, enter “N”, the entity generated 

by mirroring is not an instance of the original entity; enter “Y”, the entity generated by mirroring is an instance of the or iginal 

entity. Select the object to be mirrored to open the dialog box shown below. 

1. Parameter settings. 

(1) Mirror axis: Used to set the symmetry axis or symmetry plane of the 

mirroring. Where "offset" is used to set the offset distance of the 

mirrored object from the original object. 

(2) Clone current selection: Used to set whether to keep the original entity.  

2. Click the "Confirm" button to generate it. 

Note: 

① Mirroring is affected by the in-situ position and is mirrored by its own 

axes when the in-situ position is turned on. 

② When the mirror-generated entity is an instance of the original entity, 

the original entity will be changed when internal changes such as 

point/line/plane/element are made; when it is not an instance, they are not affected by each other.  

5.7.18 Instance 

Entities and their properties can be assigned to other editable polygons. When an instance object is modified, other instance 

objects bound with it will change as well. Select "Object Tab > Instance" item, first select the instance representative, and then 

select other editable polygons, enter to confirm. To revoke instancing, enter “U” and press Enter and select the object you want to 
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revoke instancing. 

Note: 

① Objects after instantiation, when making internal changes such as point/line/plane/element, other instanced objects 

will also change. 

② If the instance is moved, rotated, or scaled under the volume level, the instance object does not change with it. 

5.7.19 Loft 

Causes the selected section to generate a volume along the specified path. 

Select "Object Tab > Loft" to open the dialog box shown below. 

1. Align Pivot: The loft cross-section is, by default, centered on the path, 

and it can be proportionally aligned to different positions as desired.  

2. Parameters: 

(1) Angle: Sets the rotation angle of the loft cross-section. 

(2) Path: Sets the number of path segments. 

(3) Step: When the section is a line, you can set the fineness of the 

graph cross-section. 

3. Mirror Horizontal / Mirror Vertical: Set the mode of mirroring. 

After setting the above parameters, click " " button, select a path, and 

select lines or planes of editable polygons as the lofting object. Click Apply, and 

an editable polygon will be generated by lofting the selected object.  
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5.7.20 Array 

The array operation allows multiple identical bodies to be copied 

at the same time and for these objects to be arranged in space in a 

certain order and form. Select "Object Tab> Array" item, select the 

object, and the following dialog box will pop up. 

1. Parameter Note: 

(1) Offset distance: Sets the spacing between each array 

object along the X, Y and Z axes. 

(2) Rotation angle: Sets the angle at which the array object is 

rotated. 

2. Amount: I.e. the number of copies generated. 

3. After setting the parameters, click "Confirm" button to generate 

it. 

Note: 

① The array is affected by the in-situ position, which when turned on arrays by its own axes.  

② Adjusting the number and Z-axis rotation angle to achieve a circular array. 

③ In the case of a ring array, for the same editable polygon, if the axis position changes, the array shape changes. 

5.7.21 Adjust Pivot 

Changes the position of the editable polygon axis. Select "Object Tab> Adjust Pivot", and select the object, the following 

dialog box will pop up. 

1. Axial transformation. 

(1) Set axis center to center: Resetting the axis to 

the position of the object's center. 

(2) Set axis center to bottom: Placing the axis at the 

point of minimum Z value of the object's axis. 

(3) Custom: Customize the position of the axis, 

drag the axis or axis to move it, see "Move" for 

details. 
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(4) Axis rest: Reset the axis location back to default. 

2. Click the "Confirm" button to apply the axis settings.  

5.7.22 Align 

Moves the selected object so that it has the same X, Y, or Z coordinates as the other objects. Select "Object Tab > Align" item, 

select the reference object, and then select the current object, 

the following dialog box will pop up. 

1. Alignment position: Aligning the coordinate values of 

the current object with the reference object by 

different alignments. 

2. Click the "Confirm" button to apply the current 

settings. 

Note: Turning on the in-situ position only affects the 

coordinates of the reference object, while the current object is always aligned to its own coordinates.  

5.7.23 Shape Merge 

Projects the line or plane onto a selected plane. Select "Object Tab > ShapeMerge" item, select editable polygons, and then 

select Line or plane. 

Note: 

① The selected line or plane is projected onto the plane closest to the editable polygon. 

② The lines are selected must be in the same plane and closed. 

③ The selected plane must be flat. 

5.7.24 Shell 

Increases entity thickness in its local normal direction or the reverse direction. Select "Object Tab > Shell", and the following 

dialogue will pop up: 
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Parameters:  

Inner Amount: Increase thickness along the opposite direction of local 

normal. 

Outer Amount: Increase thickness along the direction of local normal. 

Segments: Divide the added thickness into segments. 

Select: 

Select Edges: Select the edges of the segments of added thickness. 

Straighten Corners: The thickness of corners will be the same as the 

entered thickness while executing the shell command. 

Inner Faces, Outer Faces: Select inner faces or outer faces. 

After the parameters are set, click "Confirm" to apply. 

5.8 Solid Editing Panel 

5.8.1 General Extrude 

Extrudes a selected plane or line of a volume. 

Note:  

① General extrusion supports buildings, lines, planes, and volumes. 

② Lines are not involved in extrusion. 

5.8.2 Extrude Cross-section 

Selects a closed area on a plane of an entity and extrude it into a volume. 

5.8.3 Make Arc 

5.8.3.1 Strings into Arcs 

Arcing a plane or part of a plane on a volume. Select "Modeling Tab > Solid Editing Panel>  Make Arc >  

Strings into Arcs" item. There are two types of arcing. 

1. To arc the whole plane, select a plane or plane on the volume and specify or enter a value to determine the arcing distance. 

The effect is shown in the following figure. 
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2. Type “P” and press Enter to specify two points for local arcing. The effect is shown in the following figure. 

 

Note: 

① Plane arcing supports planes, volumes, buildings, convex balconies, and concave balconies. 

② When plane arcing a building, only its vertical planes may be manipulated. 

③ Dragging the arced node to adjust the length, position and distance of the arc. 

④ Chord length arcing does not support curved planes. 

5.8.3.2 Tangents into Arcs  
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Arcing a straight edge of a prong or plane on a volume. Select "Modeling Tab > Solid Editing Panel>  Make Arc > 

 Tangents into Arcs", select the edge or plane to be arched, enter the radius of the corner, you can specify the mouse or enter 

a value less than or equal to the maximum radius 

to determine the radius of arcing. 

Note: Tangent arcing supports planes, 

volumes, buildings, convex balconies, and 

concave balconies. 

5.8.4 Multi-plane Loft 

3D solids are created by lofting between several cross-sections. Select "Modeling Tab > Solid Editing Panel >  Multi-

plane Loft", there are two loft methods. 

1. Lofting by straight grain effect. Select lines or planes to be generated in the selected order. 

 

2. Type “F” and press enter to loft with Smooth Fit Effect. 
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Note: The generated models differ in the order in which the sections are selected.  

5.8.5 Single-plane Loft 

5.8.5.1 Move 

Places the plane vertically and tangentially to the selected path. Select "Modeling Tab > Solid Editing Panel >  Single-

plane Loft >  Move", select 

the line or plane as cross-

section, then specify the base 

point on the section, select the 

path, and specify the placement 

point of the section on the path. 

Note: 

① If the cross-

section and the 

path are coplanar, no volumes can be generated, so it is necessary to use "Placement".  

② The location of the cross-section is where the volume is generated. 

5.8.5.2 Mirror 
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Mirrors the selected plane along the 

specified edge to adjust its location. Select " 

Modeling Tab > Solid Editing Panel >  

Single-plane Loft >  Mirror", select the 

line or plane as the cross-section, select the 

path as the mirror axis, and mirror the section. 

Note: The cross section must be on either 

side of the path range, otherwise the mirroring will not succeed.  

5.8.5.3 Path Generation 

Generates a volume along the specified 

path. Select "Modeling Tab > Solid Editing 

Panel >  Single-plane Loft >  Path 

Generation ", select the line or plane as cross-

section, then select the path. You can select 

multiple lines as the path line. 

5.8.6 Lathe 

Rotates a 2D entity around an axis to generate a 3D entity. Select "Modeling Tab > Solid Editing Panel >  Lathe", select 

the object to be rotated, line or plane, specify the starting point of the axis. In the command line prompts there are three ways to 

specify the axis. 

1. After specifying the start and end points of the axes, generate entities around the axes at the angles entered.  

2. Press return and pick the line as the axis of rotation. 

3. Enter X, Y, or Z and press Enter to form a rotation axis parallel to a coordinate axis. For example, enter X to specify the X-

axis base point through which a rotation axis parallel to the X-axis is generated following the command line prompt. Using 

the selected axis as an example, the effect is shown in the following figure.  
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Note: A line wrapped around an axis generates a plane, and a plane wrapped around an axis generates a volume. 

5.8.7 Split Entity 

Splits an entity into multiple entities. Select "Modeling Tab > Solid Editing Panel >  Split Entity " and select the plane 

of the object to be split. 

1. Creates a splitting plane directly at the specified 

point. Specifying points and orienting the splitting 

plane to split the volume. 

 

 

2. Enter “S” and press Enter to split the volume with 

the selected split line. 

 

 

 

3. Type “H” and press Enter to draw split lines in 

the same way you would draw a polyline to split 

a volume. 

 

Note: 

① Splitting objects does not support 
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building components. 

② Splitting lines does not support 3D polylines and spirals. 

5.8.8 Union 

Creates a new solid by joining two or more solids. Select "Modeling Tab > Solid Editing Panel >  Union", select multiple 

intersecting entities and perform union operation. 

 

Note: 

① Merging objects supports planes, volumes, buildings, and flower pools.  

② The building and the volume are merged as entities to produce the building. 

③ Entities, other than buildings, must be of the same type to be merged.  

5.8.9 Subtract 

Creates a new solid by subtraction. Select "Modeling Tab ＞ Solid Editing Panel ＞  Subtract " , select the subtracted 

object, then the reference object to perform the subtraction operation. 
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Note: 

① The objects to be subtracted and the reference objects can be planes, volumes, buildings, flower pools and water 

bodies. 

② The newly generated entity attributes after subtraction follow the subtracted object . 

5.8.10 Intersect 

Creates a new solid from overlapping two solids. Select "Modeling Tab > Solid Editing Panel >  Intersect", select two 

intersecting entities and perform the intersection operation. 

 

Note: 

① Intersection object can be planes, bodies, buildings, flower pools and water bodies. 

② The newly generated entity attributes after intersection follows the first object selected.  
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5.9 Generate Panel 

5.9.1 Line/Plane Conversion 

Converts a line whose beginning and end are connected enclosing a closed area into a plane, or converts a plane into a line. 

Select "Modeling Tab > Generate Panel >  Line/Plane Conversion" and select the line or plane to convert. 

 

5.9.2 Polysolid 

Draws or extracts edges on a volume, and stretch them into planes or volumes. Select "Modeling Tab > Generate Panel > 

 Polysolid" item to open the following dialog box. 

 

 

1. Free drawing: Draws line entities freely and stretch them into planes or volumes. Click on the  button to draw a line in 
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the same way as a polyline, right click to end the drawing. After the cursor captures the axis is highlighted in yellow, move 

or enter a value, right click to end, and stretch it into a plane; to stretch it into a volume, continue to move the mouse to 

stretch or enter a value. 

2. Draw along the edge: Draws along the edge of the entity to obtain a line entity, and you can stretch it into a plane or a 

volume. Click on the  button, specify a point on the edge of the entity, move the cursor along the edge, right click to 

end the drawing, and stretch or enter the stretch distance. 

3. Select a building component: Draws along the floor line of a building or component to obtain a line entity, which can be 

stretched into a plane or a volume. Click on the  button, specify a point on the floor line of the building or component, 

and stretch or enter the stretch distance. 

Note: 

① Building components support the selection of balconies, windows, doors, roofs. 

② When picking a point, picking a corner point that is coplanar cannot get the edge. 

4. Select objects: Selects lines, edges of planes, and edges of volumes to stretch them into planes or volumes. Click the  

button, select the object and stretch or enter the stretch distance. 

 

 

 

5.9.3 Extract Single Plane 

Extracts the outline of the specified plane of the entity and generates the plane by the outline. Select "Modeling Tab > Generate 

Panel >  Extract Single Plane" and select the entity you want to extract the plane from. 
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5.9.4 Plane Offset  

Creates plane entities that are equidistant from all sides of the original plane. Select "Modeling Tab > Generate Panel >  

Plane Offset", select the plane to be offset, specify the offset position directly or enter the value to be offset.  

Note: When entering a distance, positive values are shifted outward and negative values are shifted inward. 
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6 View Menu 

This chapter presents a range of commonly utilized 3D viewing tools, which can be employed by the user to fine-tune the 

project's visual impact for optimal results during the design process. 

6.1 Perspective Panel 

6.1.1 Pan 

Moves the position of the view without changing the position or scale of the objects in the drawing.  Press and hold the middle 

mouse wheel enables Pan operation as well. 

6.1.2 Orbit 

Dynamically moves the observer around the model while maintaining the same focus point. Pressing “Ctrl + middle mouse 

wheel” enables orbit view as well. If you have an entity selected and then use this function, the view is rotated with that entity as the 

center point. 

6.1.3 Centering 

Zooms to display the largest extents of all objects. It calculates all extent of objects and the original coordinates of drawings 

will not be modified. Select Centering tool to fix these problems. 

6.1.4 Full View 

Displays all entities in the workspace to the maximum extent possible. Enter “Z” and press Enter at the command line. Enter E 

and press Enter can achieve full map operation as well. 
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6.1.5 Frame Selection 

Maximizes the display of the selected model or structure. Select the " View Tab > Perspective Panel >  Frame Selection" 

item to center the selected object in the view. If there are no selected objects, the effect is the same as in "Full view".  

6.2 3D Navigate Panel 

6.2.1  View Control 

Switches current workspace 3D perspective view from different directions. Click 

on the corresponding blue arrow to set the view direction, and click on the "Flat" button 

in any view, the view will turn to the flat state. 

6.3 View Tools Panel 

6.3.1 Eye View 
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Turn on human eye view perspective. Select "View Tab > View Tools Panel > Eye View", follow the command line prompts, 

set the height offset, and specify the site location. The angle of view will automatically shift to the current eye height, and the default 

is the sum of the site height and the offset height. You can continue to enter values to adjust, and the view will be lowered or raised. 

Press and drag the left button in the scene to view around by human perspective. 

 

Note: 

① Height offset means height of human eye. Height offset + height of site location = final eye height. 

② After designating a position, you can rotate the view by dragging the mouse to browse, or use the arrow keys ↑, ↓, 

←, → on the keyboard to rotate and move the operation. 

6.3.2 Front Face 

Selects the plane on the volume to display its front view. 

6.3.3 Window View 

Maximizes the display of selected area, and enables full display and return to the previous view. Select Window View tool, and 

directly specify a two-point box range to zoom in on the view within that range. At the command line prompt, enter “E” to display 

the full view; enter “P” to return to the previous view. 

6.3.4 Previous View 

Returns to previous view performed. 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 178 of 241 

6.4 Hide Panel 

6.4.1 Hide Selected 

Hides the selected entities. Select "View > View Tools >  Hide Selected" and select the entities to hide. 

 

6.4.2 Hide Unselected 

Hides unselected entities. Select "View > View Tools >  Hide Unselected", select entities, and hide all other entities. 

 

6.4.3 Unhide 

Unhides entities. Select the "View > View Tools >  Unhide" item to display the hidden entities in the view.  
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7 Material Menu 

Material refers to the texture of an object and can be seen as a combination of object material and texture. In rendering programs, 

it is the combination of the various visual properties of the surface, referring to the color, texture, smoothness, transparency, 

reflectivity, refractivity, luminosity, etc. of the surface. 

7.1 Material Panel 

7.1.1 Image 

Automatically calculates the texture of the plane of an entity and attaches the image material to the entity at the appropriate 

size. Select "Material Tab > Material Panel >  Image", the following dialog box will appear. 

  

1. Apply Material 

(1) Single-side: Applies the material on a single side of an entity, and paste a whole material image on one plane. Click 

"Single-sided" button, the cursor will change to a straw, and select the material in the dialog box or pick the material 

of existing entity. 

(2) Layered: Paints materials according to the floor of the building. 

(3) Multifaceted: Paints multiple sides of the entity continuously, and calculate the texture size automatically according 
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to the height. Click "Multi-sided" button, select the material, select the starting plane of the entity.  

(4) Single entity: Paints the material on the entire entity. 

2. Material Adjustment. 

(1) Preview window. 

①  A preview window can be added after double-clicking on the default material in the dialog box or after drawing 

a material on a scene entity. 

②  Right-click on the preview image to reset one or reset all the materials in the preview window, view the path of 

the material, and add the material to the Favorites directory or overwrite the original material with the adjusted 

material. 

 

③  Drag and drop the material to a new preview window to copy the material. 

(2) Material effects: The dialog box is preset with five material effects: standard, glass, metal, wood and dirt, which can 

be selected in the drop-down menu. 
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(3) Parameter adjustment: Adjustment of the 

parameters of the material. Glow is only 

effective at night. 

(4) Color adjustment: Adjusts the color 

parameters of a material, click "Color 

Adjustment" button to open the dialog box 

shown below. 

Users can adjust different color parameters 

like hue, saturation, brightness and contrast. 

After adjusting the parameters, click on the 

"Save" button to save the adjusted parameter 

values and apply them; click "Reset" button to 

restore all parameter values to their default values. 

(5) UV Transformation: Adjusts the UV animation 

rate of the material to make it have dynamic effect. Click the "UV Transform" button. Adjustment of parameters changes 

material effects in real time. 

 

(6) Double-sided display: Checks to display both sides of the entity after painting the material; uncheck to display one 

side of the entity after painting the material. 

(7) Reflection map: Adds a reflection map to the material and adjust the parameters to make the material more realistic.  

(8) Bump map: Adds a bump map to the material to give it a bumpy feel. 

3. Add material. 

(1) Click the right mouse button in the category list to open the context menu, as shown above. 
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① New: New material type. 

② Delete: Deletes the newly created material type. 

③ Edit: Modifies the name of the new material type. 

④ Import: Select the folder and import the folder's material images. 

⑤ Import cpr: Select the cpr format file and import the material. 

⑥ Export cpr: Export the material in the catalog to cpr format 

(2) Right-click on the material image or on a blank space to open a context menu to remove or add materials. 

Note: 

① External images can be in jpg, png, dds formats.  

② You can drag an external image into workspace, select the paint method and object to paint it. 

7.1.2 Material 

Paints the material on the entity with the default texture parameters. Select "Material Tab > Material Panel >  Material" to 

open the following dialog box. 

 

(1) Single-side: Paints a material on a single side of an entity, applying the material to the plane in accordance with the 

default texture. 
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(2) Element: Paints the material on a single element of the attached entity. Only for elements in editable polygons.  

(3) Layered: Paints materials according to the floor of the building. 

(4) Single entity: Paints material on the entire entity. 

(5) Group: Paints material on the entities in a group. 

(6) Multi-select: Selects multiple entities to paint the material at same time. 

(7) Multiolygon: Paints materials onto multiple planes of editable polygon entities.  

7.1.3 Coating 

Paints coating onto entities. Select "Material Tab > Material Panel >  Coating" to bring up the following dialog box. 

 

"Custom colors" are saved in the software, so you can add frequently used colors to "Custom colors" for future use. 

When drawing in colors, the RGB values drawn in can be inaccurate due to ambient light effects. 

7.2 Edit Panel 

7.2.1 Adjust Texture 
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Adjusts the display scale, orientation, and 

position of entity materials. Select "Material Tab > 

Edit Panel >  Adjust Texture " to open the 

following dialog box. 

1. Zoom: Adjusts the scale of material 

textures. 

2. Rotate: Adjusts the orientation of the 

material texture. 

3. Panning: Adjusts the position of the 

material texture. 

4. Face Editing: Modification of the material 

texture of a single side. 

5. Body Editing: Modification of the texture of the same type of material on a single entity. 

6. Modify all: Modifies the textures of all materials of the same type in the scene. 

7. Mirror Horizontal: Mirrors the selected single-sided, single-volume or full material in the horizontal direction.  

8. Mirror Vertical: Mirrors the selected single-sided, single-volume, or full material in the vertical direction. 

Note: You can use the "Material" function if you want to apply an adjusted texture to another entity. 
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7.2.2  Replace Material 

Replaces materials of the same type on multiple or all 

entities in the scene. Select "Material Tab > Edit Panel > 

 Replace Material ". 

1. Multi-select: Replaces the same type of material on 

the selected entity. Click on the "Multi-select" 

button, select the default material or the material of 

the entity on workspace, then select the object to 

replace the material, and finally select the material 

to be replaced. 

2. All: Replace the same type of material on all entities. 

Click on "All" button, select the default material or 

the material that draws the entities on workspace, 

and then select the material to be replaced. 

Note: "Replace Material" only replaces the texture and 

material effect, not the UV of the texture. 

7.2.3 Free Adjustment 

The material textures of the entities are mapped to the 

appropriate projection and adjusted to refine the effect of the project. Select "Material Tab > Edit Panel >  Free Adjustment". 
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1. Material texture projection method. 

(1) Cube Retextures the material of an entity as a rectangle projection. 

(2) Cylinder: Retextures the material of an entity as a cylindrical projection. 

(3) Sphere: Retextures the material of an entity as a spherical projection. 

(4) Plane: Retextures the material of an entity as a planar projection. 

(5) Surface: Retextures the material of an entity as a default projection. 

2. Mirroring. 

(1) Mirror Horizontal: Mirrors in U-direction selected single-sided, multi-sided, single-body or all materials.  
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(2) Mirror Vertical: Mirrors a selected single-sided, multi-sided, single-body or all materials in the V-direction. 

3. Adjustment: 

(1) Single-side: Selects a single plane and adjust the material on the single plane. 

(2) Multifaceted: Selects multiple planes, and adjust the materials on multiple planes. 

(3) Body: Selects a single entity, and adjust the material on the entity. 

(4) All: Selects multiple entities to adjust the materials on all entities. 

4. Parameter adjustment. 

(1) Range: Sets the length, width and height of the edit box. 

(2) Amount: Sets the number of times the material texture is repeated. 

(3) Panning: Sets the offset distance in the UVW direction of the material texture. 

(4) Rotate: Sets the rotation angle in the UVW direction of the material texture. 

(5) Scale: Sets the scale of the material texture in UVW direction. 

Note: 

① Free adjustment does not support the selection of file entities (fbx/skp/osgb models, image maps, matching entities, 

plant entities, skeletal animations). 

② Click on the blue texts to reset the parameters. 

7.2.4 Match Material 

Matches and applies a selected material of existing plane, volume or building to other ones. Select "Material Tab > Edit Panel > 

 Match Material" to pick a material. You can choose the painting method according to the command prompt. There are five 

types of painting methods. 

1. Direct select the entity material to totally match another entity. 

2. Pick a material, type “D” and press Enter to apply the material to a single plane. 

3. Pick a material, type “L” and press Enter to apply the material to a single floor of the building. 

4. Pick a material, type “M” and press Enter to apply the material to multiple entities. 

Note: "Pick Material" not only mimics the texture and material effect, but also mimics the uv of the texture, which is different 

from "Replace Material ". 
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7.2.5 Glass Effect 

Applies glass effect to existing glass component. Select "Material Tab > Edit Panel >  Glass Effect". 

1. Single-select: Click on the glass material to 

apply a glass effect to the selected glass 

component. 

2. Select All: Double-click the glass material to 

apply a glass effect to all glass components. 

Note: Supports the selection of balconies, 

windows, doors, dormer windows, and glass 

curtain walls. The effect can also be applied to 

glass materials on other entities. 

7.2.6 Outside Wall Region 

Zoning of the building's vertical planes and the gables to allow for material painting to refine the project's effect.  Select "Material 

Tab > Edit Panel >  Outside Wall Region". 

1. Horizontal area: Draws horizontal zones. Click the  button to 

specify the starting position or enter “C” on the command line to 

select by floor. 

(1) After specifying start and end points, then follow the command 

line prompts to select another vertical plane. 

(2) To draw by floor, enter “C” and press Enter, specify directly or 

enter the number of floors to determine the starting floor, then 

determine the ending floor, then select other vertical planes as 

prompted on the command line. 

2. Vertical Area: Draws vertical zones. Simply click on the  button 

and follow the command line prompts to specify the start and end positions. 

3. Horizontal Surround: Draws a zone through the floors. Click on the  button to specify the starting position or enter “C” 
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on the command line to select by floor, in the same way as for "Horizontal Area". 

4. Graphic projiction: Defines closed lines or planes as zones or project onto a building to automatically generate zones. 

Clicking on  button and select a plane or closed line will allow the selected object to be projected onto the building to 

generate a zone. 

5. Bring to top: Adjusts the display order of overlapping zones. Click on the  button and select the overlapping zones to 

display the selected zone on top. 

Note: 

① Snap needs to be turned on when drawing zones. 

② Floor Zoning can only be drawn or defined on the above-ground part of a building, and they belong to the building 

and are changed when the building is moved, deleted or copied. 

③ Roofs do not support Floor Zoning for drawing horizontal areas. 

④ For image mapping, the cursor click point must be projected on the building and the selected object must be ≤ 2 

m from the building for the mapping to be successful. 

⑤ Double-click on the Floor Zoning to drag and drop the clip point to edit or press Delete to delete.  

⑥ Double-click on a building to select all zones on it. 

⑦ When the height of a building changes, the zones selected by floor also changes. 

⑧ Checking the Floor Zoning allows modifying the hierarchical relationships in the right-hand property column. 

⑨ Please use the "single-body" paint method when painting the zoned material. 

7.2.7 Material Optimization 

Optimizes and merges same materials. Select "Material Tab > Edit Panel > Material Optimization" to apply this function. 

Use this feature to optimize material efficiency when the scene is large. 

7.2.8 UV Editor 

UV Editor can adjust the textures of model materials. The interface is a 2D space and the UV textures dynamically change with 

related 3D model. While adjusting texture coordinates, if the UV texture is complicated, just execute the Mapping UVs feature  to 

update the 2D texture coordinates of the 3D model, and the curved faces will be cut into proper shells, which are displayed on the 

same plane and available to be exported to other drawing software to apply textures for the 3D model. After that, the UV Edit or also 

supports to perform necessary minor adjustments.  
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Select "Material > Edit Panel >  UV Editor", and the following window will pop up: 

 

7.2.8.1 State 

Switches texture border display, shades UV shells, and toggles whether textures are shown in UV Editor. Select "UV Editor > 

State", and the dropdown menu will be as follows: 

1. Texture Borders: Toggle display of texture borders on UV shells. If on, 

the borders will be shown in yellow highlight. 

2. Distortion Shader: Determine the stretched or compressed areas by 

coloring the shell. Red means stretched, and green means compressed. 

The darker the red, the more stretched, and vice versa. White means normal. 

3. Image: Toggle whether to show textures in UV Editor. 

7.2.8.2 UV Snapshot 

Exports the current UV images to external files. Select "UV Editor > UV Snapshot", and the following dialogue will pop up: 
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Parameter Description: 

1. File name: Set the name and save path of the current UV images. Click  button, enter a file name, and specify a file 

location. 

2. Size (pixel): Set the size of current UV maps. 

3. Color Value: Set the border color of UV maps. 

After setting these parameters, click Confirm to export. 

Note: 

① Exporting cannot be done if no models are selected. 

② Under point, line, or UV vertex mode, the entire model in the UV editor will be exported even if only partial is selected; 

under poly, ele, or UV shell mode, only selected part will be exported. 

7.2.8.3 Mapping UVs 

Mapping includes automatic, planar, spherical, and cylindrical mapping. Select the appropriate mapping method based on the 

general shape of the model. Select "UV Editor > Mapping UVs", and the following dialogue will pop up: 
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Parameter Description: 

1. Automatic UV： 

Automatic UV tries to find the best UV placement by projecting from multiple planes. It creates UV coordinates for the 

selected object or polygon, with the default being six projection planes. Click the dropdown button to select the number of 

projection planes and set projection plane parameters to affect the result of automatic UV mapping. The more projection 

planes, the fewer stretched and compressed planes there are. As shown below:  

 

When using automatic UV mapping, the 3D view will display projection planes, gizmo, and rotation axis relative to the 

screen with the selected object in the center, as shown below: 
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(1) Projection planes are blues planes with an opacity of 60%. Each border of a projection plane is displayed in either 

red or green, corresponding to the UV coordinate axes, the axes of the viewport of the mapped model.  

(2) The gizmo can be moved, rotated, and scaled to adjust the bounding box of the 3D model to change the mapping 

result. 

① Move: Put the cursor on the axis, axial plane or axial center of the gizmo. When the gizmo is highlighted in 

yellow, hold down left mouse button to drag. 

② Rotate: Click on the rotation axis relative to the screen to activate. Put the cursor on any rotation axis, and 

when the axis is highlighted in yellow, hold down left mouse button to drag. 

③ Scale: Click on the cube at the end of the axes and put the cursor on a cube. When the cube is highlighted in 

yellow, hold down left mouse button to drag. 

2. Planar UV 

Use planar UV to create UV texture coordinates for the selected object. The default is the X-axis. Click to select X, Y, or Z axis 

and generate a projection plane based on that axis, as shown below:  
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When using planar UV, the border will be shown with the selected object as the center in the 3D view, as shown below:  

 

(1) The border frame is shown in "田" shape. Move and scale the border frame to change the width to height ratio in the 

mapped result to avoid distortion. 

① Move: Put the cursor on the cube at the center of the border frame. When the cube is highlighted in yellow, 

hold down left mouse button to drag. 

② Scale: Put the cursor on the corner or the midpoint of an edge. When the point is highlighted in yellow, hold 

down left mouse button to drag. 

(2) Click the intersecting lines on the frame to activate gizmo and rotation axes relative to screen. Click again to hide 
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them. See Automatic UV for detailed instructions on gizmo and rotation axes. 

3. Spherical UV 

Use spherical UV to create UV texture coordinates for the selected object. This projection loops around the mesh. It's 

best used for completed closed spheres without holes. The effect is shown below:  

 

When using spherical UV, the bounding frame will be shown in the 3D view with the selected object in the center, as 

shown below: 

 

 

(1) There are cubes of different colors on the bounding circles which can be used to adjust the position and size of the 

bounding circles. 

① Green cube: Put the cursor on the green cube, and when it's highlighted, hold down left mouse button to drag 
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the cube and the bounding circle will be changed along the local Z axis. 

② Red cube: Put the cursor on the red cube, and when it's highlighted, hold down left mouse button to drag the 

cube and the bounding circle will be changed along the local X axis. 

③ Blue cube in the center: Put the cursor on the blue cube in the center of the bounding circle, and when it's 

highlighted, hold down left mouse button to change the scaling of the bounding circle.  

④ Blue circle: Put the cursor on the blue circle, and when it's highlighted, hold down left mouse button to change 

the rotation of the bounding circle. 

(2) Click on the cubes on intersecting lines to activate gizmo and rotation axes relative to screen. Click again to hide 

them. See Automatic UV for detailed instructions on gizmo and rotation axes. 

4. Cylindrical UV 

Use cylindrical UV to create texture coordinates for the selected object. This projection loops around the mesh. It's best 

used for completed closed cylinders without holes. The effect is shown below: 

 

When using spherical UV, the bounding frame will be shown in the 3D scene with the selected object in the center, as 

shown below: 
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(1) There are cubes of different colors on the bounding circles which can be used to adjust the position and size of the 

bounding circles. 

① Green cube: Puts the cursor on the green cube, and when it's highlighted, hold down left mouse button to 

drag the cube and the bounding circle will be changed along the local Z axis. 

② Red cube: Puts the cursor on the red cube, and when it's highlighted, hold down left mouse button to drag 

the cube and the bounding circle will be changed along the local X axis. 

③ Blue cube in the center: Puts the cursor on the blue cube in the center of the bounding circle, and when it's 

highlighted, hold down left mouse button to change the scaling of the bounding circle.  

④ Blue cube connected to the center: Puts the cursor on the blue cube, and when it's highlighted, hold down 

left mouse button to change the rotation of the bounding circle.  

(2) Click on the intersecting lines to activate gizmo and rotation axes relative to screen. Click again to hide them. See 

Automatic UV for detailed instructions on gizmo and rotation axes. 

7.2.8.4 Cut 

Separates UV along selected edge to create UV borders. Select "UV editor > Cut", put the cursor on the edge to be cut, and 

when the edge is highlighted in white, hold down left mouse button and hover over it. 

Note: 

① The cut function can be used in the UV view and the 3D view. 

② Before the cut command is finished, the selected cutting line is green by default. Hover over the green line and it will 

be sewed. 
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7.2.8.5 Sew 

Sews the UV along selected edge to sew two separated lines together. Select "UV editor > Sew", put the cursor on the edge 

to be sewn, and when the edge is highlighted in white, hold down left mouse button and hover over it.  

Note: When the cursor hovers over sewn edges, the sewing is done automatically. 

7.2.8.6 Unfold 

Unfold UV along cut lines. By unfolding the UV onto a 2D space, texture drawing can be easily done and applied to the model.  

Select "UV Editor > Unfold", and select the model to unfold. 

Note: UV make up the UV grid, similar to how vertices make up polygon meshes. The unfolding process is like cutting a piece 

of cloth and laying it on top of a table. 

7.2.8.7 Layout 

Automatically arranges the UV shells to maximize the space utilization from 0 to 1. It can also set the size of UV shells.  Select 

"UV Editor > Layout", and the dropdown menu is shown below:  

 

1. Layout Along: Automatically arrange the UV shells to maximize the space utilization from 0 to 1. Click Layout Along and the 

following dialogue will pop up: 

 

(1) Texture Map Size (pixel): Set the resolution in UV space to calculate the pixel filling value. 

(2) Shell Padding: Set the pixel gaps between UV shells. 
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(3) Preserve 3D Ratios: Toggles the shells will be scaled according to their corresponding area on the 3D model; 

untoggled: the shells will be scaled according to the size of the shells after unfolding.  

After setting the parameters, click Apply to get the layout. Click Reset to reset to default. 

2. Texel Density: Sets the size of UV shells by specifying the amount of texels included per unit. Click Texel Density and the 

following dialogue will pop up: 

 

After setting the density, click Get to show the texel density of selected part; click Set to scale the UV shell to fit the 

specified texel density. 

7.2.8.8 Tool 

The texture borders may be unable to be detected for unfolded external models imported to this software. Or models made with 

this software might sometimes be unable to show the texture borders. You can solve the issue by using the Refresh Shell command. 
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Select "UV Editor > Tool", and the dropdown menu is shown below: 

1. Refresh Shell: Gets the texture borders of UV shells. 

2. Orient to Edges: Selects an edge on the shell as reference, rotate this 

edge to make it parallel to the u axis or v axis to adjust the direction of 

the shell. The rotation direction can be set by the angle between the 

selected edge and the u or v axis. Normally the rotation direction is toward the side with the smaller angle. If the angle is 

exactly 45 degrees the direction will be on the u axis. 

Note: Orient to Edges can only be used under the line mode. 

7.2.8.9 Status Bar 

Before entering a sub-mode, the default state does not allow edit ing in the unfolded model view. Click a button on the status 

bar to enter editing mode. Different buttons correspond to different editing objects.  

1. Point: After clicking  button, only points can be selected in the editor, and the shared points of which are selected at 

the same time automatically. 

2. Line: After clicking  button, only lines can be selected in the editor, and the shared lines of which are selected at the 

same time automatically. 

3. Polygon: After clicking  button, only polygons can be selected in the editor. 

4. Element: After clicking  button, only elements can be selected in the editor. 

5. UV Vertex: Used alongside Point. Click  button, and point button  is automatically selected. Select points in the 3D 

view and all corresponding UV vertices in the editor are selected as well. And the shared points of the selected points in th e 

editor won’t be selected automatically. 

6. UV Shell: The button cannot be used by itself. It must be used in conjunction with the Point, Line, or Poly button. After 

clicking  button and anyone of the Point, Line or Poly button, and select part of the model in the editor, which will be 

shown in points, lines, or polygons. 

7. UV Symmetry: Make another part with a symmetry relationship in the UV view to get the same change as the selected part. 

For example, after making the modification of source objects, clicking the  button, selecting the source objects and 

right click, a bold symmetric line appears, you can select the bold symmetric lines or hold down Ctrl while dragging with 
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the left mouse button to adjust the position of the bold axis vertically and horizontally to determines where the symmetric 

shell is placed in the UV Editor workspace. Then， specify the symmetric plane in the 3D entity and right-click. 

 

8. Symmetrize: This option is for models that have a symmetry relationship in the 3D view. After selecting the symmetry axis, 

a part of the model is selected and the symmetric part of the model is also selected at the same time. You can click the 

dropdown button to select the axis, and then operate in the editor. 

9. Material: The checkboard is the default material of the software, mainly used to check whether the UV shells are stretched. 

Additionally, the material information will also be shown in the dropdown list.  

Note: When entering point, line, or element mode in the editor, select a point/line/UV shell, and the corresponding 

point/line/UV shell in the 3D view will also be selected. 

7.2.8.10 Toolbar 

1. Move: Clicking the  button, in addition to selecting an entity in the UV Editor window for the move operation, you can 

also select an entity in the 3D view for the move, which corresponds to the Move command in the advanced modeling. The 

object is moved in the following ways. 

(1) Move directly, click on an object and drag the mouse directly to move the object.  
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(2) Select and move. Add the object to be moved to the selection set first, and move it by specifying the reference point 

in the selection set as the base point. 

 

(3) Right-click the Move button and set the move distance of the selected object in the pop-up window. 
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The direction of movement is determined by the mouse and the current reference coordinate system. 2D coordinate 

system is displayed in the UV Editor window, the object can only move in 2D plane, it has linkage with the advanced modeling 

interface movement. To restrict the object to move in the X or Y axis, click directly on the axis to temporarily lock the 

corresponding axis, you can also use the "constraint" related commands in the advanced modeling window to lock the axis. 

2. Rotate: Clicking the  button, in addition to selecting an entity in the UV Editor window for the rotate operation, you can 

also select an entity in the 3D view for the rotate, which corresponds to the Rotate command in the advanced modeling. 

The object is rotated in the following ways. 

(1) Direct rotation, click on an object and drag the mouse directly to rotate the object. 
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(2) Select and rotate, the object to be rotated is first added to the selection set and rotated by specifying the reference 

point in the selection set as the base point. 

 

(3) Right-click the Rotate button and set the rotation angle of the selected object in the pop-up window. 

 

The direction of rotation is determined by the mouse and the current reference coordinate system; the UV Editor window shows 

a 2D coordinate system, the object can only be rotated in the 2D plane, it has a linkage with the rotation of the advanced modeling 

interface. To restrict the object to rotate in the X or Y axis, click directly on the axis to temporarily lock the corresponding axis, you 

can also use the "constraint" related commands in the advanced modeling window to lock the axis. 
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3. Scale: Click the  button, select an object, in addition to selecting an entity in the UV Editor window for the scale operation, 

you can also select an entity in the 3D view for the scale, which corresponds to the Scale command in the advanced 

modeling. The object is scaled in the following ways. 

(1) Direct scaling, click on an object and drag the mouse directly to scale the object. 

 

(2) Select and scale, the object to be scaled is first added to the selection set and scaled by specifying the reference 

point in the selection set as the base point.  

 

(3) Right-click the “Scale” button and set the zoom scale of the selected object in the pop-up window. 
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The direction of scaling is determined by the mouse and the current reference coordinate system; the UV Editor window 

shows a 2D coordinate system, and the object can only be scaled in the 2D plane, which is linked to the scaling of the advanced 

modeling interface. To restrict the object to scale in the X or Y axis, click directly on the axis to temporarily lock the 

corresponding axis, you can also use the "constraint" related commands in the advanced modeling window to lock the axis. 

4. Ring Select: Click on the  button, set the interval, select an object, and appropriate lines will be selected.  

5. Loop Select: Click on the  button, set the interval, select an object, and appropriate lines will be selected. 

6. Target Select: Click on the  button, hold down left button, and hover over points to select them. 

7. Borders: Click on the  button, select an object, right click to select points, lines, polygons, and UV vertices on the 

outermost ring of the UV shell. 

7.3 Display Panel 

7.3.1 Backface Cull 

The Backface Cull command determines whether the back faces of polygon planes are culled and not displayed. Select 

"Material Tab > Display Panel >  Backface Cull" to apply this function. The direction the polygon normal faces determines 

whether it is displayed when Backface Cull is enabled. 
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Polygons that are facing away from the viewport or polygons that are inside of an object and facing the viewport are not 

displayed, if you click the Backface Cull feature again, they can be displayed again. 
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8 Scene Menu 

In the process of planning and designing a project, the layout of the scene is particularly important. It reflects the style and 

design effect of the final plan, and also reflects the scenery ability and aesthetics of the designer. This chapter talks about the creation 

of roads and site entities, the arrangement of background entities, and the insertion of skeletal animation elements, so that  the user 

can flexibly use the functions when arranging the scene and make the project present a delicate and realistic effect. 

8.1 Road 

8.1.1 Urban Road 

Urban roads are the main traffic routes in the city or outside residential neighborhoods. Houseplan 1.0 provides templates for 

urban roads to facilitate quick drawing. Select "Scene Tab > Road Panel >  Urban Road" to open the following dialog box. 

 

1. Draw urban roads: Select the lane type and set the parameters in the dialog box, click "Confirm" button, and then draw 

directly at the specified point in the sceneMATERIAL Can be drawn continuously; enter “U” to go back to the previous step 

and right-click to end the drawing. 

2. Line to Road: Import or draw the line entity representing the road in the scene, select the lane type and set the parameters 
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in the dialog box, click "Confirm" button, enter C in the command line, select the line and right click to finish. The selected 

line entity will be converted to an urban road. 

3. Parameter Description: In the dialog box, switch the Tab page to select the lane type (e.g., "two-lane roads"), set the sidewalk 

width, lane width, separation width, and other parameters. "Total width" is calculated automatically according to the width 

of the sidewalk, etc. In the right side, check the sidewalk to be displayed and set  the color, single and double lines and 

dashed line style of the sidewalk. If you want to set a different width, you can modify the value below separately. 

Note: 

① When drawing a curved road, "tangent arc" means the section of the arc road is tangent to the previous section of the 

road, "convex arc" means the ends of the arc road are drawn before specifying their radius, and "three-point arc" 

means the specifying second and third points of the arc in sequence to generate the arc road. 

② When a road is drawn with a turning point, a range of arc radius is given based on the angle between two roads, with 

the default arc radius being the width of the road. 

③ When roads that are drawn and converted from lines cross, the road surface and pavement and other components are 

automatically fused. When road segments are moved or deleted, the roadway with which they were originally fused 

also automatically handles the boundaries. 

④ For roads that are drawn and converted from lines, they are made up of individual sections and road corners, requiring 

all sections to be selected for overall movement. 

⑤ For roads that are drawn and converted from lines, after selecting a road section, drag the midpoint to move the road 

section, and drag the start and end points to change the position of their ends. Dragging will snap to the height of 

the target point, e.g., if the road has a start elevation of 10, if the start is dragged to the 0 plane, the start elevation 

will also change to 0. 

⑥ Fillet: Refers to the curved sharp corner of the road surface generated between intersecting roads. The corner is 

selected and its radius can be changed by setting it in the property palette or by dragging and dropping the edit point. 

⑦ In the property column: 

➢ Click on the type to switch to another type of road. When switching back to urban roads, the pavement width 

needs to be set manually. 

➢ Width and area exclude sidewalks. 

➢ It's possible to modify the start and end elevations to give the road a three-dimensional form. 

➢ Plasticity affects the size of the triangular mesh calculated inside the road. The smaller the value, the more 

detailed the road rendering will be, but the performance will also be greatly reduced. A suitable plasticity value 
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can be set as appropriate. 

8.1.2 Residential Street 

Residential roads refer to the main access roads in an area dominated by residential buildings, and this function is used to 

map or quickly generate residential roads by converting lines. Select " Scene Tab > Road Panel >  Residential Street" to draw 

a road or convert the road according to the command line prompt. 

1. Draw residential roads: You can draw a curved road according to the command line: input “A” to draw as "tangent arc", input 

“B” to draw as "convex arc", input “C” to draw as "three-point arc". Can be drawn continuously; enter “U” to go back to the 

previous step and right-click to end the drawing. 

2. Line to Road: Imports or draws the line entity representing the road in the scene, select the lane type and set the parameters 

in the dialog box, click "Confirm" button, enter C in the command line, select the line and right click to finish. The selected 

line entity will be converted to a residential street. 

Note: The property palette allows you to modify information about parameters such as type, width, starting point elevation, 

endpoint elevation, curbstone width, length, area, shapable etc. 

8.1.3 Edit Road 

8.1.3.1 Rounded Corner 

Generates rounded sections of both roads. Select "Scene Tab > Road Panel >  Edit Road >  Rounded Corner", 

according to the command line prompts, select two road sections and specify or enter the turn radius. You can connect two sections 

of the road to generate rounded corners. 

 

Note: 

① Cannot round corners on parallel sections. 
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② The maximum turning radius is automatically calculated based on the angle between the two roads, and the default 

radius is generated by the width of the road. 

8.1.3.2 Extend Road 

Uses the road a line as the boundary so that the selected road extends to the boundary. Select "Scene Tab > Road Panel > 

 Edit Road >  Extend Road", according to the command line prompts, first select the road section or line to be used as the 

boundary , and then select the road section to be extended. You can extend the selected road to the boundary. 

 

Note: When selecting an extension section, the cursor must point at the end closer to the boundary, otherwise the extension 

fails. 

8.1.3.3 Fillet 

Modifies the turning radius of the two connecting roads. Select "Scene Tab > Road Panel >  Edit Road >  Fillet", 

according to the command line prompts, 

respectively select the road on the two 

connected straight edge, enter or use cursor to 

specify the radius of the arc. 

Note: Drawing a road requires that the 

straight edge of the road on the same side 

of two connected sections be selected and 

that the two sections must blend. 

8.2 Facilities Panel 
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8.2.1 Building Area 

Building area refers to the area that can be used for building plans, this feature is used to draw and define the building area. 

Select " Scene Tab > Facilities Panel ＞  Building Area" and there are two ways to generate it. 

1. Draw the building area directly by draw polylines. 

2. Enter D and press Enter to select the horizontal plane or closed line and define it as building area.  

8.2.2 Greening 

8.2.2.1 Flower Pool 

A flower pool is a fenced area for raising flowers and planting trees, a small structure enclosed by brick masonry or concret e 

structure for planting flowers or shrubs. The pool is filled with planting soil and provided with drainage holes; its height generally 

does not exceed 600 millimeters. This feature is used to draw and define flower pools. 

Select "Scene Tab > Facilities Panel >  Greening >  Flower Pool" and there are three ways to generate it. 

1. Directly drawing the flower pool in the same way as a polygon.  

2. Enter “S” and press Enter to draw the flower pool in the same way that a three-dimensional polygon is drawn. 

3. Enter “D” and press Enter to select the plane or closed line, and define it as flower pool. 

Note: The property palette on the right side of the screen allows you to adjust the parameters for the height and side width of 

the planter. 

8.2.2.2 Hedge 

Hedge, also known as wall tree or trellis, a tree or other plant that grows prostrate in patches along a wall or trellis, also refers 

to the wall or trellis to which such a tree is attached. This function is used to draw and define hedges. 

Select "Scene Tab > Facilities Panel >  Greening >  Hedge", enter values to determine the width and height of 

the hedge respectively, there are three ways to generate. 

1. Draw hedges directly by drawing polylines. 

2. Enter “D” and press Enter, select a line and define it as a hedge. 

3. To draw a hedge along a line, enter “Y” and press Enter and follow the command line prompts to draw it. 

Note: The parameters for the height and width of the hedge can be adjusted in the properties bar on the right. 

8.2.3 Water 
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A volume of water is one of the recurring elements in a landscape setting. This function is used to draw and define a water 

surface or pool. 

Select "Scene Tab > Facilities Panel >  Water" to open the dialog box shown below. 

 

1. Drawing water surface: click on the  button and there are three ways to generate it. 

(1) Drawing the water surface in the same way that polygons are drawn. 

(2) Enter “D”, press Enter and select the horizontal plane, horizontal closed line, and define as a water surface.  To auto-

generate a water surface, enter “Z” and press Enter, select the entity that you want to auto-generate the water surface, 

and specify it directly or enter the height value to enter. 

Note: 

① Automatic generation is generally used to generate water surfaces in low-lying areas of the terrain. 

② The entities that support automatic water surface generation are terrain, planes, and roads. 

2. Draw pools: See "Draw water surface" for more details. 
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3. Paint: Click  button, select the type of water volume in the dialog box (clear water, pond, lake, still water and sea), you 

can paint to the water volume, plane or any other entity. Right click in the scene, you can also draw the water volume 

material, paint to the water volume, etc. 

Parameter Description: 

1. Map reflection: Water reflections according to a preset map. 

2. Real time reflection: Water surface reflections in accordance with the actual environment. 

3. Water surface color: Sets the color of the water. 

4. Specular color: Add a specular map to the water surface. 

5. Smoothness: Controls the degree of smoothness of the material when exposed to light. 

6. Specular level: Controls the level of specular brightness. 

7. Reflection intensity: The magnitude of the reflection effect; the higher the value, the stronger the reflection effect. 

8. Fresnel offset: The reflectance of the surface directly facing the viewer (or incident light); this value is lower for water 

materials. 

9. Fresnel index: Decay of the Fresnel curve. 

10. Water speed: The rate at which water flows. 

11. Water ripple ratio: Controls the proportion of the water ripple tiling, the higher the value the denser the water ripple.  

12. Ripple height: Sets the ripple height of the water surface. 

13. Opacity: Sets the opacity of the water surface. 

8.2.4 Steps 

8.2.4.1 Stairs Along Lines 

Along Line Steps are steps that are generated along existing outlines. This function is used to define steps.  

Select "Scene Tab > Facilities Panel >  Steps >  Stairs Along Lines", first enter the value to determine the number 

of steps and the width of the top plane of the steps, then set whether to generate steps at both ends, select a line or a point on the 

edge of the entity, directly specify or enter a value to determine the length of the step; if you want to close the steps along the edge 

of the entity, enter “C” and press Enter. 

Note: The width of the top plane of the steps is the width of the topmost step. 

8.2.4.2 Fixed Position Stairs 
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In-Place Steps are custom generated steps based on an existing outline. This function is used to define steps. Select "Scene 

Tab > Facilities Panel >  Steps >  Fixed Position Stairs", select the side of the plane to generate steps, and enter the 

value to determine the number of steps to be generated. 

Note: 

① The edges of a plane generating a step may be multiple edges. 

② When the distance from the building is less than 0.2 m, the "Step in place" is automatically associated with the 

building. 

8.2.5 Fence 

A fence is architecturally a heavily rectilinear spatial partition structure used to enclose, divide or protect an area, generally 

enclosing the wall of a building volume. Select "Scene Tab > Facilities Panel >  Fence". 

1. Bounding wall 

(1) Click  button to draw 

the fence in a direct 

polyline. 

 

(2) Click  button to select 

a line as the fence. 

 

(3) Select the fence type and 

click  button to select 

and change the fence 

type. 

 

(4) Fence Height: Click on the 

drop-down arrow or enter 

a value directly to change the fence height. 
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2. Gate: Switches to the Gate Tab, just double click or drag the selected gate type and place it in the scene.  

 

8.3 Environment Panel 

8.3.1 Label 

Turns on/off the labels of particles and lights for easy selection of particles, lights entities. Select "Scene Tab > Environment 

Panel >  Label" to turn/off the labels of particles and light entities. Please close the tab when publishing effects and recording 

roaming videos to avoid affecting the effect. 

8.3.2 Particle Entity 

Adds dynamic fountains, smoke, vapor, and other particle entities to the scene to complete the scenario effect.  Select "Scene 

Tab > Environment Panel >  Particle Entity". 
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1. Place entity: Double-click on a particle entity in the gallery or drag it directly on workspace. 

2. To edit an entity library: Right-click on the list of entity categories: 

(1) New: Creates a new particle entity category. 

(2) Delete: Deletes the newly created particle entity. 

(3) Clear: Removes all newly added particle entities in the selected category. 

(4) Edit: Renames the newly created particle entity category. 

3. Add: Right-click on a blank space in the library window, click "Add" and select particle entity in workspace to add it. 

4. Delete: Right-click on the thumbnail and click "Delete" to delete the added particle entity. 

5. Parameter Description: 

(1) Particle amount: The higher the value of the parameter, the greater the number and density. 

(2) Particle lifetime: The time the particle exists, the higher the value the lower the particle density and the longer the 

particle exists. 

(3) Initial speed: The higher the value, the faster the speed. 

(4) Acceleration: There are three values representing the velocity of xyz in three directions, the larger the value the faster 

the velocity, for example: with an x-axis velocity of 5 and a y-axis z-axis velocity of 0, the particle is deflected in the 

x-axis direction. 

(5) Initial scale: Refers to the size of the particle at the beginning, the larger the value the larger the particle. 

(6) Final scale: The size at the end of the particles' lifetime. 
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8.3.3 Light Entity 

Add spotlights, floodlights, and other lighting entities to the scene to complete the effect.  Select "Scene Tab > Environment 

Panel >  Light Entity" to open the dialog box shown below. 

 

1. Place entity: Double-click on a light entity in the gallery or drag it directly on workspace. 

2. To edit an entity library: Right-click on the list of entity categories: 

(1) New: Creates a new light entity category. 

(2) Delete: Deletes the newly created light entity. 

(3) Clear: Removes all newly added light entities in the selected category. 

(4) Edit: Renames the newly created light entity category. 

3. Add: Right-click on a blank space in the library window, click "Add" and select light entity in workspace to add it. 

4. Delete: Right-click on the thumbnail and click "Delete" to delete the added light entity. 

5. Spotlights parameters description: 

(1) Activation: Double-click to activate or deactivate. 

(2) Radius: The size of the light range. 

(3) Direction: Direction of light. 

(4) Light cone: The greater the value the greater the range of light radiation. 

(5) Attenuation: The higher the value the lighter is concentrated. 
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(6) Light intensity: The higher the value the brighter the light. 

(7) Specular intensity: The higher the value the stronger the highlight. 

6. Floodlights parameters description: 

(1) Activation: Double-click to activate or deactivate. 

(2) Radius: The size of the light range. 

(3) Light intensity: The higher the value the brighter the light. 

(4) Specular intensity: The higher the value the stronger the highlight. 

7. There is no lighting effect during the day, and the lights turn on automatically at night. 

8.3.4 Scene Entity 

Adds different types of components as exterior design. Select "Scene Tab > Environment Panel >  Scene Entity" to open 

the dialog box shown below. 

 

1. Place entity. 

(1) Direct placement: Double-click on a model in the gallery or drag it directly on workspace. 

(2) Place along the line: Selects the model, click  button and place the entities equally spaced between the specified 

start and end points. 
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(3) Place along the object: Selects the model, click  button. If you select a road, you can arrange along the road; if 

you select water volume, you need to select a point as the starting point of entity arrangement to place along the 

water volume. 

(4) Select Layout: Selects the model and click  button to place the entities along the road in three ways. 

① Enter “C” and select "Urban Road" for the equal-spacing placement of entities. 

② Enter “Q” and select "Residential Road" for the equal-spacing placement of entities. 

③ Enter “Z” to simultaneously select both "Urban Road" and "Residential Road" and place entities with equal 

spacing. 

Note: 

① Previews that appear in grey in the gallery will automatically download if clicked. They can be placed in the 

scene when they are downloaded. 

② Margin distance refers to the horizontal distance of the starting point of the arrangement from the beginning of 

the road or water volume. As shown in the figure below.  

 

2. To edit an entity library: Right-click on the list of entity categories: 

(1) New: Creates a new model category. 

(2) Delete: Deletes the newly created model. 

(3) Clear: Removes all newly added models in the selected category. 

(4) Edit: Renames the newly created model category. 
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3. Adding objects: Right-click on a blank space in the library window, click "Add Object" and select a model in workspace to 

add it. 

4. Add File: Right-click on the blank space in the library 

window and click "Add File", the following dialog box 

will pop up. After selecting the cpi or fbx file, click the 

"Open" button to add the selected file. 

5. Delete model: Right-click on the thumbnail and click 

"Delete" to delete the newly added model. 

8.3.5 Vegetation Entity 

Adds vegetation entities to the scene to refine the scene. Select "Scene Tab > Environment Panel >  Vegetation Entity" 

to open the dialog box shown below.  

 

1. Place entity. 

(1) Direct placement: Double-click on a model in the gallery or drag it directly on workspace. 

(2) Place along the line: Select the model, click  button and place the entities equally spaced between the specified 

start and end points. 
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(3) Place along the object: Select the model, click  button. If you select a road, you can arrange along the road; if 

you select water volume, you need to select a point as the starting point of entity arrangement to place along the 

water volume. 

(4) Select Layout: Select the model and click  button to place the entities along the road in three ways. 

① Enter “C” and select "Urban Road" for the equal-spacing placement of entities. 

② Enter “Q” and select "Residential Road" for the equal-spacing placement of entities. 

③ Enter “Z” to simultaneously select both "Urban Road" and "Residential Road" and place entities with equal 

spacing. 

Note: 

① Previews that appear in grey in the gallery will automatically download if clicked. They can be placed in the 

scene when they are downloaded. 

② Margin distance refers to the horizontal distance of the starting point of the arrangement from the beginning of 

the road or water volume.  

2. To edit an entity library: Right-click on the list of entity libraries: 

(1) New: Creates a new model category. 

(2) Delete: Deletes the newly created model. 

(3) Clear: Removes all newly added models in the selected category. 

(4) Edit: Renames the newly created model category. 

3. Add object: Right-click on a blank space in the library window, click "Add Object" and select a model in workspace to add 

it. 

4. Add File: Right-click on the blank space in the library 

window and click "Add File", the following dialog box 

will pop up. After selecting the cpi or fbx file, click the 

"Open" button to add the selected file. 

5. Delete model: Right-click on the thumbnail and click 

"Delete" to delete the newly added model. 

8.3.6 Environment 

Applies weather, lighting and fog effects in the environment. Select "Scene Tab > Environment Panel >  Environment". 
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1. Weather: Double-click on a weather image to apply the corresponding weather effects. 

2. Lighting: Click on "lighting" and the dialog box will look as follows. 

 

(1) Show shadows: Check “show shadows” and “show shadow effects” in the scene. 

(2) Enter a value in the text box or drag the slider to adjust the azimuth and altitude angle parameters of the sun. When 

shadows are on, adjusting the azimuth and altitude will affect the effect of the shadows.  

3. Effect Parameters: Click on "Effect Parameters" and the dialog box will look like this: 
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Solar, ambient, fog effect, volumetric light and HDR parameters can be modified separately to enhance the ambient 

effect. 

(1) Sun 

① Sun Color: Sun color, which can be drawn directly from the color panel. 

② Sunshine Color: Sunshine color, which can be drawn directly from the color panel. 

③ Intensity: The intensity of the sun's rays on the ground (higher the value, stronger intensity). 

(2) Environment 

① Environment Color: The environment, and the color of objects in the environment 

② Intensity: The intensity of the color (higher the value, stronger intensity). 

③ Light-blocking intensity: The intensity of the shadow at the angle between objects (higher the value, stronger 

intensity). 

④ Radius of light blocking: The size of the shadow area at the angle between objects (larger the value, larger 

area). 

(3) Fog Effect 
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① Color: Applies fog color. 

② Intensity: The density of the fog in the part of the sky (higher the value, denser the fog). 

③ Density: The density of the overall fog (higher the value, denser the fog). 

(4) Volumetric Light 

① Color: Volumetric light color. 

② Weight: The proportion of the color of the volume light. When the weight is 0, the color of the volumetric light 

will be displayed completely, the larger the weight value, the smaller the proportion of the color of the volume 

light setting. 

③ Intensity: Controls the sun's halo and light, the higher the value, the stronger the halo and light.  

④ Attenuation: Controls the intensity of sunlight reaching the ground; the smaller the value, the stronger the light 

reaching the ground. 

(5) HDR 

① HDR: High dynamic range. 

4. Night vision settings: Click on " Night vision settings " and the dialog box will look like this: 

 

The lighting category, lighting rate and brightness can be modified separately to adjust the lighting effect in night mode.  
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(1) Light up type: Controls the lighting status of the corresponding category in the scene. 

(2) Lighting rate: Controls the number of entities lit in the scene. The higher the value of the lighting rate, the more 

entities are lit, and vice versa. 

(3) Brightness: Only affects the brightness of the lit solid material. 

8.3.7 Optimization 

Sets anti-aliasing, visual balance, and arc 

segments to adjust the entity effects in workspace. 

Greater values are not necessarily better. Select 

"Scenes Tab > Environment Panel >  

Optimization". 

1. Anti-aliasing 

Removes jagged display and aliasing to make the view smoother and prettier. Set the value of anti-aliasing and click 

"Apply". The Anti-aliasing button on the right bottom corner can turn this effect on or off as well, as shown below:  

 

2. Visual Balance 

Simplifies surface details of entities to reduce the geometrical complexity of a scene while not affecting the visual effects. 

Set a value to increase the performance of the scene without losing noticeable graphic details.  Drag the slider or enter a value 

to change the LOD display distance. Entities farther away will be displayed in simpler models or not rendered at all; entities 

close to the viewpoint will be displayed in detailed models.  

Note: During drawing, if imported drawings are not visible, it could be that the imported drawing is too big and the 

viewpoint is too far away. Increase the value of LOD and the drawing should display normally.  

3. Arc Segments 

Sets the display effect of arcs and curved planes. Drag the slider or enter a value directly to adjust the number of segments. 

The smaller the value, the fewer the segments, and the more efficient the rendering; the greater the value, the more detailed  

the arcing effect, but the performance will be lower. 

Note: Arc segments affect the following entities: 

① Line: Sphere, arc, ellipse, elliptical arc. 
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② Edge: The edge of planes and volumes that contain sphere, arc, ellipse, or elliptical arc. 

③ Curved plane: Individual curved plane entity or curved plane on volumes. In other words, all non-flat planes are 

affected. 

8.4 Animation Panel 

8.4.1 Skeletal Animation 

Adds animated objects to the scene to add animation effects. Select "Scene > Animation Panel >  Skeletal Animation" 

to open the following dialog box. 

 

1. Apply the animated entity: 

(1) Select the animated entity, set the moving speed and insertion height; 

(2) Double-click the animated entity model or drag it to the scene to insert it. 

2、 Edit the animation entity library:  
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         When right click the animation library 

entity list: 

(1) New: Creates a new skeletal 

animation entity category; 

(2) Delete: Deletes the newly created 

skeleton animation category; 

(3) Empty: Empties all the newly 

added skeleton animation entities in 

the selected skeleton animation 

category; 

(4) Edit: Renames the newly created 

skeleton category; 

(5) Import: Selects the folder and import the fbx file in the folder. 

3. Add models: 

(1) Add file: Right click on the blank space of the right part of the window, click the "Add File", and then select fbx file 

in the pop-up dialog box. 

(2) Delete: Right click on the model and click "Delete" to delete the newly added model. 

 

8.4.2 Play Animation 

Plays the animation or stop playing the animation according to the set path. Select "Scene Tab > Animation Panel >  

Play Animation" to start or stop playing the movie. 

8.4.3 Wavy Path 

Adds undulating paths to animated entities, generated when drawing based on the height of the specified point.  Select "Scene 

Tab > Animation Panel >  Wavy Path", select the animated entity, and draw the undulation path. 

Note: 

① If there is no control point for snapping in the scene, the drawn path is a horizontal path, and you need to click the 

"Edit Path" command to modify the control point, see "Edit Path" for the specific operation. 



Houseplan 1.0 Make stunning 3D scheme with speed and ease 

Page 229 of 241 

② The property palette allows you to adjust parameters such as frequency of the animated entity, whether it moves itself, 

whether it follows the path, the path speed, whether the movement mode is single or circular and whether it casts a 

shadow. 

8.4.4 Edit Path 

Edits the drawn animation path. Select "Scene Tab > Animation Panel >  Edit Path" to open the dialog box shown below. 

1. Selection: Click  button to select the animated entity or click on the name of the animated entity on the left side of the 

dialog box to display its path and control points in the scene and its control points and height on the right side of the 

dialog box. 

2. Undulating Path: Click  button to draw 

undulating paths. 

3. Move: Click  button and select the control 

point to move. 

4. Delete: Click  button to delete the 

selected control point. 

5. Right-click on the name of the animated entity 

on the left side of the dialog box to open the 

context menu; 

(1) Delete animation: Deletes the selected 

animated entity and its path. 

(2) Clear path: Removes the animation path 

of the selected entity. 

Note: 

① It is not permitted to delete or move the first control point. 

② Double click on the blue text "height", and all points below the selected row will be modified to the height value of 

the selected row. 

8.4.5 Erase Path 
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Clears the defined animation path. Select "Scene Tab > Animation Panel >  Erase Path" and select the entity you want 

to delete the animation path from. 

8.4.6 Show Path 

Shows or hides the defined animation path. Select "Scene Tab > Animation Panel >  Show Path" to show or hide the 

defined animation path. 
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9 Video Menu 

To facilitate users to experience the real 3D model world, Houseplan 1.0 outputs HD video based on the real environment path 

to show the effect of the design dynamically in all aspects. 

9.1 Path Panel 

9.1.1 Draw Path 

Draws roam path in the scene. Select "Video Tab > Path Panel >  Draw Path" to draw a path in the scene. 

Note: 

① The drawing is captured in three dimensions. 

② After drawing a path, when drawing it again, continue along the last path by default. 

③ If you want to redraw it, you can click on "Delete path" command and draw it again. 

④ If the previous path needs to be saved, save it in the "Video Highlights" before clearing the path. 

⑤ If the drawn path line is not saved in "Video Highlights", the path line information will not be recorded, and the path 

will be lost when the file is opened again. 

9.1.2 Grounded Path 

Draws video paths that adhere to the ground in the scene, enabling video to undulate with the ground automatically when 

roaming. Select "Video Tab > Path Panel >  Grounded Path" to draw a path in the scene. 

Note: 

① The ground includes the earth, the terrain and the roads. 

② When there is a superposition of ground entities, the path falls on the higher entity. 

③ When the two paths are drawn by switching between them, the drawn path is generated in the same way as the 

newly drawn path. 

9.1.3 Edit Path 

Edits the current roaming path. Select "Video Tab > Path Panel >  Edit Path" and the following dialog box will appear. 
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1. Control Point Parameters: Click on an item in the dialog box to modify it. 

(1) Camera height: The height of the camera when roaming to that point, either by entering the value directly, or by 

dragging the right slider to change it. 

(2) Height Angle, Azimuth: Seta horizontal and vertical viewpoint when roaming, click the drop-down list and select 

"Pick", you can use the selected point in the scene as the viewpoint. After that, select the control point, you can 

modify the coordinates of the point at the top of the "Enter Viewpoint". 

(3) Velocity: Speed at which the roaming is running. 

(4) Angular velocity: Speed at which the camera turns, which needs to be increased to match if the camera is going 

too fast. 

(5) Blue Font: Select a value and double-click the blue font above the column to change all the values below to the 

same value as that item. 

2. Clicking  button to move the selected control point and allow capturing. 

3. Click the  button to delete the selected control point. 

4. Clicking  button to move the selected control point horizontally without changing the height of the control point.  

5. Click the  button to add control points to the path line. 

Note: Grounded paths do not support panning. 

9.1.4 Delete Path 

Deletes the currently drawn roaming path. Select "Video Tab> Path Panel >  Delete Path" to automatically clear the 
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roaming path in the scene. 

9.2 Video Panel 

9.2.1 Roaming Operation 

Implement roaming effects and generate roaming videos. Select "Video Tab> Video Panel >  Roaming Operation" to 

open the following dialog box. 

 

1. Click on the  button to open the dialog box shown below. 

(1) Click on "Detailed Parameters" to open the "Edit Path" dialog box, refer to the "Edit Path" item for details. 

(2) Select "Temporary Parameters" and the dialog 

box will to Confirm like this. 

① Moving speed: Enter the speed at which 

the viewpoint moves when roaming. 

② Path height: Enter the horizontal height of 

the roaming viewpoint. 

③ View: Select the camera view, which 

contains five options: Front, Overlook, 

Look up, Left, and Right. 

(3) Video Size: Sets the size of the generated video. 

Select "Custom" in the drop-down list to open 

the dialog box shown below. 
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Enter width and height dimensions and click "ok" button 

to add it to the video size list. 

Note: The larger the size, the larger the file generated. 

Considering that saving data to the hard disk takes up 

system resources and affects the recording process, 

please choose the right size according to your 

computer performance. 

(4) Video quality: Sets the video quality, including High, 

Medium, and Low. After setting the parameters, click on the "Confirm" button to roam according to the settings.  

2. Click on the  button to start roaming through the scene according to the drawn path and its parameters.  

3. Click on the  button to stop roaming. 

4. Click on the  button to pause the roaming and click again to continue the roaming. 

5. Click the  button, set the save path and file name and then start roaming and record the roaming process as *. mp4, *. 

mkv, *. mov format files. 

9.2.2 Roam Path List 

Saves the current roam path or apply a saved roam path. Select "Video Tab > Video Panel >  Roam Path List" to open 

the following dialog box. 

 

1. Save path: Enter the path name and click the "Save" button to save the current drawn path. 

2. Apply path: Double-click on the line where the path is located in the dialog box to invoke the path. 

3. Context menu: Right-click in the list to open the "Context menu", you can delete or rename the path. 
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4. Click on the  button to set the path roaming parameters. 

5. Click on the   button to start roaming through the scene according to the drawn path and its parameters.  

6. Click on the  button to stop roaming. 

7. Click on the  button to pause the roaming and click again to continue the roaming. 

8. Click the  button, set the save path and file name and then start roaming and record the roaming process as *.mp4, 

*.mkv, *.mov format files. 

Note: 

① Modified paths require a click on “Save” to update the path to the latest. 

② When saving a path to a video set, the ambient weather is also recorded in the path information. 

9.3 Camera View Panel 

9.3.1 Camera View List 

Saves the viewpoints in the scenario for quick positioning. Select "Video Tab > Camera View Panel >  Camera View 

List", the following dialog box will pop up. 

 

Enter the viewpoint name and click  button to save the current viewpoint to the list. Check the viewpoint and click  

button to export the viewpoint to local in image format. Right-click on the viewpoint name to open the context menu, which allows 
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you to rename, delete and delete all the viewpoints. You can also remove the viewpoint all together by right-clicking in the blank 

space of the dialog box. 
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10 Others 

Houseplan 1.0 provides some common tools and shortcuts to help users categorize and manage entities in the process of 

designing solutions in an organized and efficient manner. 

10.1 Graphic Class Control 

When designing entities or elements, you can use the layer control 

function for easy operation management. Click  button to open the 

dialog box shown below.  

Click on each item to close or open the class, layer and background. 

For example, click on the "Close the selected class" button to select the 

entity to be closed. For example, if you select a building, you can turn off 

the main volume of the building and the balcony and other components. 

Note: You can also click on the top of the software to have control 

over the graph class layers, as shown in the following image. 

 

① Click on the checkbox  in front of a class or  in front of a layer to turn a single class/layers on or off. 

② Double-click the checkbox  in front of the category to close all categories. Double-click again on  to open all 

categories. 

③ Classes and layers are linked. For example, if you close the class on the left, the corresponding layer on the right 

closes with it. 
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10.2 Right-Click Context Menu 

If you right-click on the workspace, a context menu will pop up 

with the following commands; Last command, Orbit, Eye View, Full 

View, Frame Selection, Pan, View Control, Previous View, Front Face, 

Window View, Polyline, Rectangle, Polygon, Box, Extrude Building, 

General Extrude, Copy, Move, Rotate, Erase, Hide Selected, Hide 

Unselected, Unhide. 

For more operation details, see the description of each of these 

commands above in this guide. 

10.3 Orthogonal 

Restricts the operation to horizontal or vertical orientation. 

1. Click on  button at the below the command line to turn the orthogonal function on/off. 

2. Right click on  button to open the context menu, as shown below. 

(1) Conventional: Switches to the normal orthogonal orientation. 

(2) User Orthogonal: Switches to the user orthogonal direction. There 

are three methods of access. 

① Direct selection of solid edges, as orthogonal directions.  

② Angles may be entered as orthogonal directions, as prompted on the command line. 

③ Enter “D” to specify two points and plot the orthogonal direction, and “C” to clear the defined orthogonal 

direction and return to the default state. 

Note: Set user orthogonal, i.e., re-designate the direction of the positive half-axis of X-axis. In some project drawings, 

the orientation of land, roads and other entities is not according to the default XY axis direction of the system, so 

for the convenience of drawing, you can define your own orthogonal direction. 

10.4 Polar Axis 

During drawing and editing, you can turn on the polar axis to easily obtain capture points in the X-, Y-, or Z-axis direction. 

10.5 Snap 
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When drawing or editing, you can turn on the snapping function to assist in the operation for precise positioning.  

1. Click the  button below the command line or press the F3 key to turn snapping on or off. 

2. Right-click on  button to open the context menu, as shown below. 

 

Select "Settings" option to open the dialog box shown below. 

You can set snapping options, where "plane" refers to the surface of 

a plane or solid. 

Click the "Select All" button to check all the boxes; click the "Confirm" 

button to apply the settings. 

Note: When snapping to the circle center of an arc, you need to 

hover the cursor over the edge line to display the center of the 

circle. 

10.6 Follow 

Displays distances and angles at the mouse pointing position when 

drawing and editing objects. Click  button at the bottom of the 

command line to turn the follow function on/off. The angle displayed is the angle with the positive half-axis of the X-axis. 

10.7 Reference 

When drawing and editing objects, a temporary extension line, vertical line, or a polar axis through an entity's endpoint, 

midpoint, or other capture points is displayed as a dashed line when the cursor passes over that point, so that the user can specify 

a point at the extension line or capture the intersection of multiple reference lines. Click  button at the bottom of the 

command line to turn the reference function on/off. The reference is based on snapping and requires snapping to be on in order to 

use it. 
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10.8 Isometric 

Switches the design environment to isometric mode. Click the Isometric button in the bottom right corner to turn the feature 

on, and click it again to turn it off. As shown in the figure below. 

 

10.9 Perspective 

Switches the design environment to Perspective projection. Click the Perspective button in the bottom right corner to turn on 

the feature, and click it again to turn it off. As shown in the image below. 

 

10.10 Shadow 

Simulates the shadow shading effect of the project. Click the Shadow button in the bottom right corner to turn the feature on, 

and click it again to turn it off. As shown in the image below.  

 

10.11 Anti-Aliasing 

Jaggies are eliminated and the edges of the image are softened to make the edges of the image look smoother and closer to 

the physical object. Click the light blocking button in the bottom right corner to turn on the feature, and click it again to turn it off. 

As shown in the figure below. 

 

10.12 Light Projection 

Ambient light masking, which depicts the effect of blocking out surrounding diffuse light when objects and objects intersect 
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or are close together. Click the Light Projection button in the bottom right corner to turn on the feature, and click it again to turn it 

off. As shown in the figure below. 
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